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PhotoFiltre Overview

The interface
PhotoFiltre is a very complete image editing software. It allows you to make simple or
advanced adjustments to an image and apply a wide range of filters to it.

1. The menu bar
The menu bar contains all of the PhotoFiltre commands grouped by category.
2. The toolbar
The toolbar is on two levels. The first level provides quick access to the most common
functions. The second level mainly offers quick access to the main functions and setting
filters. This level is also called the filter bar and it can be hidden to free up space in the
work area.
See also chapter The Toolbar .
3. The color palette
The color palette lets you select foreground and background colors. These colors are
used for drawing and some filters.
See also chapter The color palette .
4. The workspace
The workspace is the area in which open images are displayed. Each open image

contains a layer bar on its left side. The number of open images can be limited by the
memory available to your computer.
5. The tool palette
The tool palette contains tools for working with PhotoFiltre . It includes selection tools,
drawing tools and retouching tools.
See also chapter The Tool Palette .
6. The status bar
The status bar (or status bar) displays information about the general state of PhotoFiltre
and some information about the active image. It consists of four parts.

A. Activity in progress
This part indicates the activity or actions in progress. If there is no activity, PhotoFiltre
displays the word Ready . If there is a long process to complete, PhotoFiltre displays
[Processing in progress]. A progress bar and a percentage are visible to follow the
evolution of the activity.
- Progress bar

The progress bar appears 1 to 3 seconds after the start of the treatment, to avoid its
display in short treatments. In complex cases, the progress bar can be restarted several
times in the same process.
During long treatments, avoid using the mouse, keyboard, or switching
between applications, as progress may freeze and display problems may occur. It
is therefore advisable to let PhotoFiltre finish the current treatment!
B. Dimensions and color mode
This part displays the dimensions and color mode of the active image.
The information is displayed as follows:
[Width] x [Height] [Color Mode]
- [Width] indicates the width of the image in pixels
- [Height] indicates the height of the image in pixels
- [Color Mode] indicates the color mode of the image, ie:
. x2 for monochrome mode
. x16 for the 16-color indexed mode
. x256 for 256 indexed color mode
. x16M for 16 million RGB color mode
. (Alpha) for RGBBA mode (Alpha layer)

For example, for an 800x600 pixel image in RGB color mode, PhotoFiltre displays
800x600x16M .
C. Position of the mouse cursor
When the mouse cursor is on an open image, this part displays the position (in pixels) of
the cursor. The value [X] indicates the horizontal position, and [Y] indicates the vertical
position. These values are relative to the pixel of the image (origin) located at the top left.
If the mouse cursor is not on an open image, this part remains empty.
D. Information about the selection, the layer, and the name of the image file
This part displays information depending on the context.
1. If a selection is in progress, this part contains information about the selection. This
information is represented as follows:
X1: Y1 => X2: Y2 (L = V1 H = V2 L / H = V3)
- [X1: Y1] indicates the position in pixels of the point at the top left of the selection
- [X2: Y2] indicates the position in pixels of the point at the bottom right of the selection
- [V1] corresponds to the width in pixels of the selection
- [V2] corresponds to the height in pixels of the selection
- [V3] corresponds to the ratio between the width and the height of the selection
2. If the [Layer Manager] tool is enabled, this part contains information about the active
layer. This information is represented as follows:
X1: Y1 => X2: Y2 (L = V1 H = V2)
- [X1: Y1] indicates the position in pixels of the point at the top left of the layer
- [X2: Y2] indicates the position in pixels of the point at the bottom right of the layer
- [V1] is the width in pixels of the layer
- [V2] corresponds to the height in pixels of the layer
3. In all other cases, this part displays the location and file name of the active image.

Displaying images
• Arrange windows
Each open image is displayed in a window in the work area. The list of open windows is
available in the [Window] menu. The number of open images can be limited by the
memory available to your computer.
See the Opening an Image chapter for more information on opening images.
You can rearrange the window display using one of the following methods:
- click on the [Window> Arrange All] menu to stack the cascading windows
- click on the menu [Window> Horizontal Mosaic] or [Window> Vertical Mosaic] to
rearrange the windows edge-to-edge
- click on the [Window> Collapse All] menu to reduce all icon images
- click on the [Window> Restore all] menu to restore the window sizes

To close windows, use one of the following methods:
- click on the [File> Close] menu to close the active window
- click on the [File> Close All] menu to close all windows.
• The display zoom
PhotoFiltre offers several commands to enlarge or reduce the display of an image. The
zoom factor is displayed at any time in the toolbar as an edit box with a button with an
arrow. By clicking on the arrow, you can choose a display zoom between 10% (1:10) and
1600% (16: 1).
Example of displaying an image with a zoom of 100%
After zooming, the position of the image window is retained. Pressing the [Ctrl]
key during zoom execution reposition the image window at the top left of the
workspace.
Using the zoom in a batch of images organized horizontally or vertically does
not change the size of the image windows. If the [Ctrl] key is used with zoom, the
image will be repositioned at the top left of the PhotoFiltre workspace.
It is possible to activate or not the smoothing of the screen display via the
[Display> Smooth] menu. It is strongly recommended to disable it when working
on large images to increase the display speed. Smoothing turns off automatically
if a zoom greater than 100% is used.
1. To enlarge the display of an image, you can:
- click on the icon
in the toolbar
- click on the menu [View> Zoom In]
- press the [+] key
- select a higher magnification factor in the zoom edit box
- position the cursor of the mouse in the image then move the wheel of the mouse
towards the bottom
2. To reduce the display of an image, you can:
- click on the icon
in the toolbar
- click on the menu [View> Zoom out]
- push the button [-]
- select a smaller magnification factor in the zoom edit box
- position the cursor of the mouse in the image then move the wheel of the mouse
upward
3. To display a full size image, you can:
- click on the icon
in the toolbar
- click on the menu [View> actual size]
- press the [=] key
- select [100%] in the zoom editing area
4. To display an image with an automatic zoom, that is, so that it is fully visible in the
window, you can:
- click on the icon
in the toolbar

- click on the menu [View> Automatic Zoom]
- push the button [*]
- select [<Auto>] in the zoom editing area
- click on the image with the mouse wheel
5. To display an image in full screen, you can:
- click on the icon
in the toolbar
- click on the menu [View> Full Screen]
- press the [Ctrl + F] keys

Navigate the image folder
When an image is open, you can navigate in its folder to display:
- the next image with the [Next Page] key
- the previous image with the [Page Up] key
- the first image of the folder with the [Home] key
- the last image of the folder with the [End] key
Navigation also works in full screen mode.

Use the tracking grid
The registration grid makes it possible to align selections and layers more precisely. It
also makes it possible to find one's way when drawing or resizing.

Display example with a marker grid.
To show or hide the cue grid, click the [View> Cue Marker] menu.
To change the grid settings, use the [Tools> Preferences] command and select the [Tool
Palette and Grid] page.
See the Customize PhotoFiltre chapter for more information on setting the grid.

The properties of an image
• The information displayed
To view the properties of the active image, you can:
- click on the menu [File> Image Properties]
- press the [Ctrl + J] keys
PhotoFiltre displays the following information in the [Image] tab:
- Image name
- File location folder
- Dimensions in pixels, cm or inches, resolution (for JPEG format, this information is

taken in EXIF metadata, if present)
- Number of colors used by the image
- File size
- Date and time of modification
- Size in memory
- Total size in memory with history
If the image contains EXIF, IPTC or Comment data, these are displayed in the
corresponding tabs.
It is possible to export the properties of the image into a text file.
• The comment
In the [Comment] tab, you can enter your own comment on one or more lines.

Property of the [Comment] tab
The [OK] button
The button becomes accessible from the moment you start typing your text. Pressing the
button preserves your input while using the file. The comment will definitely be taken into
account when saving the file.
Only PFI, JPEG, GIF, and PNG formats retain the comment when saving.

Shortcut menus and keyboard shortcuts
• Context menus
In addition to the menus located at the top of the screen, the contextual menus display
commands according to the context and the type of active element (image, selection,
layer, layer bar, ...).
To use a context menu:
1. Place the mouse cursor on an image or an element (selection, layer, ...)
2. Right-click the mouse
• Keyboard shortcuts

A keyboard shortcut allows you to quickly execute a command without using a menu, by
pressing a key or key sequence.
For example, by pressing [Ctrl + O], PhotoFiltre starts the command to open an image.
Most keyboard shortcuts appear in the menus to the right of the command.
See the chapter Keyboard shortcuts for a complete list.

Cancel and restore an operation
PhotoFiltre stores the state of an image before applying a change. This makes it
possible, in case of error, to cancel most of the operations performed. You can also
restore the last saved version of an image. The number of stored operations depends on
the setting of the history.
1. To cancel the last operation you performed, you can:
- click on the menu [Edit> Undo <command name>]
- click on the icon in the toolbar
- press the [Ctrl + Z] keys
2. To restore the last operation performed, you can:
- click on the menu [Edit> Redo <command name>]
- click on the icon in the toolbar
- press the [Ctrl + Y] keys
3. To restore the last saved version, click the [File> Reset] menu.
4. In some cases (filters, settings, fill, drawing ...), you can partially cancel the last
operation to attenuate the effects. To use the attenuation function, you can:
- click on the menu [Edit> Mute <command name>]
- press [Shift + Ctrl + Z]
To change the number of histories per image, use the [Tools> Preferences] command
and select the [Histories] page.
See the Customize PhotoFiltre chapter for more information on setting history.
To purge the logs assigned to open images, and thus free up memory space,
click the [Edit> Purge> Logs] menu.

Open an image

use
The purpose of the [Open] command is to open an image file and display it in the
PhotoFiltre work area. The number of open images can be limited by the memory
available to your computer.
1. Open the Windows dialog box to select an image file:
- use the menu [File> Open]
- press the [Ctrl + O] keys
- click on the icon
in the toolbar
- use the context menu (right click on the workspace then [Open])
2. Locate the folder containing the image file you want to open. PhotoFiltre is positioned
in the current opening folder and displays the list of files present. By default, the most
common images are displayed. In the [Type Files] area, you can select a particular file
type.
3. Click the image file that you want to open. If the [Preview] box is checked, the
selected image will be displayed as a thumbnail in the panel on the right side of the
dialog and the main properties of the image:
- width and height in pixels
- the color mode or the type of image
- transparency (if present, with Windows XP and higher)
- the size of the image file
- the date of last modification of the image
- if the image has EXIF data ( with Windows XP and higher):
. the camera builder
. the model of the camera
. the shooting date of the image
4. Confirm to close the dialog and open the image file. PhotoFiltre creates a new window
in the workspace to display the image. The title of the window is the short name of the
image file.

Properties of the opening dialog box (with Windows XP).
Up to 20 image files can be opened in one operation.
With Windows XP and higher versions , the dialog is resizable.
With Windows XP and higher , PhotoFiltre memorizes the different display
modes of the files offered by the dialog box.

Special features when opening an image
Depending on the color mode and transparency of the open image, some PhotoFiltre
features are disabled.
See also chapter Color modes and transparency .
• Indexed color mode (from 1 to 8 bits)
To recognize an image in indexed color mode:
- the [Image> Mode> Indexed Colors] command is checked
- the icon is accessible in the toolbar
- the icon is accessible in the toolbar
In this mode, the following features are disabled:
- the commands of the [Settings] menu
- the commands in the [Filters] menu
- the commands of the [Layer] menu
- collage functions
- the filter bar
- the tools of drawing of the palette of tools, except the tool [Eraser] in case of
transparency
Indexed color mode image files can be PNG, GIF, BMP, RLE, TIFF, Targa, and PFI
types.
With this mode, you can use a simple type of transparency and save your result

in GIF and PNG.
• RGB color mode
To recognize an image in RGB color mode:
- [Image> Mode> RGB color] command is checked
- the icon is accessible in the toolbar
- the icon is grayed out in the toolbar
If the image is transparent, the following features are disabled:
- the commands of the [Settings] menu
- the commands in the [Filters] menu
- most menu commands [Layer]
- collage functions
- the filter bar
- the drawing tools of the tool palette, with the exception of the [Eraser] tool
If the image is not transparent, all PhotoFiltre features are enabled.
RGB color image files can be of any type except for GIF and RLE.
This mode is recommended for all touch-up operations and filter application.
This is the native mode of PhotoFiltre .
With this mode, you can use a simple type transparency and save your result in
PNG.
• RGBBA mode (Alpha layer)
To recognize an image in RGBA mode with Alpha layer:
- the [Image> Mode> RGBBA (Alpha Layer)] command is checked
- the icon is grayed out in the toolbar
- the icon is accessible in the toolbar
In this mode, the majority of PhotoFiltre controls are accessible.
RGBBA image files can be PNG, BMP, Targa, TIFF, and PFI types.
With this mode, you can use alpha layer transparency.
• The multilayered images
Some files may contain layered images, that is, images composed of a background layer
and at least one other superimposed layer. This is the case of PFI format images or
animated GIFs. For animated GIFs, PhotoFiltre creates as many layers as there are
images in the animation.
In case of a layered image, access to PhotoFiltre's controls depends on the type of layer
selected.
See also Layers overview .

Enable Paste, Adjustment, and Filter Controls
Under certain conditions, gluing, adjustment and filter commands are not accessible.
This lock may be due to the color mode of the image or transparency.
• Cancel transparency
If the image is transparent, use the [Image> Transparency Color] menu or click on the
icon in the toolbar, and then check the [Disable transparency] check box in the setting
window.
• Force RGB color mode
If the image is in indexed color mode, it must be converted to RGB color mode. Use the
[Image> Mode> RGB Colors] menu or click on the icon in the toolbar.

Create a new image

use
The purpose of the [New] command is to create a new image by defining its physical
properties. By default, the image is composed only of a background layer (background).
To create a new image, you can:
- use the menu [File> New]
- press the [Ctrl + N] keys
- click on the icon in the toolbar
- use the context menu (right click on the workspace and then [New])

New command properties

Size in pixels / Memory
Here we find the indications of the width and height of the image to be created. When
you first launch PhotoFiltre , the default value for width and height is [800x600]. Then,
the command retains the parameters that have been modified.
The memory is a value calculated by PhotoFiltre which indicates the place that will be
taken into memory by the new image.
For example, an image in 800 x 600 in 24 bits will occupy:
800 x 600 x 3/1024/1024 = 1.37 MB

New size
This group of parameters and options makes it possible to modify the physical or logical
properties of the image.
• The [Width] and [Height] settings

These settings allow you to manually change the width and height of the image. You can
specify a size in pixels, cm, or inches. The sizes in pixels are called physical, because
they are not related to the resolution whereas the sizes in cm or in inches are said
logical, because they are calculated according to the resolution. Changing the size
automatically updates the value of the Memory setting.
The [Width] and [Height] settings are saved when you exit PhotoFiltre .
The default unit can be customized via the [Tools> Preferences> Defaults]
command.
See the Customize PhotoFiltre chapter for more information about customizing these
values.
• The [Resolution] setting
The resolution indicates the number of pixels over a certain length. This is defined in dpi
(dot per inch) or dpi (dots per inch). A resolution in inches (1 inch = 2.54 cm) or cm can
be indicated. Implicitly the resolution is 72 dpi. The resolution is especially important for
printing, the higher it is, the better the print quality.
The [Resolution] setting is saved when you exit PhotoFiltre .
• The [Background] setting
This parameter is used to fill the background with a particular color. White is the default
color.
• The option [Background pattern]
It allows to apply a pattern to the bottom. Check the box and choose in the search box
the reason. The motif has priority over the substance. In the case of a transparent
pattern, it will reveal the background color at the transparent areas.
• The list of predefined sizes
This size list allows you to create a new image with predefined dimensions and
resolution. Here is the list of the different values proposed by PhotoFiltre :
Custom sizes

<Custom>
Allows you to manually define dimensions in
entering the width, height and resolution

Screen sizes
unit: pixels
resolution: 72 dpi

640x480
800x600
1024 x 768
1280 x 1024
1600x1200

Paper sizes
unit: cm
resolution: 200 dpi

A4 (21 x 29.7) in portrait mode
A4 (29.7 x 21) in landscape mode
B5 (18.2 x 25.7) in portrait mode
B5 (25.7 x 18.2) in landscape mode

Photo formats
unit: cm
resolution: 300 dpi

Photo (silver standard)
Digital photo
Post card

CD sleeve
unit: cm
resolution: 200 dpi

CD cover - Face (12 x 12)
CD sleeve - Back (13.8 x 11.8)

DVD sleeve format Standard DVD sleeve (27.3 x 18.3)
unit: cm
resolution: 200 dpi
DVD formats
unit: pixels
resolution: 72 dpi

NTSC DVD (720x480)
DVD PAL / SECAL (720x576)

You can use the [File> Image Properties] command or the [CTRL + J] keyboard
shortcut to control the dimensions of the image you just created.

Automatic transparency
If the box is checked, the new image is fully transparent and the RGBA mode is
activated (Alpha layer). If the box is unchecked, the new image is created with the
[Background] and [Background] settings. This box is unchecked by default.

The toolbar
Presentation
The toolbar is on two levels. The first level provides quick access to the most common
functions, such as opening and saving an image, color modes, image size, or display zoom. The
second level mainly offers quick access to the main functions and setting filters. It includes, for
example, automatic corrections, brightness and contrast adjustments, or sharpening. This level
is also called the filter bar and it can be hidden using the [View> Filter Bar] menu to free up
space in the work area.

Description of the buttons

1. New document
2. Open an image
3. Saves the current image
4. Save the image under another name
5. Prints the current image
6. Launches the Twain acquisition module
7. Undo the last action
8. Repeat the last action
9. Copy to the clipboard
10. Paste as a layer
11. Glue as a picture
12. Force RGB Mode
13. Force indexed color mode
14. Sets the transparency of the image
15. Size of the image
16. Size of the work area
17. Shows / Hides the selection
18. Inserting a text layer
19. Launches the Vector Trace module
20. Show / Hide Image Explorer
21. Launches the automation module
22. Displays the preferences window
23. Direct access to the display zoom
24. Zoom in
25. Zoom out
26. Displays the image in real size
27. Adjust the image on the screen
28. Displays the image in full screen

29. Brightness (-)
30. Brightness (+)
31. Contrast (-)
32. Contrast (+)
33. Gamma correction (-)
34. Gamma correction (+)
35. Saturation (-)
36. Saturation (+)
37. Histogram
38. Custom setting
39. White balance
40. Automatic levels
41. Automatic contrast
42. Forces the image in gray level
43. Forces the image in sepia tones
44. Old photographic effect
45. Applies a dustproof effect
46. Softens the image
47. Applies a blur
48. Relief softened
49. Clearer
50. Strengthening
51. Variation of hue
52. Applies a gradient
53. Launches the PhotoMasque module
54. Horizontal symmetry
55. Vertical symmetry
56. Rotate 90 ° to the left
57. Rotate 90 ° to the right

The color palette

Using colors
PhotoFiltre uses foreground color to draw or surround shapes and background color to
fill in shapes and erased areas of an image. Foreground and background colors are also
used by some filters.

Selecting foreground and background colors
The grid mode is the default mode, but it is possible to obtain several color gradients by
clicking on the two bottom buttons (left arrow and right arrow).

The principle of color selection is always the same, we click with the mouse on a color
with the left button to change the color of foreground or with the right button to change
the background color.
You can also click with the mouse on the boxes at the top left to display the Windows
color selection box that allows you to enter the RGB and TSL values. After validation, the
color of the panel will be updated.

Windows color selection box
A color can be defined by components:
- RGB = Components Red, Green, Blue
- HSL (= HSL) = Hue, Saturation, Brightness

Invert foreground and background colors
To invert the foreground and background colors, click the color swap icon

at the top

of the color palette.

Reset foreground and background colors
To reset the foreground and background colors, click the default colors icon
at the
top of the color palette. PhotoFiltre changes the foreground color to black and the
background color to white.
By activating the [Eyedropper] tool, you can see the RGB values of the color in
HTML format.

Select a color in a command
Some commands need one or more colors to work. This is the case of some filters and
effects or filling functions. PhotoFiltre , provides an input area consisting of a colored
rectangle (which defines the current color) and a button.
If you left-click inside the colored rectangle, PhotoFiltre displays the Windows color
selection box. After validation, the color is updated and the rectangle reflects the new
color.
If you click the arrow button, PhotoFiltre provides a list of predefined colors as a grid.
The first color in the list is the foreground color. Select a color from this list to update the
color.

At the top, the input area with the colored rectangle and the button.
Below, the list of predefined colors and the foreground color.

The tool palette

Presentation
The tool palette consists of three main parts.
1. The color palette
It allows to select the foreground and background color
either by clicking with the mouse on the boxes at the top left,
or by clicking on one of the colors of the grid with the left
button (foreground color) or right (background color).
2. Work tools
It allows you to select the working tool from:
- selection tools (shapes, magic wand)
- drawing tools (brushes, line, airbrush, ...)
- retouching tools (blur, finger, red eye, ...)
- the tool [Pipette]
- the tool [Displacement]
- the [Layer Manager] tool
- the tool [Distort]
- the tool [Nozzle]
3. The options of the work tool
This part is dynamic, it changes according to the working tool
in progress. In our example, it corresponds to the Selection
tool and proposes the predefined shapes and basic
manipulations on the selections.

List of tools

1. Selection
2. Layer Manager
3. Traveling
4. Pipette
5. Magic wand
6. Line
7. Filling
8. Airbrush

9. Eraser
10. Brush
11. Advanced Brush
12. Cloning buffer
13. Blur
14. Finger
15. Retouching
16. Deformation
17. Art Brush
18. Nozzle

Position of the tool palette
You can position the tool palette in different places in the workspace.
Photofiltre offers three modes.
• Floating pallet
In this mode, you can position the Tool Palette anywhere on your desktop. This one will
always be visible, because it stays above the other windows of the application. Its
position will be kept the next time PhotoFiltre is opened.
If your screen has a definition of 800x600, it is advisable to use this mode in
order to display all the properties of the tools.
• Left alignment
The tool palette is docked to the left of the workspace. It takes the form of a toolbar and
it can not be moved.
• Right alignment
The tool palette is docked to the right of the workspace. It takes the form of a toolbar and
it can not be moved.
You can customize the position of the Tool Palette using the [Tools>
Preferences> Tool Palette and Grid] command.
See the Customize PhotoFiltre chapter for more information on positioning the Tool
Palette.

Work with selections

Definition
When you create a selection, you temporarily protect a part of the image so that only the
portion included in the selection is changed. It can be compared to a stencil. The
modifiable part corresponds to the pierced part of the stencil while the non-modifiable
part corresponds to the solid part of the stencil. A selection is materialized by a dotted
outline. You can move a selection, copy it, fill it, apply a filter, an effect, or use the
drawing tools.
A selection is called vector when it is calculated dynamically with each change of size.
Thus, there is no loss, because we can find the original selection by simply knowing its
shape and dimensions. Magic Wand selections are distorted with each size change. If
the deformation is too important, we will not find the basic shape even if it gives back its
original dimensions. PhotoFiltre handles both types of selection.
The animation of the selection can be deactivated for the current image via the
[Selection> Options> Animate selection] function.

Vector selections
Select a shape by clicking the button representing it in the tool palette or by activating it
in the [Select> Change Shape] menu.
• The predefined forms
They are composed of basic forms:
- Rectangle
- Ellipse
- rounded corners (low, medium, high)
- Diamond
- Triangles
Click in the image with the left mouse button and drag the cursor until the selected area
has the desired size. As the mouse moves, a dotted shape appears to indicate the
outline of the current selection. Release the mouse button and the selection outline
becomes flashing.
By checking the function [Selection> Options> Mode> Dilate], the selection is
drawn around the starting point.
By holding down the [Shift] key while moving, you get a shape whose width is
always equal to the height (Square with a Rectangle shape, Circle with an Ellipse
shape, ...).
• Rectangular shapes with ratio

If the image is empty of selection, clicking on one of these buttons creates a selection:
- Square
- Report Rectangle [4: 3]
- Rectangle ratio [3: 2]
The selection is centered in the image. The size of this one is calculated by applying the
ratio to the size of the image.
• The [Polygon] tool
The [Polygon] tool is used to surround an area with a contour consisting of successive
straight lines. Click on the image where you want the outline to begin. As you move the
mouse, a straight line connects the outline to the starting point. Click on the image where
you want to anchor the line and change direction.
When the last line surrounding the selected zone is connected to the starting point, the
created trace then flashes to indicate that the selection is made.
You can close the path without having to join the starting point by right-clicking
in the image or by pressing the [Enter] key.
To delete an anchor point from the line during selection, press the [Delete] key.
• The tool [Lasso]
The [Lasso] tool is used to select a freehand area. Click on the image where you want
the outline to begin. While holding down the left button, move around the image to
surround the area you want to select.
When the contour is almost closed (connected to the starting point), you can either
release the mouse button or press the [Enter] key. The outline will then flash to indicate
that selection is complete.
• Using the [Pause / Move] Mode
When an image is larger than the PhotoFiltre workspace, it is displayed with a horizontal
scrollbar and / or a vertical scrollbar. So, part of the image is hidden, on which it is
difficult to create a vector selection.
In this case, you can use the [Pause / Move] mode to access the hidden part, following
the following procedure:
1. Start the selection.
2. Without releasing the left mouse click, press the SPACEBAR (you enter [Pause /
Move] mode, the cursor takes the form of a hand), then release the left click.
3. Without releasing the spacebar, move the image to the desired location with the
mouse or using the elevators.
4. Release the space bar (exit [Pause / Move] mode, the cursor returns to the standard
form).
5. Reposition the cursor at the end of the previous plot, left click and continue selection.
This procedure is very useful with the tool [Polygon] and the tool [Lasso].

The [Magic Wand] tool
Unlike other selection tools that define a closed and unique outline, the [Magic Wand]
tool lets you select content based on pixel colors. Click in the image with the left mouse
button (in an area you want to select).
• The [Tolerance] parameter
The tolerance defines the color difference allowed to pass from one pixel adjacent to the
other. The values must be between 0 and 100. A low tolerance selects pixels whose
color is very close to that of the pixel you clicked while a high tolerance selects a wider
range of pixels.
• The [Color] option
When this option is enabled, the [Magic Wand] tool extends the selection to all pixels in
the image with close colors even if they are not adjacent (discontinuous selection).

Convert text to selection
You can use the [Text] tool to create a text-based selection. The setting is the same as
creating a Text layer, but instead of closing the dialog box with the [Ok] button, use the
[Change to Selection] button. The result is automatically transformed into a magic wand
selection.
Refer to chapter Creating a new layer for a detailed description of the [Text] tool options.

Invert a selection
If we assume that a selection is a mask (or stencil) in black and white, reversing the
selection amounts to applying a negative effect on the mask. The pierced part of the
stencil becomes full and the solid part becomes pierced.
In some cases, it is easier to make a selection by delimiting the part to be ignored from
the image and then inverting it. For example, if the background is a single color, select
the background, and then reverse the selection.
To reverse a selection, you can:
- execute the menu [Selection> Invert]
- press the [Ctrl + I] keys
- use the contextual menu (right click on the selection then [Invert selection])
in the [Select] tool options in the Tool Palette
- use the button

Select all
To select the entire image, you can:
- use the menu command [Select> Select All]
- press [Ctrl + A].
By default, PhotoFiltre uses a rectangular vector selection.
To select an entire layer, you can:
- use the menu command [Select> Select Layer]

- press [Shift + Ctrl + A]
By default, PhotoFiltre uses a Magic Wand selection.
If no selection is active, PhotoFiltre considers that the entire image or layer is
selected.

Smoothing selections
Smoothing makes it possible to obtain a softened outline by playing on the opacity of the
pixels located at the border. If no smoothing is applied, the outlines of a selection may
appear too sharp.
PhotoFiltre supports three customizable smoothing modes in the [Selection> Smoothing]
menu:
- [No smoothing]: the outline is net
- [Smoothing]: the contour is softened
- [Progressive contour]: the pixels at the border of the outline are rendered progressively
transparent

1. Start selection.
2. Fill the selection without smoothing.
3. Fill the selection with simple smoothing.
4. Fill the selection with progressive contour.
By default, PhotoFiltre uses simple smoothing for 16 million color (RGB) images and no
smoothing for indexed color mode images.

Move a selection
• Using the mouse
Position the mouse cursor inside the selection. While holding down the left button, move
around the image. Release the button as soon as the selection is in the desired position.
Hold down the [Shift] key to move the selection along a vertical or horizontal
axis.
• Using the keyboard
It is possible to move the selection using the keyboard using the arrow keys. The
selection moves one pixel at a time after each press of one of the arrow keys.
Hold down the [Shift] key to move the selection eight pixels at a time after each
press of one of the arrow keys. The [Caps Lock] key can also be used instead of
holding down the [Shift] key.

Change the shape of a selection
To change the shape of a selection into another vector shape, just choose the new
shape from the [Select> Change Shape] menu.

Change the size of a vector selection
• Using the mouse
Double-click inside the selection to display the bounding box (or marks). Position the
mouse cursor on an edge or corner of the bounding box (the shape of the cursor must
change). While holding down the left button, move around the image to stretch or
contract the shape. Release the button as soon as the selection is the desired size.
Checking the [Keep proportions] function in the contextual menu of the
selection makes it possible to preserve, during the displacement, the proportions
of the selection (the ratio between the width and the height remains constant).
Holding down the [Shift] key while moving reverses this function.
To cancel the current move, press the [Esc] key.
• Using the keyboard
It is possible to increase or decrease the size of the selection using the keyboard using
the arrow keys while holding down the [Alt] key. The selection expands or contracts one
pixel at a time after each press of one of the arrow keys.
Hold down [Shift] to contract or expand the selection by eight pixels at a time
after each press of one of the arrow keys.

Change the size of a magic wand selection
It is not possible to stretch or contract a magic wand selection directly with the mouse.
You must use the [Manual Setting] command.
Refer to the Manual Setup section for a detailed description of the available options
(further in this chapter).

Contract a selection
This function is available for all types of selection and reduces a selection evenly across
all four sides of the bounding box.
Here's how to proceed:
1. Display the dialog via the [Select> Contract] menu.
2. Change the contraction width.
3. Confirm to close the dialog and perform the operation.

Dilate a selection
This function is available for all types of selection and allows you to enlarge a selection
evenly across the four sides of the bounding box.

Here's how to proceed:
1. Display the dialog via the [Select> Dilate] menu.
2. Change the expansion width.
3. Confirm to close the dialog and perform the operation.

Adapt the report
Manual adjustment of a ratio between width and height is often tedious. PhotoFiltre
provides a list of predefined reports. This function is available only for vector shapes.
1. Create a new selection.
2a. Run one of the commands in the [Selection> Adapt Report] menu or
2b. Use one of the ratio buttons in the [Select] tool options on the Tool Palette.
Use this function just before cropping the image. If your image is for a screen
display, use a [4: 3] report. For images for digital photo print, use a [3: 2] report.

Create a bang
This function allows you to create a new selection from a current selection. The result
corresponds to a selection composed of a contour with thickness.
1. Create a new selection.
2. Display the dialog via the [Selection> Fringe] menu.
3. Change the width of the fringe.
4. Confirm to close the dialog and perform the operation.
The result is automatically transformed into a magic wand selection.

Manual setting
The [Manual Setting] dialog box allows you to define a selection by directly entering
values in the edit boxes provided for this purpose.
• The [Position] parameter
Choose an automatic position or enter the position of the top / left point of the selection
box.
• The [Size] setting
Enter the size of the selection (in pixels, centimeters, or inches) or relative values
relative to the size of the image (% / Image). The [Keep Aspect Ratio] option allows you
to not distort the selection when changing size.

• Form
In design mode, only basic vector shapes are available. Do not change this data if you
only want to change the size or position.

Manual setting properties

Transform a selection
You can mirror or rotate a selection without changing the content, regardless of the type
of selection. Use one of the commands in the [Selection> Transformation] menu.

Combine selections
You can add or remove from existing selections. The result is automatically transformed
into a magic wand selection.
• Add to a selection
1. Create a new selection.
2. Hold down the [Ctrl] key.
3. Select the part of the image to add.
Repeat steps 2 and 3 as many times as necessary.
• Subtract a selection
1. Create a new selection.
2. Hold down the [Alt] key.
3. Select the part of the image to subtract.
Repeat steps 2 and 3 as many times as necessary.

Contour and automatic filling
This function is used to fill and draw the outline of a vector shape automatically at the
end of the selection.

1. Activate the Selection tool in the tool palette.
2. Choose the predefined shape to use.
3. Select the Contour and Fill checkboxes in the options section of the work tool.
4. Select the area of the image with the mouse.
At the moment the mouse button is released, PhotoFiltre fills the shape and draws an
outline instead of making the selection. The thickness of the contour is determined by
the [Line] tool and the filling by the [Fill] tool.
Use this function to create flowcharts (in combination with the [Line] tool).

Contour and configurable filling
This function is used to fill and trace the outline of a shape manually.
To start the Contour and Fill function, you can:
- use the menu [Edit> Contour and fill]
- press the [Ctrl + B] keys
- use the contextual menu (right-click in the selection and then [Contour and fill])

Properties of the Contour and Fill command
• The [Opacity] setting
This parameter defines the intensity with which the settings will apply.
• The [Contour] option
This option draws an outline around the shape or around the image. If the box is
checked, the parameters below are accessible.

The [Smooth] parameter
This parameter is used to activate or not the contour smoothing to improve the visual
appearance. Smoothing is not available for rectangular shapes.
The [Color] parameter
This parameter indicates the color of the outline.
The [Width] parameter
This parameter defines the thickness of the contour.
The [Pattern] parameter
If this box is checked, we have access to the reasons thanks to the opening button
symbolized by a small folder. Selecting a pattern disables the [Color] setting.
• The [Fill] option
This option allows you to fill a shape with a color or pattern. If the box is checked, the
parameters below are accessible.
The [Color] parameter
This parameter indicates the fill color.
The [Style] parameter
This parameter allows you to apply one of the predefined styles in the drop-down menu
with a color defined by the previous parameter.
The parameter [Fill pattern]
If this box is checked, we have access to the reasons thanks to the opening button
symbolized by a small folder. Selecting a pattern disables the [Color] and [Style] settings.

If no selection is defined, this function acts on the entire layer.

Copy a selection
You can copy a selection to the clipboard for later retrieval in any image (as long as you
do not leave PhotoFiltre ). Use the [Select> Copy Shape] menu.

Paste a shape
If the internal clipboard contains a copied shape, you can paste it into your image using
the [Select> Paste Shape] menu.
If a selection is already in progress, PhotoFiltre proposes to keep its dimensions. If you
do not want to keep its dimensions, or if no selection is in progress, the pasted selection
is displayed in the center of the visible area. In this case, if the size of the selection is

larger than that of the image, its dimensions will be adapted keeping the proportions.
The position of the selection is kept if possible.

Save a selection
You can save a selection to your computer's hard drive for later retrieval in any image.
1. Display the dialog via the [Select> Save Shape] menu. By default, PhotoFiltre is
positioned in the folder [Selections] and displays the list of files
corresponding to the selections already saved.
2. Enter a name for the new selection and confirm.
The selections are saved in PFS ( PhotoFiltre Selection ) format.

Load a selection
1. Display the dialog box via the [Select> Load Shape] menu.
2. Locate the folder containing the selection you want to load.
By default, PhotoFiltre is positioned in the [Selections] folder and displays the list of files
corresponding to the saved selections.
3. Click the file containing the selection you want to load (use preview).
4. Confirm to close the dialog box and load the selection.
If a selection is already in progress, PhotoFiltre proposes to keep its dimensions. If you
do not want to keep its dimensions, or if no selection is in progress, the loaded selection
is displayed in the center of the visible area. In this case, if the size of the selection is
larger than that of the image, its dimensions will be adapted keeping the proportions.

Layers overview

Definition
Layers can be compared to sheets stacked on top of each other. When the layer
contains transparent areas, you can see the layer from below through these areas.
Below all layers is the background layer, also called the background layer. An image
created in PhotoFiltre consists of at least one background layer that is used as a
medium. As long as the layers are not merged, each one remains independent of the
others.
Example of an image composed of three layers
1. Background layer (background)
2. Bitmap layer
3. Text type layer

There is no limitation in number of layers, but it is possible that you are limited
by the amount of memory available to your computer.
It is recommended to monitor the memory occupied by your image via the [File>
Properties] menu and to save this image regularly in different files.

Layer types
PhotoFiltre handles four types of layers. The Bitmap type is an array of two-dimensional
pixels forming a digital graphic representation. The Text type displays a block of text at a
specific point in the image. Text attributes (content, font, color) can be changed at any
time. The Color type allows you to achieve translucent solid color effects without actually
changing the layers from below. The Adjust type works much the same way, but instead
of applying a color effect, it allows you to apply a series of settings to the layers from
below without actually modifying them.

Working with layers
PhotoFiltre has several tools for working with layers. The layer bar on the left of each
image displays the layer's thumbnail, its display order, and some main options. The
[Layer Properties] dialog box allows you to set the active layer. The [Layer Manager]
tool, which is available in the toolbar, provides quick access to the main properties.
Finally, the [Layer] menu has general controls for creating, managing, and merging
layers.

The layer bar
The layer bar is placed to the left of each image and contains a representation of the

layers as a thumbnail. Each thumbnail is placed according to the order of the layer it
represents. Thumbnails are stacked from bottom to top, so the bottom layer thumbnail is
at the bottom of the stack. The order of the thumbnail is actually the order in which the
layer is displayed. The background layer is displayed first, then the layer whose
thumbnail is just above that of the background layer is displayed. This is done up to the
top layer whose thumbnail is at the top of the stack.

On the left, the layer bar of an image composed of three
layers. The thumbnail of the background layer is at the bottom of
the stack and active layer is at the top of the stack.
Navigation and search buttons appear at the bottom of the layer bar when the number of
thumbnails exceeds the number of thumbnails that can be displayed in the bar.
1. This button scrolls through
thumbnails up
2. This button scrolls through
thumbnails down
3. This button allows quick access to a
layer (activate the layer).

Click on a thumbnail with the left mouse button to select the associated layer.
This will become the active layer (the thumbnail of the active layer contains a
colored box).
Right-click on a thumbnail to display the pop-up menu containing the most
common functions.

If the number of layers is too large, you can use the [View> Layer Thumbnails>
Text] command.

The [Layer Properties] dialog box
The [Layer Properties] dialog box contains all the properties of the active layer. The
proposed options are dynamic depending on the type of layer.
Refer to chapter Creating a New Layer for a detailed description of the options.
Double-click a thumbnail to display the properties dialog box for the active
layer.

The Layer Manager tool
The [Layer Manager] tool provides direct access to the main properties of the layer. You
can easily change the opacity, visibility and locking of a layer by just clicking. When this
tool is active, you can also move a layer in the image using the mouse or keys on your
keyboard. To activate this tool, click on the corresponding button in the tool palette.
Refer to the Layer Basic Operations chapter for more details on the options for this tool.
When this tool is active, the contextual menu of the image corresponds to the
context menu of the layer bar.

Create a new layer

Introduction
Creating a layer is possible only if the image is in 16 million RGB or RGBA color (with
Alpha layer). The new layer is placed just above the active layer. It is therefore better to
select a layer correctly before creating a new layer if you do not want to move it later.
PhotoFiltre provides several functions to create a new layer.

Creating a layer by gluing
The easiest way to create a new layer is to paste the contents of the clipboard using the
[Edit> Paste] menu. When running this function, PhotoFiltre automatically creates a
bitmap layer. Transparency is also taken into account if the clipboard contains internal
data. To access the new layer options, launch the [Layer> Options] menu.
• The [Opacity] setting
It defines the visibility coefficient of the layer below. A Bitmap layer with an opacity of
10% is almost transparent, while a layer with 100% opacity is completely opaque.
• The option [Drop Shadow]
This option simulates a drop shadow, as if the layer was elevated from the layer below.
The [DeltaX] and [DeltaY] parameters define the offset of the shadow relative to the
layer. The [Color] parameter allows you to choose the color of the shadow (black by
default). Opacity defines the intensity with which the shadow is displayed. The higher
this value, the more the shadow will be visible and opaque. PhotoFiltre handles three
styles of drop shadows (flat, smoothness, diffusion) that allow you to modify the borders
of the shadow. For the drop shadow style [Smooth], the smoothing radius can be set
(progressive contour).

Properties of a Bitmap Layer

Creating a blank layer
To create a blank bitmap layer, use the [Layer> New> Blank] menu.
PhotoFiltre then displays the Layer Properties dialog box.
• The [Position] parameter
PhotoFiltre has nine automatic positions, but you can manually enter the position of the
point at the top left of the new layer. In the latter case, the position is defined in pixels.
• The [Size] setting
Enter the layer size (in pixels, centimeters or inches) or relative values relative to the
image size (% / Image). The [Keep Aspect Ratio] option maintains the ratio of width to
height when any of these values change.
• The [Layer] parameter
If the [Auto Transparency] check box is selected, the new layer is fully transparent (the
[Color] and [Apply Layer Options] options are disabled). If the [Auto Transparency] check
box is cleared, the new layer has the color set in the [Color] option. If the [Apply Layer
Options] check box is selected, the layer options saved in a previous process are added
to the color.
If a selection is active at the time of this function, PhotoFiltre retrieves its
position and dimensions for use in creating the layer.

Properties of a blank layer

Creating a color layer
A color layer is used to fill the entire image with a solid color and a translucency
coefficient. A layer of this type does not actually change the layers below, but the
settings are made in real time. To create a color layer, use the [Layer> New> Color]
menu. PhotoFiltre then displays the Layer Properties dialog box. A layer of this type
affects all visible layers below.
• The [Opacity] setting
This parameter defines the translucency coefficient of the color. A Color layer with an
opacity of 10% is almost transparent, while a layer with 100% opacity is completely
opaque and fully filled with the defined color.
• The [Color] setting
This parameter is used to set the fill color of the layer. You can enable the [Invert] option
to simulate a color subtraction effect.

Properties of a color layer

Creating an adjustment layer
An adjustment layer allows you to simulate and correct multiple layers with a single
adjustment, instead of applying the adjustment to each one. A layer of this type does not
actually change the layers below, but the settings are made in real time. To create an
adjustment type layer, use the [Layer> New> Setup] menu. PhotoFiltre then displays the
Layer Properties dialog box. A layer of this type affects all visible layers below.
• The [Opacity] setting
This parameter defines the intensity with which the settings will apply on the layers
below.
• The settings
Brightness, contrast, saturation, hue and gamma correction can be changed in one
operation.

Properties of an adjustment layer

Creating a layer from an image file
PhotoFiltre offers to open an image file and import it to automatically create a bitmap
layer. To do this, use the [Layer> New> Open as layer] menu. PhotoFiltre then displays
the Windows dialog box for selecting an image file. To access the new layer options,
launch the [Layer> Options] menu. Thus, you can set the opacity and the drop shadow.
See Creating a new layer by pasting for a detailed list of options.

Creating a text layer
A Text layer is used to display a block of text at a specific point in the image. Text
attributes can be changed at any time even after inserting another layer. To create a text
layer, use the [Layer> New> Text] menu (or the [T] button on the toolbar, or CTRL + T).
PhotoFiltre then displays the properties dialog that consists of two tabs.
• The [Text] tab
The Text tab defines the font properties of the text and its contents. Start by selecting the
font, size, and attributes (bold, italic, strikethrough, underline). The preview area allows
you to view these different parameters in real time. In a second step, choose the color of
the text, the alignment, the angle of rotation and the option of smoothing (activated by
default). Finally, enter your text in the box provided. The [Reset] button restores the
default values in the [Text] and [Effects] tabs.

Text tab options
The list of available fonts corresponds to the fonts installed on your computer
(refer to the Windows documentation on font installation).
• The [Effects] tab
This tab offers various predefined effects to change the appearance of the result. For
example, you can change the opacity of the text, the spacing between characters, the
size of the line spacing, or add a drop shadow. The setting is the same as for a Bitmap
layer. The three options - [Outline], [External Bevel] and [Negative Mode] - are exclusive,
that is, they can not be used at the same time. It is also possible to fill in the text with a
pattern rather than using a solid color. To do this, activate the [Fill Pattern] option and
click the folder button. PhotoFiltre then displays the Windows dialog box for selecting an
image file that will be used as a text fill pattern.

Effects tab options
Some options, such as [External Bevel] and [Blur], provide the best results for
large texts.

Basic operations on layers

Rename a layer
If an image contains multiple layers, it is much more convenient to rename the layers so
that they are easier to identify. Preferably use a short and explicit name. All types of
layers can be renamed.
To rename a layer, do the following:
1. Select the layer in the layer bar by clicking on its thumbnail.
2. Use the [Layer> Rename Layer] menu or the [Rename Layer] command in the Layer
Bar context menu by right-clicking its thumbnail.
3. Enter a new name in the edit box.
4. Click [OK] to validate and close the dialog box.
The layer bar displays the new name just below its thumbnail.

Move a layer in the image
To move a layer, you must select the Layer Manager tool from the Tool Palette and
select the layer to move by clicking its thumbnail in the Layer Bar.
• Using the mouse
Position the mouse cursor over the layer. While holding down the left button, move
around the image. Release the button as soon as the layer is in the desired position.
Hold down the [Shift] key to move the layer along a vertical or horizontal axis.
• Using the keyboard
It is possible to move the layer using the keyboard using the arrow keys. The layer
moves one pixel at a time after each press of one of the arrow keys.
Hold down the [Shift] key to move the layer eight pixels at a time after each
press of one of the arrow keys. The [Caps Lock] key can also be used instead of
holding down the [Shift] key.

Change the opacity of a layer
The opacity of a layer defines the visibility coefficient of the layer below. A layer with an
opacity of 10% is almost transparent, while a layer with 100% opacity is completely
opaque.
To change the opacity of a layer, you can:
- use the [Layer> Options] menu to display the Layer Properties dialog box (the dialog is
dynamic depending on the layer type)
- select the [Layer Manager] tool from the tool palette
- double-click on the thumbnail of the layer to display the layer properties dialog box (the
dialog is dynamic according to the type of layer)

In both cases, vary the adjustment bar associated with the [Opacity] parameter. The
possible values are between 10% and 100%.

On the left, the top layer has a opacity of 100% (opaque).
On the right, the same layer with an opacity of 50%. He lets appear the
layer from below by semi-transparency.

Duplicate a layer
PhotoFiltre lets you duplicate any layer, including the background layer.
To duplicate a layer, you can:
- use the [Layer> Duplicate] menu
- use the [Duplicate] command in the context menu of the layer bar by right-clicking on
its thumbnail
PhotoFiltre automatically creates a new layer of the same type and content and places it
just above the active layer.

Change the order in which a layer is displayed
The stacking order of thumbnails in the layer bar determines the order in which layers
are displayed in the image, that is, if one layer appears in front of or behind the other
layers. Since the background layer can not be moved, this feature is available only if
your image contains at least three layers.
To change the display order of a layer, do the following:
1. Select the layer in the layer bar by clicking on its thumbnail.
2. While holding down the left mouse button, drag the thumbnail up or down in the layer
bar. When the colored separator line is in the desired position, release the mouse button.

Thumbnails are moved and the image is redisplayed to reflect the change.

1. Select the top layer
2. Drag it from position 1 to position 2
3. The display order of the layers in the image is changed
The functions in the [Layer> Order] menu allow you to change the order of the
active layer in the layer list.

Lock a layer
You can lock a layer to protect its contents. When a layer is locked, a lock appears in its
thumbnail at the bottom right and editing is impossible. Locked layers can be moved to a
different place in the layer stack, but can not be deleted. The layer to be locked must be
the active layer, so select it before performing the operation.
To lock a layer, you can:
- activate the [Lock] command in the context menu of the layer bar by clicking with the
right mouse button on its thumbnail
- select the [Layer Manager] tool in the tool palette and activate the [Lock] option
To unlock a layer, you can:
- disable the [Lock] command in the context menu of the layer bar by right-clicking on its
thumbnail
- select the [Layer Manager] tool in the Tool Palette and disable the [Lock] option

Hide and show a layer
You can hide a layer to make it invisible in the image. When a layer is hidden, a barred
eye appears in its thumbnail at the bottom left. The layer to hide or display must be the
active layer, so select it before performing the operation.
To hide a single layer, you can:
- disable the [Visible] option in the context menu of the layer bar by right-clicking on its
thumbnail
- select the [Layer Manager] tool from the tool palette and disable the [Visible] option
To display a single layer, you can:
- activate the [Visible] option of the context menu of the layer bar by clicking with the
right mouse button on its thumbnail
- select the [Layer Manager] tool in the tool palette and activate the [Visible] option

The background layer (background) can also be hidden. In this case, a
transparency of type Alpha (RGBBA mode) is forced.

Hide and show all layers
To hide all layers in an image (except the background layer) in one operation, use the
[Layer> Hide All Layers] menu. You can also make all layers of an image visible using
the [Layer> Show All Layers] menu.

Delete a layer
PhotoFiltre does not allow you to delete the background layer because it is required.
To delete a layer, you can:
- use the [Layer> Delete] menu
- use the [Delete] command in the context menu of the layer bar by right-clicking on its
thumbnail
- press the [Ctrl + Del] keys
It is best to first hide the layer rather than delete it.

Save an image with layers
Only the PFI ( PhotoFiltre Image ) format allows to keep an image with all its layers. The
other formats automatically fuse all visible layers, and when you open it the image will be
composed of only one background layer.
PhotoFiltre displays a warning if you try to save a layered image in a format other than
PFI.

Advanced operations on layers

The modes of fusion
• Definition
The blend mode determines how the pixels in a layer are combined with the background
pixels. Background pixels are the result of merging lower-level layers. The combination
of blend modes creates a large number of effects and settings.
• List of blending modes

- Normal (default mode)
- Diffusion
- Minimum
- Maximum
- Overlay
- Difference
- Product
- Inlay
- Hue
- Saturation
- Brightness
- Color
• Merger rules
1. When merging two layers, the "result" layer uses the lower layer's blend mode.
2. The top layer before being deleted draws on the lower layer using its own blend mode.
3. Adjustment layers use only the Normal merge mode.

Merge layers
Merge assembles two consecutive layers into one, simplifying the image and keeping
the file size down. The layer resulting from a merge contains all the data of the two
layers concerned and keeps their transparent areas. You can merge any type of layer
with a bitmap layer just below it.
To merge a layer with the layer below:
1. Make sure the two layers to merge are visible and correctly positioned. Select the top
layer in the layer bar.

2. Use the [Layer> Merge with Bottom Layer] menu or the [Merge with Bottom Layer]
command in the context menu of the layer bar by right-clicking the layer thumbnail.
The target layer, that is to say the layer below, must absolutely be Bitmap type.

Merge special layers
A special layer is a type of adjustment , of type Color or type Text , because these layers
do not contain data in the form of pixels. You can merge a special layer with a bitmap
layer beneath it. However, you can not use a special layer as the target layer for a
merge.
Special layers do not significantly increase the size of the image file, so you do not need
to merge these layers to limit size, but rather to simplify it.

Flatten the image
In a flattened image, all visible layers are merged into the background layer, greatly
reducing the file size.
As a general rule, it is best not to flatten an image until you have finished editing the
layers individually. So be sure to keep a copy of your image with all layers if you think
you need to rework it later.
To flatten an image, do the following:
1. Hide all the layers you do not want to merge (they will still be deleted).
2. Use the [Layer> Merge All Layers] menu.
If you want to keep non-visible layers for later editing, you must:
1. Hide all the layers you do not want to merge (they will be kept at the top of the stack in
the layer bar).
2. Use the [Layer> Merge all visible layers] menu.

Convert a Text layer to a Bitmap layer
Text layers are very useful for dynamically modifying a block of text, but effects other
than predefined ones can not be applied to them. PhotoFiltre offers the possibility of
converting these layers to a Bitmap layer to circumvent this limitation. Once converted,
you can apply filters to it and edit it with drawing tools, but you can not edit it using text
editing options. It is therefore advisable to convert the layer only when you are sure of
not having to modify its contents.

Merge the shadow
Bitmap and Text layers both have a drop shadow option. This option is dynamic, that is,
it is calculated each time the layer is displayed and moved. The disadvantage is that the
calculations are complex and the duration of treatment can increase considerably and
become a nuisance. To work around this problem, PhotoFiltre offers the ability to convert
this drop shadow into pixelated data.
To merge the drop shadow of a layer, use the [Layer> Merge Shadow] menu.
Once merged, the drop shadow resumes the layer merge mode. With merge
modes other than Normal, the drop shadow may appear to disappear or change

color and opacity.
To merge the drop shadow of a Text layer, you must first convert it to a Bitmap
layer.

Change the alpha transparency of a layer
To change the alpha transparency of the layer, click the [Layer> Transparency>
Transparency Color] menu or the button in the toolbar. PhotoFiltre displays the
window for setting the Alpha transparency.

Properties of the Transparency Colors function.
• The [Color] setting
This parameter is used to set the transparency color of the layer. Move the mouse over
the layer to see the pipette cursor. Click an area with the color to be set as transparent.
• The [Tolerance] parameter
The tolerance defines the color difference allowed to pass from one pixel adjacent to the
other. The values must be between 0 and 100. A low tolerance selects pixels whose
color is very close to that of the pixel you clicked while a high tolerance selects a wider
range of pixels.
• The [Opacity] setting
This parameter defines the translucency coefficient of the color. An opacity of 0% means
that the color will not be visible whereas an opacity of 50% creates a semi-transparency
effect (or translucency).
Alpha transparency is also called translucency.
See also chapter Color modes and transparency .

Change the Alpha transparency of an area on a layer
To change the Alpha transparency on a part of a layer, after selecting the area to be
processed, click the [Layer> Transparency> Opacity] menu. PhotoFiltre displays the
window for setting the Alpha transparency.

Property of the function
• The [Opacity] setting
This parameter defines the translucency coefficient of the area to be treated. An opacity
of 0% means that the area will not be visible, while an opacity of 50% creates a semitransparency (or translucency) effect.
• The [Reset] setting
If this parameter is active, the opacity is absolute (from the image without opacity). If this
parameter is not active, the opacity requested is cumulative with the previous opacities
(relative opacity).

Transparent gradients
Transparent gradient functions create a linear or radial fade. To obtain a transparent
gradient, PhotoFiltre varies the opacity of the layer in a progressive way (see the images
below). A linear gradient can be horizontal (images [1] and [2]), vertical (images [3] and
[4]) or oblique (images [5] to [8]). A radial gradient can be from the center to the outside
or from the outside to the center (images [9] and [10]).
Transparent gradient functions change the Alpha layer of the layer!
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The black parts correspond to the opaque areas of the layer while the white parts
correspond to the transparent areas of the layer.
To apply a transparent gradient, use one of the commands in the [Layer> Transparency>
Transparent Gradient] menu. This function is available only for Bitmap layers.

Left the bottom. In the center a layer to which a gradient has been applied
linear transparency. On the right the result obtained by the merger.
The linear transparent gradients take into account the current selection.

Edge effects

Edge effects allow you to change the outline of a layer by creating a simple smoothing
effect, blur, feathering, or a more advanced effect such as a scattered dispersion or
outline. The outline of a layer corresponds to the border between the transparent regions
and the opaque regions. Edge effects change the Alpha layer of the layer.
To apply a side effect, use one of the [Layer> Edge Effect] menu commands. This
function is available only for Bitmap layers.

On the left a dispersion effect, on the right a torn outline.
Most edge effects can be minimized by using the [Edit> Mute Edge Effect]
function.
The size of edge effects [Progressive Edge] and [Dispersion] are adjustable.

Layer transformations

Symmetries
• Horizontal symmetry
Horizontal symmetry (or vertical axis symmetry) lets you toggle the active layer,
background layer (media), or all layers composing the image horizontally. This gives a
mirror effect.
To horizontally mirror the active layer, you can:
- use the menu [Layer> Transformation> Horizontal symmetry]
- click on the icon
in the toolbar
To horizontally mirror the background layer, you can:
- use the menu [Image> Transformation> Horizontal symmetry> Bottom]
- click on the icon
in the toolbar if the active layer is the background layer
To horizontally mirror all layers, you must use the menu
[Image> Transformation> Horizontal Symmetry> All Layers].
• Vertical symmetry
Vertical symmetry (or horizontal axis symmetry) lets you toggle the active layer, the
background layer (media), or all the layers that make up the image vertically. This gives
a reflection effect in the water.
To vertically mirror the active layer, you can:
- use the menu [Layer> Transformation> Vertical symmetry]
- click on the icon in the toolbar
To vertically mirror the background layer, you can:
- use the menu [Image> Transformation> Vertical symmetry> Bottom]
- click on the icon in the toolbar if the active layer is the background layer
To perform vertical symmetry on all layers, you must use the menu
[Image> Transformation> Vertical Symmetry> All Layers].

Original image

Horizontal symmetry Vertical symmetry

If a selection is in progress, the contextual menu of the selection also offers the
symmetry functions, but the selected area is converted to a layer before applying
the transformation.

Simple rotations

• Counterclockwise rotation 90 °
The 90 ° counter-clockwise rotation rotates a quarter of a turn counterclockwise, the
active layer, the background layer (media) or all the layers composing the image.
To rotate 90 ° counter-clockwise on the active layer, you can:
- use the menu [Layer> Transformation> Rotation 90 ° counterclockwise]
- click on the icon
in the toolbar
To rotate 90 ° counterclockwise on the background layer, you can:
- use the menu [Image> Transformation> Rotation 90 ° counterclockwise> Bottom]
- click on the icon
in the toolbar if the active layer is the background layer
To rotate 90 ° counter-clockwise on all layers, you must use the menu
[Image> Transformation> Rotate 90 ° counterclockwise> All Layers].
• 90 ° rotation
90 ° rotation rotates a quarter of a turn clockwise, active layer, background layer (media),
or all layers in the image.
To rotate 90 ° clockwise on the active layer, you can:
- use the menu [Layer> Transformation> Rotation 90 ° clockwise]
- click on the icon
in the toolbar
To rotate 90 ° clockwise on the background layer, you can:
- use the menu [Image> Transformation> Rotation 90 ° time> Background]
- click on the icon
in the toolbar if the active layer is the background layer
To rotate 90 ° clockwise on all layers, you must use the menu
[Image> Transformation> Rotate 90 ° Time> All Layers].
• 180 ° rotation
The 180 ° rotation allows you to rotate by half a turn, the active layer, the background
layer (support) or all the layers composing the image.
To rotate 180 ° on the active layer, you must use the menu
[Layer> Transform> Rotate 180 °].
To rotate 180 ° on the background layer, you must use the menu
[Image> Transformation> 180 ° Rotation> Background].
To rotate 180 ° on all layers, you must use the menu
[Image> Transformation> 180 ° Rotation> All Layers].

Original image

Rotation 90 ° Rotation 90 °
CCW
schedule

Rotation 180 °

If a selection is in progress, the context menu of the selection also proposes
the rotation functions, but the selected area is converted to a layer before
applying the transformation.

The parameterized rotation
The parameterized rotation makes it possible to rotate, from any angle, the background
layer (support) or all the layers composing the image.
To perform a parameterized rotation, use the [Image> Transform> Rotate
parameterized] menu. PhotoFiltre then displays the dialog box for setting the rotation.

Properties of the parameterized rotation
• The [Angle] setting
This parameter is used to set the angle of rotation in degrees. The default direction is
clockwise, so to rotate counterclockwise, you must enter a negative value.
• The [Background] setting
After rotating, some areas of the image are empty. This parameter is used to replace
empty areas with a background color.
• [Adjust size] option
After being rotated, the image is a little larger, because the corners of the transformed
image are no longer superimposed on those of the support. PhotoFiltre automatically
enlarges the media so that the transformed image is not trimmed.
• The [Smooth] option

It allows to activate the bilinear interpolation during the transformation. Thus, the result is
of a better visual quality. This option is not available in indexed and transparent mode.
• The [All Layers] option
This option is active if the image is composed of multiple layers. It allows you to rotate all
layers at once in one operation.
• View window
This window displays, in real time, a preview of the image after the application of the
rotation.

After a rotation, the size of the image is larger

The [Incline] command
This command allows you to tilt the background layer (media) or all layers composing
the image along a horizontal or vertical axis. After tilting, the image is a little larger,
because the corners of the transformed image are no longer superimposed on those of
the support. PhotoFiltre automatically enlarges the media so that the transformed image
is not cropped.
To tilt, use the [Image> Transform> Tilt] menu. PhotoFiltre then displays the dialog box
for tilting.

Properties of the Tilt feature
• The [Background] setting

After rotating, some areas of the image are empty. This option replaces empty areas
with a background color.
• The tilt axis
You can choose between a horizontal axis or a vertical axis. Deformation and
adjustment of the work area depend on this orientation.
• The strain coefficient
If the inclination is along a horizontal axis, the deformation will be from the top of the
image to the bottom of the image. If, on the other hand, the inclination is along a vertical
axis, the deformation will be from the left of the image to the right of the image.
Therefore, the strain coefficient corresponds to the maximum displacement of the ends
concerned.
Move the slider to the left or right with the mouse or the arrow keys to change the
coefficient. The displayed value is in percentage relative to the width or the height of the
image according to the axis.
• The [Smooth] option
It allows to activate the bilinear interpolation during the transformation. Thus, the result is
of a better visual quality. This option is not available in indexed and transparent mode.
• The [All Layers] option
This option is active if the image is composed of multiple layers. It allows you to tilt all
layers at once in one operation.
• View window
This window displays, in real time, a preview of the image after the application of the
inclination.

After tilting, the size of the image is larger

The [Trapeze / Perspective] command
The [Keystone / Perspective] command lets you give a perspective effect, horizontally or
vertically, to the background layer or active layer of the image. After processing this
command, the changed item may be larger or smaller than the original item. PhotoFiltre
automatically resizes the edited item so that it is not cropped.
To make this command on the active layer, you can use the [Layer> Transform>

Keystone / Perspective] menu
To make this command on the background layer, you can use the [Image> Transform>
Keystone / Perspective] menu

Properties of the [Keystone / Perspective] command
• The [Background] setting
After processing the [Keystone / Perspective] command, some areas of the image are
blank. On the background layer, this option replaces empty areas with a background
color. On the active layer, this parameter is grayed out and the empty areas are
transformed into transparency.
• The deformation axis
You can choose between a horizontal axis or a vertical axis. Deformation and
adjustment of the work area depend on this orientation.
• Deformation coefficients
If the [Keystone / Perspective] command is made along a horizontal axis, the distortion
will be from the top of the processed element toward the bottom of the element. On the
other hand, if the control is carried out according to a vertical axis, the deformation will
proceed from the left of the treated element to the right of the element. The strain
coefficients correspond to the maximum displacement of the ends concerned.
Move the slider to the left or right with the mouse or the arrow keys to change the
coefficient. The displayed value is in percentage relative to the width or the height of the
image according to the axis.
• View window
This window displays, in real time, a preview of the image after the application of the
command.

The command [Spiral]
The [Spiral] command is used to give a winding effect, in a clockwise or anti-clockwise
direction, to the background layer or the active layer of the image. After processing this
command, the changed item may be larger or smaller than the original item. PhotoFiltre
automatically resizes the edited item so that it is not cropped.

To do the [Spiral] command on the active layer, you can use the [Layer> Transform>
Spiral] menu
To make the [Spiral] command on the background layer, you can use the [Image>
Transform> Spiral] menu

Properties of the [Spiral] command
• The [Background] setting
After processing the [Spiral] command, some areas of the image are empty. On the
background layer, this option replaces empty areas with a background color. On the
active layer, this parameter is grayed out and the empty areas are transformed into
transparency.
• Spiral direction
You can choose between clockwise or counterclockwise. Deformation and adjustment of
the work area depend on this orientation.
• Quantity
The higher this parameter, the closer the winding of the spiral is tightened. Move the
slider to the left or right with the mouse or the arrow keys to change the amount.
• View window
This window displays, in real time, a preview of the image after the application of the
[Spiral] command.

The command [Curve]
The [Curve] command allows you to warp, in a path, the background layer or active layer
of the image. It is based on the use of Béziers curves. After processing this command,
the modified item may be larger than the original item. PhotoFiltre automatically resizes
the edited item so that it is not cropped.
To make the [Curve] command on the active layer, you can use the [Layer> Transform>
Curve] menu
To make the [Curve] command on the background layer, you can use the [Image>
Transform> Curve] menu

Properties of the [Curve] command

• The [Grid] setting
This option displays or hides the cue grid. In the majority of cases, the display of the grid
makes it possible to have a more precise adjustment.
• The [Color] setting
It allows you to change the color of the grid. Change the color only in case the grid is not
visible on the thumbnail of the image.
• The [Background] setting
After processing the [Curve] command, some areas of the image are empty. On the
background layer, this option replaces empty areas with a background color. On the
active layer, this parameter is grayed out and the empty areas are transformed into
transparency.
• The deformation axis
You can choose between a horizontal axis or a vertical axis. Deformation and
adjustment of the work area depend on this orientation.
1. [Edit] function
It allows you to change the location of a point, keeping the left click pressed on it and
moving the mouse.

2. [Add] function
It allows to add a new point on the curve by clicking on it at the desired place. A new
point can only be created at a certain distance from the previous one (at least 12 pixels).
3. [Delete] function
It allows you to delete a point by clicking on it. The curve is redrawn between the
previous point and the next one.
4. [Smooth] function
By executing this function, PhotoFiltre calculates an automatic smoothing of the curve.
5. [More neat] function
By executing this function, the plot of the curve uses only segments of straight lines.
6. [Reset] function
It returns the default setting, the curve becomes a simple straight line centered in the
middle of the representation of the layer (taking into account the axis of deformation).
7. Function [Open]
This function allows you to load a setting previously saved in a file. PhotoFiltre displays
the dialog box. It is positioned by default in the [Data] folder and displays the PFD format
files. Select the desired file and click [Open] to load the setting.
8. [Save] function
This function proposes to save a setting for future use. PhotoFiltre displays the dialog
box and is positioned by default in the [Data] folder. Type a new file name and click
[Save].
Vector plots are saved in PFD ( PhotoFiltre Data ) format.

Resize a layer
• Using the mouse
To resize a layer using the mouse, first display the handles using the [Layer>
Transform> Resize Layer] menu or the [Resize Layer] command in the context menu of
the layer bar.
Position the mouse cursor on one of the handles of the bounding box (the shape of the
cursor must change). While holding down the left button, move around the image to
stretch or contract the bounding box. Release the button as soon as the layer is the size
you want.
You can do this again on the other handles. The bounding box always retains a
rectangular shape (right angles).

When you are satisfied with the result, you must validate it by double-clicking on the
layer, pressing the [Enter] key or using the [Enter] command in the context menu of the
layer.
If, on the other hand, the result does not satisfy you, you can cancel it by pressing the
[Escape] key or using the [Cancel] command in the context menu of the layer.

Resize handles
Selecting the [Keep Aspect Ratio] function in the context menu of the resizing
frame allows you to preserve the layer's proportions while moving a handle (the
ratio between width and height remains constant). Holding down the [Shift] key
while moving a handle reverses this function.
To cancel the current move of a handle, press the [Esc] key.
• Using the [Manual Setting] dialog box
The [Manual Setting] dialog box allows you to define a selection by directly entering
values in the edit boxes provided for this purpose. Display the dialog via the [Layer>
Manual Setup] menu or via the [Manual Setting] command in the context menu of the
layer bar.
Note that this function can not be applied to the background layer (media).
Refer to chapter Creating a New Layer for a detailed description of the [Position] and
[Size] options.

Manual setting properties

Distortion (or free transformation)

Distortion allows you to stretch a layer in all directions via the handles. The distortion is
done using the mouse. Start by displaying the handles via the [Layer> Transformation>
Distortion] menu.
Position the mouse cursor on one of the handles of the bounding box (the shape of the
cursor must change). While holding down the left button, move around the image to
distort the layer. Release the button as soon as the layer has the desired shape. You
can do this again on the other handles.
When you are satisfied with the result, you must validate it by double-clicking on the
layer, pressing the [Enter] key or using the [Enter] command in the context menu of the
layer.
If, on the other hand, the result does not satisfy you, you can cancel it by pressing the
[Escape] key or using the [Cancel] command in the context menu of the layer.

The handles of the Distortion function
Note that this function can not be applied to the background layer (media).
To cancel the current move of a handle, press the [Esc] key.
Use the distortion to give the layer a perspective effect.

The parameterized transformation
The parameterized transformation makes it possible to apply several types of
deformation to a layer in a single operation. Start by displaying the dialog via the menu
[Layer> Transformation> Transformed Parameter]. PhotoFiltre then displays the dialog
box for setting up the transformation.
All options offered are optional. You can change the angle of rotation in degrees, the
layer scale, or the incline along a vertical and horizontal axis by moving the sliders to the
left or right with the mouse or arrow keys. keyboard. Modifying an option triggers the
real-time update of the display.

Properties of the parameterized transformation
Note that this function can not be applied to the background layer (media).

Combination of rotation and inclination

Image size and cropping

Image size
• Use
The [Image Size] command lets you change the pixel dimensions (physical data),
resolution, and print size (logical data) of your image.
To resize an image, you can:
- use the menu [Image> Image Size]
- press the [Ctrl + H] keys
- click on the icon
in the toolbar
- use the contextual menu (right click on the image)

Properties of the Image Size command
• Size in pixels / Memory
Here we find the indications of the width and the height of the image to be treated. The
memory is a value calculated by PhotoFiltre which indicates the place that will be taken
into memory by the new image (this data does not take into account the layers).
• New size
This group of parameters and options makes it possible to modify the physical or logical
properties of the image.

[Width] and [Height] settings
These settings allow you to manually change the width and height of the image. You can
specify a size in pixels, in percentage, in cm, or in inches. The sizes in pixels and in
percentage are called physical, because they are not related to the resolution whereas
the sizes in cm or in inches are said logical, because they are calculated according to
the resolution. The percentage corresponds to an enlargement coefficient. Changing the
size automatically updates the value of the Memory setting.
Percentage beaches:
1. 10 to 99%, the picture will be reduced
2. 100%, the picture will not be changed
3. Greater than 100%, the image will be enlarged
The default unit can be customized via the [Tools> Preferences> Defaults]
command.
See the Customize PhotoFiltre chapter for more information on setting up the unit.
The [Resolution] setting
The resolution indicates the number of pixels over a certain length. This is defined in dpi
(dot per inch) or dpi (dots per inch). A resolution in inches (1 inch = 2.54 cm) or cm can
be indicated. The resolution is especially important for printing, the higher it is, the better
the print quality.
The resolution is retrieved in the EXIF metadata when opening JPEG and TIFF
images.
[Keep proportions] option
This option automatically updates the width when you change the height, and vice versa
to keep the ratio between height and width constant.
[Resampling] option
Resampling is the act of modifying the physical dimensions (in pixels) of an image. If you
decrease the number of pixels, information is removed from the image. If you increase
the number of pixels, new pixels are added. PhotoFiltre offers several modes of filtering
when applying resampling, but it is advisable to use the automatic mode in the majority
of the cases.
The management of resampling depends on the chosen unit:
Pixels or% : The [Resampling] option is inaccessible. It is possible to modify
the dimensions and / or the resolution independently. The filtering mode
chosen from the drop-down list will be applied.
cm or inches : The [Resampling] option is available.
- The box is checked:
1. It is possible to modify the dimensions and / or the resolution
independently.

2. The dimensions in pixels are recalculated according to the new data.
3. The selected filter mode from the drop-down list will be applied.
- The box is unchecked:
1. Dimensions and resolution are related. If you change the dimensions, the
resolution is recalculated. Similarly, if the resolution is changed, the
dimensions are recalculated.
2. Pixel dimensions are not changed.
3. No filtering mode will be applied (the filter drop-down list is inaccessible).
If the image is transparent, PhotoFiltre always uses automatic filtering.
If the [Keep Proportions] option is unchecked, resampling is mandatory
regardless of the unit chosen.
[All layers] option
This option is active if the image is composed of multiple layers. It allows you to resize all
layers at once in one operation.
Changing the pixel dimensions of an image may result in a loss of image
quality and sharpness, or a pixelated effect. It is therefore advisable to use the
Soften, Harden or Reinforce filters to correct defects.
• Notes
When preparing an image for the Web, it is best to set the size of the image in pixels,
taking into account the resolution of the screens. Remember that changing pixel
dimensions affects the visual quality of an image, but also its print quality. If, on the other
hand, your image is intended for printing, it is best to define its size according to the print
dimensions (in centimeters or inches) and the resolution (pixels per inch or pixels per
cm). It is advisable to change the print size directly in the print module, but you may
decide to keep these values for compatibility with other applications.
You can use the [File> Image Properties] command or the keyboard shortcut
[CTRL + J] to control the dimensions of the image at any time.

Adapt the image
• Use
The [Fit Image] command is a simplified version of the [Image Size] command. It is
essentially intended to prepare the images for the Web since it only allows to modify the
dimensions in pixels.
To adapt the size of the image, you can:
- use the menu [Image> Adapt image]
- use the contextual menu (right click on the image)

Properties of the Fit Image command
• The [Width] and [Height] settings
These settings change the width and height in pixels of the image. The data entered are
not exact values, but they represent limits. In other words, it means that the image is
resized with the maximum values entered.
You can change the default limits via the [Tools> Preferences> Defaults] command.
See the Customize PhotoFiltre chapter for more information on setting these values.
• The [Optimize] option
If this option is selected, the smoothing mode enables bilinear interpolation when
changing the size. Thus, the result is of a better visual quality.
• The option [Allow deformation]
If this option is enabled, the image will have the exact size defined by the [Width] and
[Height] parameters. Therefore, it will be distorted if the reports are not identical. If,
however, this option is not activated, the proportions will be kept to avoid distortion.
• The predefined limits
PhotoFiltre offers the most common limits that are essentially screen sizes. Selecting an
item from the list automatically updates the [Width] and [Height] input boxes.
• The [All Layers] option
This option is active if the image is composed of multiple layers. It allows you to resize all
layers at once in one operation.

Size of the work area
• Use
The [Work Area Size] command lets you change the size of the image's work area
(media), either by enlarging it (adding a background) or by reducing it (cropping).
To change the size of the image canvas, you can:

- use the menu [Image> Size of the work area]
- press the [Shift + H] keys
- click on the icon in the toolbar
- use the contextual menu (right click on the image)

Command Properties Size of the Work Area
• Size in pixels / Memory
Here we find the indications of the width and the height of the image to be treated. The
memory is a value calculated by PhotoFiltre which indicates the place that will be taken
into memory by the new image (this data does not take into account the layers).
• New size
This group of parameters and options makes it possible to modify the physical or logical
properties of the image.
[Width] and [Height] settings
These settings allow you to manually change the width and height of the image. You can
specify a size in pixels, in percentage, in cm, or in inches. The sizes in pixels and in
percentage are called physical, because they are not related to the resolution whereas
the sizes in cm or in inches are said logical, because they are calculated according to
the resolution. The percentage corresponds to an enlargement coefficient. Changing the
size automatically updates the value of the Memory setting.
The default unit can be customized via the [Tools> Preferences> Defaults]
command.

See the Customize PhotoFiltre chapter for more information on setting up the unit.
The [Position] parameter
It allows to position the image on the work area in nine different places.
Three cases can occur:
1. The entered dimensions are larger than the original dimensions, the parameter
indicates where the image will be positioned (adds a background).
2. The entered dimensions are smaller than the original dimensions, the parameter
indicates the part of the image that will be retained (cropping).
3. In other cases, there will be a combination of the first two.
The [Background] setting
It allows you to apply a color to the work area. This parameter is ignored in the case of a
crop.
The option [Background]
It allows you to choose a pattern to apply to the background. The pattern has priority on
the bottom. In the case of a transparent pattern, it will reveal the background color at the
transparent areas. This option is ignored in the case of a crop.

Crop an image
Cropping consists of selecting and deleting part of an image to improve its composition.
In other words, it reduces the size of the work area. In this way, you also decrease the
amount of memory required for image editing.
When you crop an image containing multiple layers, only the background is actually
cropped, the layers are only moved.
1. Create a selection using the mouse or via the [Manual Setting] dialog box.
2. Set the selection smoothing mode using the [Selection> Smoothing] menu.
3. If the shape of the selection is not rectangular, set a background color in the color
palette for filling out-of-shape areas.
4. Click the [Image> Crop] menu or use the context menu (right-click on the image and
Crop Image).
See Working with Selections for more information on creating a selection .

On the left, the original image, on the right the image after
a crop with an Ellipse selection
In some cases, your image may contain a uniform outline (unwanted frame, residue after

a scan). It is best to use Auto Crop using the [Image> Auto Crop] menu.

On the left, the original image, on the right the image after a
automatic cropping

Outside Framing
The [External Framing] command allows you to add a frame to an image without
trimming its contents and without distorting it. PhotoFiltre automatically changes the size
of the work area by adding equal margins to each side of the image.

Command Properties External Framing
• The [Width] parameter
This parameter is used to define the width in pixels of the frame.
• The [Color] setting
This parameter indicates the fill color of the frame.
• The option [Background pattern]
It allows to apply a pattern for filling the frame. Check the box and choose the reason in
the search box. The pattern takes precedence over the color. In the case of a
transparent pattern, it will reveal the fill color at the transparent areas.

On the left, the original image, on the right the image after a frame

outside using a woody pattern.
Apply an external frame several times in succession by combining different
colors and patterns in order to obtain more elaborate frames.

Outer shade
The [Outer Shade] command allows you to add a drop shadow outside an image without
trimming its content and without distorting it. PhotoFiltre automatically changes the size
of the work area by adding, if necessary, margins on each side of the image.

Outer Shadow command properties
• The [Color] setting
This parameter sets the color of the shadow.
• The [Width] parameter
This parameter is used to define the width of the drop shadow.
• The [Opacity] setting
Opacity defines the intensity with which the drop shadow is displayed. The higher this
value, the more the shadow will be visible and opaque. Be sure to set the background
color or pattern for translucency and smoothing effects.
• The option [Margin]
This option allows you to create an outside frame in addition to shading. The frame uses
the [Background] setting and the [Background Pattern] option for the fill.
• The [Style] parameter
PhotoFiltre supports two drop shadow styles that allow you to change the borders of the
shadow and play on the transition with the background color or with the fill pattern. The
[Flat] style creates a shadow with sharp edges. The [Smooth] style creates a shadow
with progressive borders. This last style offers a better visual quality.

• The [Background] setting
This setting defines the background color, and therefore, the merging color for
translucency and smoothness. It is linked to the [Opacity] and [Style] parameters and the
[Background Pattern] option.
• The option [Background pattern]
It allows to apply a pattern for filling the bottom located below the drop shadow. Check
the box and choose the reason in the search box. The pattern takes precedence over
the background color. In the case of a transparent pattern, it will reveal the background
color at the transparent areas.

On the left, the original image, on the right the image after the application
an outer shade using a mottled pattern and a margin.

Draw with PhotoFiltre

Using drawing tools
Drawing tools are available only in 16 million colors (RGB or RVBA). They always apply
to the active layer. The active layer must be Bitmap type.
1. Start by setting a foreground color and possibly a background color.
2. Select the tool that seems best suited to your needs (brushes are used to draw
continuous lines of color while the airbrush applies spray effects).
3. Define the size of the tool (radius, thickness, ...).
4. Define the additional options (pressure, dispersion, pattern, ...).
Using a selection acts as a stencil and prevents overflow during drawing.
Pressing the [Space] key forces the motion tool to position itself more easily on
the part of the image to be drawn.

The [Line] tool
Click with the left mouse button on the image at the position corresponding to the first
end of the line. While holding down the button, move around the image to reach the
position of the other end of the line. You can add arrowheads using the [Arrow] option.
The [Line] tool uses a special selection that allows real-time preview, so you can cancel
the plot at any time by pressing the [Esc] key.
By holding down the [Shift] key while moving, you get perfectly horizontal,
vertical or 45 degree angle lines.
The [Style] option lets you draw different line styles (see below). For the outline
line style, the outline color is the foreground color (in the color palette), the
background is the background color.

Tools [Brushes]
Click with the left mouse button on the image to define a starting point. Then, while
holding down the button, move around the image. The plot is done in real time.
Holding down the [Shift] key while moving will produce a perfectly horizontal or

vertical path.
To draw a line using one of the brushes, click to set a starting point in the
image. Then, while holding down the [Shift] key, click to set an end point.
By clicking the right mouse button, PhotoFiltre uses the background color
instead of the foreground color.
• The basic brushes

Basic brushes use simple shapes (circles, squares, oblique lines).
PhotoFiltre offers several styles of paths.
The style [Color]
It allows drawing with the foreground and background colors using a solid path.
The style [Rainbow]
It allows you to draw by automatically creating a gradient along the path.
The style [Pastel]
It allows to draw by imitating the pastel with the colors of front and background.
The style [Charcoal]
It allows to draw by imitating the charcoal with the colors of front and background.
The style [3D]
It allows drawing with the foreground and background colors by simulating 3D effects.

Sample paths with Color, Rainbow, Pastel, and 3D styles
• Advanced brushes
Advanced brushes use very different shapes and the effects are sometimes surprising.
1. Drop-down list proposing the different brushes of the
same series. The number to the right of the icon indicates
the size of the brush.

2. Clicking on this icon opens a context menu that allows you
to choose a series of brushes. The series of brushes are
stored in the [Brushes] folder of PhotoFiltre .
3. Pressing this icon applies vertical symmetry to the active
brush.
4. Pressing this icon applies horizontal symmetry to the
active brush.
5. Drop-down list with percentages of reduction or increase
of brush size. The scroll arrows to the left of the drop-down
button allow you to fine-tune the percentage.
6. The pressure gives more or less opacity to the plot.
7. The step is used to define the spacing between each
brush stroke when drawing.
8. If this box is checked, the pressure decreases
progressively during the plot. Otherwise, the pressure
remains constant.
9. Reminder of the plot style defined in the basic brushes
(Color, Rainbow, Pastel, Charcoal and 3D).
Advanced brushes use the plot style defined in the Brush tool (Color, Rainbow,
Pastel, Charcoal, and 3D) .
Advanced brushes use the foreground and background colors, but you can
combine the two by left-clicking and then right-clicking without moving the
mouse.
The step is disabled if the 3D plot style is set in the Brush tool .

The [Airbrush] tool
The [Airbrush] tool applies color spray effects by simulating airbrush bomb techniques.
Click with the left mouse button on the image to define a starting point. Then, while
holding down the button, move around the image. Spraying is done in real time.

The [Dispersion] option allows you to change the spacing of each point of impact.
The [Rainbow] option lets you draw by automatically creating a gradient along the path.
Holding down the [Shift] key while moving will produce a perfectly horizontal or
vertical path.
By clicking the right mouse button, PhotoFiltre uses the background color
instead of the foreground color.
You can add multiple layers of color by repeating several times in one place.

The [Fill] tool
The [Fill] tool allows you to fill adjacent pixels that have similar colors. Click on the part of
the image to fill. All pixels specified in the tolerance range are filled with the selected
foreground color or pattern.
• The [Pattern] option
Specify whether you want to fill the pixel area with the foreground color or with a pattern
(by checking the Pattern option or not). To use a pattern, it must be defined beforehand.
Access to the [Open], [Horizontal Symmetry] and [Vertical Symmetry] buttons
is available after the first opening of a pattern.
• The option [Opacity]
This parameter is used to change the opacity of the foreground color or selected pattern.

• The option [Tolerance]
The tolerance defines the color difference allowed to pass from one pixel adjacent to the
other. Values must be between 0 and 100. A low tolerance fills pixels whose color is very
close to that of the pixel you clicked while a high tolerance fills a wider range of pixels.
By clicking the right mouse button, PhotoFiltre uses the background color
instead of the foreground color.
Start with a low tolerance and gradually increase it until the result is right for
you.

The [Eraser] tool
The [Eraser] tool lets you erase areas of an image to reveal transparent pixels or
background color. It is used as a basic circular brush, but the result varies depending on
the context. If you are working on the background layer and the layer is not in
transparent mode, the pixels take on the background color. If the background is in
transparent mode or contains an Alpha layer, that is to say in RGBA mode, the pixels are
converted into transparent pixels and show the transparency checkerboard. If you are
working on a layer, the pixels are always converted to transparent pixels and let the
pixels in the lower layer appear.
Click with the left mouse button on the image to define a starting point. Then, while
holding down the button, move around the image. The scrub is done in real time.

1. This button toggles the shape of the eraser between
the Standard Brush and the Advanced Brush
By holding down the [Shift] key while moving, you get a perfectly horizontal or
vertical scrub.

To erase following the path of a line, click to set a starting point in the image.
Then, while holding down the [Shift] key, click to set an end point.
Use the eraser on a transparent GIF or PNG to edit the transparent areas.
To cancel scrubbing effects on Alpha type transparencies, use the eraser with
the [Invert] option. In this way, the retouched areas become opaque again.

The [Cloning buffer] tool
The [Clone Stamp] tool has two different functions depending on the [Pattern] option. If
this is enabled, the tool acts as a pattern buffer, otherwise it is the clone buffer function
that is used.
• The [Cloning Buffer] tool (without the [Pattern] option)
The [Clone Buffer] tool takes a sample from the image that will be applied to another part
of the image or another image. Each time the buffer is moved, the sampled sample is
applied using the same offset (translation). Two marks indicate the position of the initial
sample and the drawing position.
Place the mouse cursor on the part of an image in which you want to take a sample and
click while holding down the [Ctrl] key (the mouse cursor must be in the form of a buffer).
This sampling point will be the starting point for duplication. Release the mouse button
and the button. Then click in the same image or another image to define a starting point.
Then, while holding down the left button, move to the image. Duplication takes place in
real time.
It is possible to duplicate one part of a layer to another layer in the same image
or in another open image.
You can view the new sampling point using the right mouse button.
By holding down the [Shift] key while moving, you get a perfectly horizontal or
vertical duplication.
The [Fixed] option does not perform the translation while moving and always
duplicates the initial part. It is used to make duplicates one by one with one click.
With this option, the [Step] parameter is accessible.
The [Accurate] option avoids smoothing the outline of the duplication.

The [Broadcast] option applies a dispersion effect to duplication.

Examples of cloning in the same image and in two different images
• [Pattern Stamp] tool (with the [Pattern] option)
The [Pattern Stamp] tool lets you apply a pattern to the image by drawing. To use this
tool, you must define a pattern beforehand. It is used as a basic brush of circular shape.
Click on the image to set a starting point. Then, while holding down the button, move
around the image. The drawing is done in real time.
Holding down the [Shift] key while moving will produce a perfectly horizontal or
vertical path.
The [Fixed] option allows you to not translate during the move and always
duplicates the original part of the pattern. It is used to make one-shot impacts with
one click. With this option, the [Step] parameter is accessible.
The [Accurate] option avoids smoothing the outline of the pattern.
The [Broadcast] option applies a dispersion effect to duplication.
Access to the [Open], [Horizontal Symmetry] and [Vertical Symmetry] buttons
is available after the first opening of a pattern.

The tool [Nozzle]
The tool [Nozzle] (or tube) is a series of patterns contained in a file. These patterns are
displayed successively on the image by moving and holding down the mouse button. At
the first use of the nozzle, the first pattern of the series is displayed. When resuming a
new edition, the first pattern displayed will be the one following the last displayed.
1. Drop-down list proposing the different nozzles. The miniature
represents the first motif in the series. The number on the right
of the thumbnail indicates the size in pixels of the nozzle.

2. Drop-down list proposing the percentages of reduction or
increase of the size of the nozzle. The scroll arrows to the left of
the drop-down button allow you to fine-tune the percentage.
3. The pressure gives more or less sharpness to the nozzle.
4. The pitch is used to define the spacing between each
nozzle's footprint when drawing. The smaller the step, the more
the footprints will overlap each other.
To start the drawing with the first pattern in the series, hold down the [Shift]
key while moving. Release the [Shift] key as soon as the first pattern is displayed.
Using the [Ctrl] key forces the display of the current pattern.

The [Pipette] tool
The [Eyedropper] tool lets you select a color from an image to make it the new
foreground or background color. This color can be used by drawing tools and some
filters. To select a new foreground color from an image, click on the color with the left
mouse button. To select a new background color, right-click.
As you drag the [Eyedropper] tool onto the image with the mouse while holding down the
button, the color selection box (foreground or background) is updated in time real.
To use the [Eyedropper] tool temporarily while using another drawing tool, hold
down the [Ctrl] key. The cursor of the mouse will take the form of a pipette.
You can change the foreground color by directly entering RGB values in HTML
format in the Web edit box (for example, # FF0000 represents the color red)

The [Move] tool
The [Move] tool moves the visible area of the image when the zoom magnification is high
and the image is not fully visible on the screen. It scrolls the image both horizontally and
vertically, unlike Windows scrollbars that allow moving in one direction at a time.
The [Move] tool is often used during drawing or retouching operations, as high
magnification is often required to obtain a more accurate result.

For large images and high display magnifications (high zoom), use a jerky
mode for faster movement.

Touch up a freehand image

use
The retouching tools make it possible to modify certain zones of the image, freehand and
very precisely. They are only available in 16 million colors (RGB or RGBA) and they still
apply to the active layer. The active layer must be Bitmap type.
1. Select the tool that seems best suited to your needs.
2. Choose a department from the list of predefined departments. Start with a medium
radius.
3. Set the pressure. Start with a medium pressure.
The use of a selection acts as a stencil and prevents overflow during
retouching operations.
Work preferably with a display zoom of 200% or 300%.

The tool [Blur]
• Definition
The [Blur] tool is used to:
- soften or smooth certain areas of the image to make them less distinct
- dilute other retouching effects (cloning buffer, finger, etc.)
- remove noise in a photograph or excessive compression effects, for example after
JPEG compression is too high
• Use
Click with the left mouse button on the image to define a starting point. Then, while
holding down the button, move slowly in the image. Go back and forth by repassing
several times in the same place. The editing is done in real time. Release the mouse
button to complete the changes.

Dilution of retouching effects after
removal of electrical cables.

The [Finger] tool
• Definition
The [Finger] tool simulates a spreading effect. It picks up the colors in the starting area

(defined by the radius), then spreads them according to the movement of the mouse
cursor. This tool can also be used to eliminate some imperfections on faces in portrait
photographs.
• Use
Click with the left mouse button on the image to define a starting point. Then, while
holding down the button, move slowly in the image. Go back and forth by repassing
several times in the same place. The editing is done in real time. Release the mouse
button to complete the changes.

Elimination of pimples on the face.
This tool also changes the Alpha layer in RGBA mode if the [Draw on Alpha
Transparency] option is enabled in the preferences.

The [Retouch] tool
• Definition
The [Retouch] tool allows you to correct the contrast or saturation of certain areas of the
image, eliminate a red-eye effect due to flash, or erase an area in the image. PhotoFiltre
offers several correction functions.

Correction functions .
• Correction functions
Gamma (-) and Gamma (+)
These two functions make it possible to lighten or darken certain areas of the image.
They use a gamma correction. Gamma correction looks like a contrast adjustment, but
uses a more complex algorithm. The dark and light tones are very little modified, while
the midtones are more so. This method ensures optimal fit while preserving shadows
and reflections.

Color (-) and Color (+)
These two functions make it possible to modify the saturation of color of certain zones of
the image. The change in saturation is to increase or decrease the intensity (or purity) of
the color, a dull blue can become bright blue for example. Therefore, by increasing the
saturation, the image becomes more colorful, and by reducing it, the image will lose
color and tend toward grayscale.
Sharpness (-) and Sharpness (+)
These two functions make it possible to modify the sharpness of certain zones of the
image. The change in sharpness makes it possible to catch some blurs on an image or
to attenuate areas that are too pronounced.
Red eye
The red eye effect occurs when the camera's flash is reflected in the back of the eye.
This function allows you to easily eliminate this effect.

Elimination of the red eye effect.
Magic eraser
This function allows you to automatically erase certain areas of the image by recovering
the pixels that are at the edge of them. Depending on the type of zone to be erased, this
function offers 3 operating modes:
- Radial: This mode allows you to clear the spots.
- Horizontal: This mode allows you to erase tracks that have a more or less horizontal
layout.
- Vertical: This mode allows you to erase tracks that have a more or less vertical layout.

Erase the red line by applying the Horizontal mode.
To obtain an optimal result, it is recommended to proceed with successive
clicks along the path to be erased.

• Use
After selecting a correction function, left-click on the image to define a starting point.
Then, while holding down the button, move slowly in the image. You can also proceed by
successive click for a more precise result. Proceed back and forth by repeating several
times in the same place if necessary. The editing is done in real time. Release the
mouse button to complete the changes.

The tool [Distort]
• Definition
The [Warp] tool lets you apply a warp to a part of the image.
• Deformations
Spiral
This option creates a spiral with a left winding using the left click of the mouse or a spiral
with a right winding using the right click.
Zoom in
This option allows you to magnify an area of the image.
Expand
This option dilates, by spreading from the center to the outside, an area of the image.
Contract
This option contracts, spreading from the outside to the center.

Example of using the tool [Distort]
The diameter of the deformation is a function of the [Radius] parameter.

The [Art Brush] tool
• Definition

The [Art Brush] tool lets you apply filters along a path instead of applying it to the entire
image.

Filters available .
• Use
After selecting a filter from the list, left-click on the image to define a starting point. Then,
while holding down the button, move slowly in the image.

Applying Pointillism, Oil Painting, Tint and Grayscale filters.
The [Duotone] filter uses the foreground and background colors. PhotoFiltre
always chooses the darkest color for the drawing and the lightest color for the
background. As a result, color inversion and intensity adjustments may occur.

Apply filters

Definition
Filters are special functions that apply effects to your images, for example, artistic or
aesthetic effects, deformations, textures. The filters are accessible via the [Filter] menu
and are categorized.
Applying filters may take a long time, especially on large images. Therefore, test the
filters on a small area of the image.
Most filters offer the [Preview] button that allows you to see the result on the image in
real size.
PhotoFiltre follows the following rules:
1. The image must be in RGB or RGBA mode for the filters to be accessible.
2. Filters apply to the active layer.
3. The active layer must be Bitmap type.
4. If a selection is active, the filters apply to the selected area.
The last applied filter is proposed by the command [Edit> Repeat <name of the
filter>].
To apply a filter to a Text layer, you must first convert it to a bitmap layer.

Mitigate the effects of a filter
Although the [Mitigate] command can be accessed after an adjustment, drawing, or fill
operation, it is mostly used after applying a filter to smooth out the effects.

Property of the Mitigate command.
To use the attenuation function, you can:
- click on the menu [Edit> Mute <command name>]
- press [Shift + Ctrl + Z]
• The [Opacity] setting
This single parameter makes it possible to blur the effects of the previous operation by
partially restoring the state of the image before its saving (in the history of the
modifications). For example, an opacity of 70% corresponds to a restoration of the
previous state of 30% (ie 100% - 70%).
You can call this command repeatedly without changing the history.

Lexicon

In this glossary, you will find the definitions of the main terms used in the filters.
• Level
This term is generic, it represents the intensity with which a filter applies or a quality of
precision.
• Threshold
It defines a minimum value of light intensity from which the filter or some properties of
the filter apply. It allows to preserve certain details of the image.
• Gain
The gain is the percentage applied to the final result. If it is 100%, the result is complete.
If it is less than 100%, the result is attenuated. Finally, if it is greater than 100%, the
result is reinforced.
• Ray
It defines the radius of action of the filter, that is to say, the number of adjacent pixels to
be tested during the processing of a pixel. The higher the radius, the longer the filter
processing time will be.
It is advisable to start with small radius values

Filters [Attenuation]
• Definition
These filters are grouped in the [Filter> Damping] menu. They help attenuate and
smooth certain areas of the image. They are very useful for retouching.
• List of filters
- Soften
- Blur
- Even more vague
- Smooth

Applying a Blur effect.

Filters [Sharpness]
• Definition

These filters are grouped in the [Filter> Sharpness] menu. They enhance the sharpness.
They are very useful for retouching.
• List of filters
- Sharper outlines
- Sharper
- Even more clear
- Enhancement

Sharpening the sharpness to improve the details.

Filters [Noise]
• Definition
These filters are grouped in the [Filter> Noise] menu. They allow you to add or remove
noise. Noise is generated by pixels with random color levels. Noise suppression
removes the effects of dust. Adding noise helps to make retouched areas look more
realistic.
• List of filters
- Add noise
- Inner blur
- Anti dust

Remove noise using the dust filter.

The filters [Relief]
• Definition
These filters are grouped in the [Filter> Relief] menu. They enhance the relief effects.
They are very useful for retouching.

• List of filters
- Softened Relief
- Relief
- Even more relief

The relief effect enhances the texture of the image.

The filters [Color]
• Definition
These filters are grouped in the [Filter> Color] menu. They can change colors, for
example by increasing or decreasing the saturation, changing the hue, or applying a
gradient.
• List of filters
- Shades of grey
- Sepia
- Posterize
- RGB inversion
- Hue variation
- Revive the colors
- tarnishing the colors
- Night effect
- Sunset effect
- Colorize
- Degraded
- Colored filter

Application of the Night Effect and a sepia tint.

Filters [Artistic]
• Definition

These filters are grouped in the [Filter> Artistic] menu. They can simulate artistic effects
by matching the techniques used in drawing. The effects obtained are not always
realistic because they depend on the dimensions of your image. If the image is too small,
the effects will be too pronounced. If, on the other hand, it is too big, the effects may not
be sufficiently visible.
• List of filters
- Pointillism
- Oil painting
- Palette knife
- Watercolor
- Pastels
- Comic
- Colouring pencils
- Black pencil
- Charcoal / Sanguine
- Chinese ink
- Airbrush
- Spreading
- Crystallization
- Inked contours

Applying an Oil Painting and Pointillism effect.
Use the [Edit> Mute] command to fade the effects of a filter.
Try to combine several artistic filters.

Filters [Optical effect]
• Definition
These filters are grouped in the [Filter> Optical Effect] menu. They make it possible to
simulate optical effects, for example a scene taken in motion or in foggy weather.
• List of filters
- Mist
- Soft focus
- Gaussian blur
- motion blur
- Radial blur
- Circular soft
- Fragmentation

Applying a motion blur effect attenuated to 70%.
Use the [Edit> Hold] command to fade the effects of a filter.

The filters [Distort]
• Definition
These filters are grouped in the [Filter> Distort] menu. They make it possible to deform
an image or a selected area by applying trigonometric functions to it.
• List of filters
- Trapeze / Perspective
- Spherification / Lens
- Spiral
- Ellipse
- Ripple
- Glass
- Reflection in the water
- Curve

Application of Spiral deformation.

Filters [Aesthetics]
• Definition
These filters are grouped in the [Filter> Aesthetics] menu. They allow to create aesthetic
effects, that is to say decorative or stylized effects. These filters are of various types,
they can as well create contours as raster effects.
• List of filters
- Tiles
- Puzzle
- Mosaic

- Cross stitch
- Diffusion
- Scan lines
- Progressive contour
- Drop shadow
- 3D contour

Applying a Tiles effect.
The Outline and Drop Shadow filters also change the Alpha layer to RGBA
mode if the [Draw on Alpha Transparency] option is enabled in the preferences.

Filters [Aging]
• Definition
These filters are grouped in the [Filter> Aging] menu. They allow to give an old
appearance to a photograph.
• List of filters
- Black and white
- Sepia
- Old photo

Applying the old photo filter.

Filters [Framing]
• Definition
These filters are grouped in the [Filter> Framing] menu. They allow you to frame an
image or a selected area by applying 3D effects in relief or stylized. They are useful for
creating buttons for the web.
• List of filters

- Simple frame
- Slide
- 3D button
- Embossed edges

Combination of Simple Frames and Smooth Relief Edges.
You can combine several types of framing.
The Single Frame and Slide filters also modify the Alpha layer in RGBA mode if
the [Draw on Alpha Transparency] option is enabled in the preferences.

Filters [Flatten]
• Definition
These filters are grouped in the [Filter> Flatten] menu. They simulate a flattening effect
by removing details and adding relief in the contours.
• List of filters
- Stamping
- Embossed paper
- Photocopy
- Plaster

Applying the stamping filter.

Filters [Contours]
• Definition
These filters are grouped in the [Filter> Contours] menu. They allow you to simulate
contour lines by copying techniques used in the drawing. Some of these filters add grain
or texture.

• List of filters
- Outlines in color
- Black contours
- White chalk

Applying the Color Contours filter.

The filters [Texture]
• Definition
These filters are grouped in the [Filter> Texture] menu. They make it possible to add
effects of substance (texture), for example grain, cracks or meshes. They are often used
in addition to artistic filters.
• List of filters
- Crackling
- Fine mesh
- Wide mesh
- Old canvas
- Grain paper
- Zebra skin
- 1 pixel out of 2
- Sandstone
- Wire rack
- Zigzag
- Other

Old canvas texture application.
See also chapter The Texture module .

Filters [Miscellaneous]
• Definition

These filters are grouped in the [Filter> Miscellaneous] menu. They are of various kinds
and can both create a grid and create your own effects using the [Custom] filter. This
filter makes it possible to modify the brightness of each pixel of the image by using a
method of convolution. Each pixel value is calculated based on the values of the
adjacent (neighbor) pixels.
• List of filters
- Custom
- Minimum
- Maximum
- Screening
- Grid
- Radial mask

Creating a grid.
The Grid filter also changes the Alpha layer in RGBA mode if the [Draw on
Alpha Transparency] option is enabled in the preferences.

Improve an image
Introduction
Even if your photo looks bad, PhotoFiltre offers functions that correct some imperfections.
Most of these functions are in the [Setup] menu and apply to the entire image or part of the
selected image. They are available only in 16 million colors (RGB or RGBA) and still apply
to the active layer. The active layer must be Bitmap type.
You should never work on your original photos because in some cases you will not be able
to go back.
Duplicate your photos and work on the copies.

Automatic corrections
Before launching a setting function that you have to set manually, you can try an automatic
correction method. PhotoFiltre offers automatic level correction and automatic contrast
correction.
If your photo is poorly exposed, you can attempt an automatic level correction by using the
[Adjustment> Auto Levels] menu or clicking the button.
in the toolbar. This function
adjusts the red, green and blue layers separately.
If your picture seems dull, you can try an automatic contrast correction using the
in the toolbar.
[Adjustment> Auto Contrast] menu or by clicking the button.

With automatic level correction, the image becomes clearer and
find colors closer to reality .
If the correction effects seem too pronounced, use the [Edit> Mute] function.

Brightness and contrast
This setting is quite simple, but it only allows to correct minor defects such as a picture a
little dark or a little dull. In general, brightness and contrast work together. For example, if
you increase the brightness, your image will be a little duller and you will have to increase
the contrast.

Properties of the Brightness and Contrast Functions
You can create an adjustment layer so that you do not edit the image directly.
Click the [Adjustment> Brightness] or [Adjustment> Contrast] menu. PhotoFiltre displays a
window that allows you to set the function. Using the mouse, move the top slider to change
the brightness or to change the contrast. You can also edit a color layer separately for finer
adjustments.

By increasing the contrast, the image becomes less dull.
Buttons

and

vary the brightness of -8% and + 8%.

Buttons

and

vary the contrast from -10% to + 10%.

Poorly exposed photo and gamma correction
In case of bad exposure, you get an underexposed or overexposed image. To correct
these defects, the most suitable function is the gamma correction.

Properties of the gamma correction function
You can create an adjustment layer so that you do not edit the image directly.
Click the [Setup> Gamma Correction] menu. PhotoFiltre displays a dialog box that allows
you to set the function. Use the mouse to move the slider to the left, to decrease it, and to
the right to increase it. You can also edit a color layer separately for finer adjustments.
Gamma correction looks like a brightness adjustment, but uses a more complex algorithm.
The dark and light tones are very little modified, while the midtones are more so. This
method ensures optimal fit while preserving shadows and reflections.

By raising the level, the image becomes lighter and details appear.
Buttons

and

vary the level of -0.2 and +0.2.

See also chapter Using the histogram .

Hue and saturation
Even if the tones in your image look good, the colors may be dull or out of line with reality.
In this case, you can correct the hue and saturation. The hue adjustment is to move the
colors in the visible spectrum (or rainbow), a red color can become green for example.

By increasing the hue, a red color may turn green.
Adjusting the saturation is to increase or decrease the intensity (or purity) of the color, a
dull blue can become bright blue for example. Therefore, by increasing the saturation, the
image becomes more colorful, and by reducing it, the image will lose color and tend toward

grayscale.

Properties of the Hue / Saturation function
To correct saturation or hue, you can also create an adjustment layer.
Click the [Setup> Hue / Saturation] menu. PhotoFiltre displays a window that allows you to
set the function. Using the mouse, move the top sliders to change the hue or to change the
saturation. You can also edit a color layer separately for finer adjustments.

By changing the hue, the fruits that looked ripe are
green again.
Buttons

and

vary the saturation of -20% and + 20%.

The color balance
Many digital camera (APN) camera users experience color problems, and in particular, an
excess of red color. In general, the problem is related to the white balance. The photos
taken outdoors are correct while the photos taken inside often have a dominant red (more
rarely green or blue). To correct this problem, the most suitable function is the color
balance.

Properties of the Color Balance function
Click the [Setup> Color Balance] menu. PhotoFiltre displays a window that allows you to
set the function. Using the mouse, move the corresponding slider to the color cast to be
rectified. For example, to reduce the red cast, move the top slider to the cyan color
(opposite to the red color). Adjustments are applied to the brightness or separately on dark
tones, midtones or highlights.

Reduction of the dominant red.
Some color cast can be corrected automatically using the [Setup> White Balance]
command.

Custom setting
This setting allows you to change brightness, contrast, saturation and level in one
operation.

Properties of the Custom function
To use this command, you can:
- use the menu [Setup> Custom]
- click on the button
in the toolbar
PhotoFiltre displays a window that allows you to set the function. Using the mouse, move
the slider for the type of adjustment to be made. You can also edit a color layer separately
for finer adjustments.

Decrease a backlight effect
In a photo against the light, some details are very dark because of the strong light source.
To correct this type of image, you only need to modify the dark areas without touching the
light areas to avoid the effects of saturation. In this case, the most suitable function is the
correction of levels.

Properties of the Levels function
Click the [Setup> Levels] menu. PhotoFiltre displays a window that allows you to set the
function. This window is composed of three groups (dark tones, medium tones, light

tones).
Each group contains sliders that can be moved left and right. For example, to increase the
brightness of dark tones, move the slider from the intensity of dark tones to the left
(decrease). The setting of this function is very delicate, proceed by small movements each
time.

The details are more visible in the dark areas after a
reduced intensity of dark tones.
In addition, it is advisable to use the gamma correction and brightness and
contrast functions.

Adjustment with the use of curves
This setting allows you to apply a gamma correction, change the contrast, brightness,
levels on each color layer. It is based on the use of Béziers curves.
To display this setting use the [Setup> Curves] menu. PhotoFiltre displays a parameter
window. Using the mouse, move the type points a and b to make adjustments. You can
also select a color layer for finer adjustments.

Properties of the Curves function
at. Main point (or vertex or node)
b . Checkpoint (or handle)
vs. Guideline that unites a node at a control point.

1. [Edit] function
It allows you to change the location of a point, keeping the left click pressed on it and
moving the mouse. If the [Smooth] function is active, you can change the curvature of the
line on either side of the point by manipulating the control points.
2. [Add] function
It allows to add a new point on the curve by clicking on it at the desired place. A new point
can only be created at a certain distance from the previous one (at least 12 pixels).
3. [Delete] function
It allows you to delete a point by clicking on it. The curve is redrawn between the previous
point and the next one.
4. [Smooth] function
By executing this function, PhotoFiltre automatically calculates the default smoothing of the
curve.
This function enables the management of control points and guidelines by
positioning on a point.
5. [More neat] function
By executing this function, the plot uses only segments of straight lines.
6. [Reset] function
It resets the default setting to the selected brightness or color layer. By clicking on it, the
curve becomes a simple straight line.
7. Function [Open]
By executing this function, a previously saved setting is loaded into a file. PhotoFiltre
displays the dialog box. It is positioned by default in the [Data] folder and displays the PFC
format files. Select the desired file and click [Open] to load the setting.
8. [Save] function
This function proposes to save a setting for future use. PhotoFiltre displays the dialog box
and is positioned by default in the [Data] folder. Type a new file name and click [Save].
Vector plots are saved in PFC ( PhotoFiltre Curve ) format.
Pressing the [Esc] key exits the [Curves] function at any time.
• Some examples of setting

Catch a blurred photo
In a photo, the blur is rarely voluntary. Most of the time, it is due to poor lens adjustment,
autofocus or camera shake. If the blur is not pronounced, you can try to increase the
sharpness.
Click on the [Filter> Sharpness> More Neat] menu or the button in the toolbar. This
command is not customizable, but you can execute it several times in order to accentuate
the effects by using the menu [Edit> Repeat <command name>] or by pressing the [Ctrl +
K] keys.

By applying the function twice, the image becomes clear.
If the blur is more pronounced, catching up is trickier because, by sharply increasing the
sharpness, image defects and noise also increase. PhotoFiltre offers the reinforcement
function.
Click the [Filter> Sharpness> Reinforcement] menu or the button
PhotoFiltre displays a window that allows you to set the function.

in the toolbar.

Properties of the Reinforcement function
The gain is the percentage applied to the final result. If it is 100%, the result is complete. If
it is less than 100%, the result is attenuated. Finally, if it is greater than 100%, the result is
reinforced. Start by selecting a small radius and increase as needed. In general, a radius
of value 2 or 3 gives a good result for an acceptable calculation time. The threshold makes
it possible to limit the pixels to be treated according to their light intensities. A large
threshold value rarely gives a good result, preferably select a threshold between 0 and 7.

Reinforcement application example (gain 150%, radius 2 pixels).
Proceed by progressive modification by checking the preview regularly.

Reduce noise
Sometimes your photo contains a lot of small parasitic grains that are also called noise. To
reduce noise effects, click the [Filter> Noise> Dust Control] menu or the button in the
toolbar. PhotoFiltre displays a window that allows you to set the function.

Properties of the dustproof function.
The gain is the percentage applied to the final result. It reduces the effect by selecting
values less than 100%. Start by selecting a small radius and increase as needed. In
general, a radius of value 2 or 3 gives a good result for an acceptable calculation time. The
threshold makes it possible to limit the pixels to be treated according to their light
intensities. A large threshold value rarely gives a good result, preferably select a threshold
between 0 and 7.

Dustproof with a medium radius and a threshold of 150.
Proceed by progressive modification by checking the preview regularly.

Replace a range of colors
Your photo is successful, but some colors do not satisfy you, for example a garment, the
color of the sky or the flower in the foreground. PhotoFiltre provides a function to rectify
this problem.
1. Begin by trimming, as precisely as possible, the area of the image to be processed. For
this, use a polygon or lasso selection.
2. Activate the smoothing of the selection using the [Selection> Smoothing> Contouring]
menu.
3. Click the [Setup> Replace Range] menu. PhotoFiltre displays a window that allows you
to set the function.

Properties of the Replace Range function.
4. Move the mouse over the image to see the pipette cursor. Click an area with the color
range to replace. It is advisable to select an average tone.
5. Select the new color gamut using the middle slider. The proposed colors are pure
colors.
6. Finally, select the tolerance. A good result often requires a high tolerance.

Replacement of the yellow range by a red range.
To replace a solid color with another solid color, use the [Setup> Replace Color]
command.

Use the histogram
use
The histogram is a graphical representation that allows to know the distribution of the
luminous intensities of the pixels. The Histogram function of PhotoFiltre makes finer
corrections of tones and overall brightness (or gamma level). This feature also provides
real-time preview.
To start the histogram, you can:
- use the menu [Settings> Histogram]
in the toolbar
- click on the icon

Properties of the Histogram

Choice of the layer to be treated
A color image in RGB mode makes it possible to build four histograms associated with
the different color layers:
- Distribution of brightness (or luminance). This distribution takes into account all the red,
green and blue layers.
- Distribution of the red layer
- Distribution of the green layer
- Distribution of the blue layer
The drop-down list at the top allows you to select the histogram to be processed.
Color layers can be edited separately. The result is the combination of all these

settings.

The histogram
The graphical representation shows the distribution of light intensities. On the x-axis,
there are the light intensities, the darkest on the left, the lightest on the right. On the
ordinate, we find the number of pixels of each light intensity.

Setting
• Entry levels
The input levels act on the different tones of the image. To vary the input levels, move
one of the three sliders below the histogram.
The black cursor
It acts on the dark tones. Moving the slider to the right darkens dark areas. This slider is
linked to the [Minimum] value just below.
The gray cursor
It acts on all tones with a higher coefficient for midtones. Moving the slider to the left
reduces the overall brightness (or gamma level). Moving the slider to the right increases
the overall brightness. PhotoFiltre uses an algorithm that maximizes shadows and
reflections. This slider is linked to the [Level] value.
The white cursor
It acts on light tones. Moving the slider to the left intensifies the bright areas. This slider
is linked to the [Maximum] value just below.
• Pipettes
Pipettes can be used to search the image directly for the color of a pixel to determine the
input level for dark tones (pipette on the left) or tones on the right (pipette on the right).
Click in the image, with the left mouse button where you want to recover the color of a
pixel. The cursor associated with the pipette is automatically moved.
• Output levels

Output levels are set by moving the sliders below the gradient to black and white.
The black cursor
Moving the slider to the right brightens the dark areas. This slider is linked to the
[Minimum] value just below.
The white cursor
Moving the slider to the left darkens the light areas. This slider is linked to the [Maximum]
value just below.
• Information values
The value [Average]
This data indicates the average light intensity. It is the sum of the luminous intensities of
each pixel divided by the number of pixels.
The value [Median]
This data indicates the median value of the light intensities. It corresponds to the value
for which the number of pixels, having a lower luminous intensity, is equal to the number
of pixels having a higher luminous intensity.
The value [Pixels]
This data indicates the number of pixels used in the processing.
• The [Histogram] option
If the box is checked, the graphical representation shows the distribution of the luminous
intensities in real time.

Perspective and horizon correction

Perspective correction
When photographing a low-angle building, the perspective of the image obtained is often
very pronounced. It is possible to delete this perspective by using the Perspective
Correction function.

Properties of the Perspective Correction function
1. Click the [Image> Perspective Correction] menu. PhotoFiltre displays a window that
allows you to set the function. This window is composed of two parts. The left side
displays a thumbnail of the image to be processed and contains the adjustment sliders.
The right side displays a preview of the result in real time.
2. Using the mouse, move the adjustment sliders. By this movement, bring the grid
closer to the vanishing lines of the perspective of the miniature on the left. Check the
result in the preview window on the right. The sliders have an independent displacement
if the [Symmetry] box is unchecked, otherwise those on the same side move
symmetrically.
3. Confirm the settings with the [Ok] button. PhotoFiltre applies an automatic crop of the
image if necessary.
• The [Grid] option
This option displays or hides the cue grid. In the majority of cases, the display of the grid
makes it possible to have a more precise adjustment.
• The [Symmetry] option
If the box is checked, the movement cursors are linked horizontally and vertically and
always position themselves symmetrically. If the box is unchecked, the sliders move

independently.
• The [Color] option
It allows you to change the color of the grid. Change it only if the grid is not very visible
on the thumbnail of the image.

Straightening of the lines of leaks.
Use the [Edit> Undo] function before repeating a correction on the same image.
In this way, the position of the sliders is preserved.

The horizon line correction
As a result of improper positioning when taking a photograph, the horizon line may be
inclined. To straighten the horizon line and thus the entire image, you can use the
Skyline Correction function.

Properties of the Skyline Correction function.
1. Click the [Image> Skyline Correction] menu. PhotoFiltre displays a window that allows
you to set the function. This window is composed of two parts. The left side displays a
thumbnail of the image to be processed and contains the adjustment sliders. The right
side displays the rotation angle and a preview of the result in real time.
2. Using the mouse, move one of the sliders to bring the grid into alignment with the
horizon of the left thumbnail. Check the result in the preview window on the right.

3. Confirm the settings with the [Ok] button. PhotoFiltre applies an automatic crop of the
image if necessary.
• The [Grid] option
This option displays or hides the cue grid. In the majority of cases, the display of the grid
makes it possible to have a more precise adjustment.
• The [Auto Cropping] option
If the box is checked, PhotoFiltre performs an automatic cropping at the end of
processing in order to remove the margins caused by the rotation. If the box is
unchecked, the image retains its original dimensions, but may also contain unwanted
white margins.
• The [Color] option
It allows you to change the color of the grid. Change it only if the grid is not very visible
on the thumbnail of the image.

Straightening the skyline followed by automatic cropping.
Use the [Edit> Undo] function before repeating a correction on the same image.
In this way, the position of the sliders is preserved.

Color modes and transparency

Color modes
An image is represented by a two-dimensional array where each box is a pixel. To
numerically represent an image, simply create an array of pixels whose each box
contains a value. The value stored in a box is encoded on a number of bits.
One byte, considered the basic unit for storage, contains 8 bits.
• The color palette
The color palette, or color table, contains all the colors that can be contained in the
image. Each color is associated with an index. By coding the indices on 4 bits (two
indices per byte), it is possible to define 16 colors maximum. This storage method is
used by the 16-color mode. By coding the indices on 8 bits (one index per byte), it is
possible to define 256 colors maximum. This storage method is used by the 256 color
mode.
An image using a palette is called an image in indexed color mode .
• The monochrome mode
The monochrome mode, or more generally the black and white mode, is stored on a
single bit. One byte can store up to eight pixels. This is the mode that takes the least
space on the hard drive and is recommended for storing scanned handwritten
documents (equivalent to a photocopy). The monochrome mode is not accessible in the
case of a layered image.
To convert an image to monochrome mode, click the [Image> Mode> Indexed Colors]
menu or the icon in the toolbar. PhotoFiltre displays the window for setting the color
mode.

Properties of the Indexed Colors function.
Select the [System] tab, then a color reduction method. PhotoFiltre offers the
[Monochrome] method for reducing colors without dithering (scattering), and the [Raster
Monochrome] method that improves the visual quality of the result by using a dithering
effect.
Use this mode only for recording, because pasting functions, settings, filters,
and drawing tools are not accessible.
• 16 color mode
The 16-color mode, or 16 gray levels, is stored on 4 bits. A byte can store up to two
pixels. This mode takes up little space on hard disk, but the visual quality, images, is
generally insufficient because of the low number of colors. The 16-color mode is not
accessible in the case of a layered image.
To convert an image to 16-color mode, click the [Image> Mode> Indexed Colors] menu
or the icon in the toolbar. PhotoFiltre displays the window for setting the color mode.

Properties of the Indexed Colors function.
To convert an image to 16-color optimized mode, select the [Optimized] tab, then a color
reduction method. PhotoFiltre offers the [8 colors] and [16 colors] methods. The
[Broadcast] option improves the visual quality of the result.
To convert an image to 16 grayscale mode, select the [System] tab, then a color
reduction method. PhotoFiltre offers the methods [Gray 4 colors] and [Gray 16 colors].
Both methods use a diffusion algorithm that improves the visual quality of the result.
Use this mode only for recording, because pasting functions, settings, filters,
and drawing tools are not accessible.
• 256 colors mode
The 256 color mode, or 256 gray levels, is stored on 8 bits. A byte can therefore store a

single pixel. This mode is used by the GIF and PNG formats, for example. It offers a
good compromise between place for storage and visual quality. That's why it's so
prevalent on the web. The 256 color mode is not accessible in the case of a layered
image.
To convert an image to 256 color mode, click the [Image> Mode> Indexed Colors] menu
or the icon in the toolbar. PhotoFiltre displays the window for setting the color mode.
See, above, the properties of the Indexed Colors function.
To convert an image to 256-optimized color mode, select the [Optimized] tab, and then a
color reduction method. PhotoFiltre offers the methods [32 colors], [64 colors], [128
colors] and [256 colors]. The [Broadcast] option improves the visual quality of the result.
To convert an image to 256-level grayscale, select the [System] tab, then the [256-color
Gray] color reduction method.
To convert an image to Windows 20 color mode, select the [System] tab, then the [Color
Windows 20] color reduction method. PhotoFiltre only uses the 20 colors of the Windows
system during the reduction.
To convert an image into 216 Web-optimized color mode, select the [System] tab and
then the [216 Web Color] reduction method. PhotoFiltre uses a color palette recognized
by the majority of Internet browsers.
Use this mode only for recording, because pasting functions, settings, filters,
and drawing tools are not accessible.
• RGB color mode
This mode is used to represent a pixel by its three RGB components (Red, Green and
Blue). If each component is stored on one byte (8 bits), a pixel is stored on three bytes
(24 bits). This mode is capable of handling up to 16 million colors and offers a very good
visual quality. It is used by JPEG and PNG formats for example. It is also the native
mode of PhotoFiltre and it allows layered images.
Each component has a value between 0 and 255, which is 256 possibilities. If the color
is coded on three components, the possible number of colors is:
256 * 256 * 256 = 16,777,216
To convert an image to RGB color mode, click the [Image> Mode> RGB Colors] menu or
the icon in the toolbar.
In this mode, all PhotoFiltre functions are accessible.
RGB color mode is also known as True Color mode or True Color mode.
• RGBA mode
The RVBA mode is an RGB mode to which we add an Alpha layer. As a result, one pixel
is stored in four bytes (32 bits). This mode is used in case of alpha layer transparency
(see below). The RGBBA mode is not accessible in the case of a layered image.

In this mode, the background layer is handled like any other layer, and the
[Layer] menu functions are accessible.

Transparency
Transparency is a property that allows you to define the opacity of an image, that is to
say the possibility of seeing through the image and to let appear elements below (a
background or another graphic object ). In case of transparent image, the background is
symbolized by a checkerboard. PhotoFiltre is able to handle two modes of transparency.

On the left, the original image.
In the center, a simple transparency.
On the right, transparency by alpha channel .
• Simple transparency
Simple transparency applies to an indexed image or RGB mode and consists in defining,
among the colors of the image, a color that will be transparent. PNG and GIF formats
support this transparency mode.
See the chapter Saving an Image for more information on formats.
Create a simple transparency
1. To create simple transparency, you must first make sure that the image is in indexed
color mode or in RGB color mode. To do this, use the [Image> Mode] menu.
2. After this check, click the [Image> Transparency Color] menu or the icon
toolbar. PhotoFiltre displays the window for setting the transparency color.

in the

Properties of the Transparency Color function.
3. Move the mouse over the image to see the pipette cursor. Click an area with the color
to be set as transparent.
4. Select a tolerance value. The tolerance defines the color difference allowed to pass

from one pixel adjacent to the other. The values must be between 0 and 100. A low
tolerance selects pixels whose color is very close to that of the pixel you clicked while a
high tolerance selects a wider range of pixels.
5. If the image already contains a transparent color, PhotoFiltre offers the options
[Combine with current transparency] and [Replace current transparency].
You can use the Eraser tool to easily change the transparency.
If a selection is active, you can create transparency based on the selected
areas using the [Image> Auto Transparency] menu commands.
Cancel a simple transparency
1. To cancel a simple transparency, click the [Image> Transparency Color] menu.
PhotoFiltre displays the window for setting the transparency color.
2. Select the [Disable Transparency] check box and confirm.
• Alpha layer transparency
Alpha channel transparency consists of adding, for each pixel of the image, a byte
defining the level of transparency (from 0 to 255). The process of adding an Alpha layer
is usually called Alpha blending . This mode of transparency is also called translucency.
PNG, TIFF, Targa and BMP formats support this transparency mode.
See the chapter Saving an Image for more information on formats.
Create alpha layer transparency
1. To create Alpha Layer Transparency, you must first ensure that the image is in RGBA
(Alpha Layer) mode. To do this, use the [Image> Mode] menu.
2. Depending on your need, use one of the following functions:
- the function [Layer> Transparency> Transparency Color]
- menu functions [Layer> Transparency> Transparent Gradient]
- the functions of the [Layer> Edge Effect] menu
See Advanced Layer Operations for more information on these features.
You can use the Eraser tool to easily change the transparency.
Undo Alpha Transparency
To cancel alpha layer transparency, click [Layer> Transparency> Disable Alpha
Transparency] menu or change the color mode to RGB.
Edit Alpha Transparency
It is possible to edit the Alpha layer via the [Layers> Transparency> Edit Alpha Layer]
menu. The Alpha layer is then displayed as an image and you can edit it using drawing
tools and filters.

To apply it back to the RGBA source image, use the menus:
- [Edit> Copy]
- [Layers> Transparency> Paste As Alpha Layer]

Save an image

Introduction
Saving is saving your image to a file using a compressed storage format or not.
PhotoFiltre is able to save an image in different formats. As long as you have not
finished editing or creating your image, save your work in PhotoFiltre Image (PFI) format
to keep all layers. If your image contains only one background layer (background), you
can also use the PNG format.
When you have finished editing or creating your image, you can save it in another
format. The format to choose depends on the content of your image and the use you
want to make. For example, if you are saving an image for the Web, it is recommended
that you use PNG, JPEG, or GIF formats.
To save an image in another format, use the [File> Save As] command or click the
in the toolbar, and then choose the format from the list of formats.
button
When you click the button
, PhotoFiltre retains the same file name and format.
However, it can display additional options in a new window.
If you select a format that is not compatible with the image data, PhotoFiltre
displays a warning message. It is recommended to use another format if your
work is not finished.
When saving, PhotoFiltre applies the following rules:
1. If the format does not handle layers, all visible layers are merged.
2. If the format does not handle transparency, the transparent areas are replaced by
white.
3. If the format does not support the current color mode, PhotoFiltre uses a compatible
color mode.

PNG format
PNG ( Portable Network Graphics ) was originally designed to replace the GIF format. It
uses ZLIB / LZ77 lossless compression that reduces file size. It supports monochrome
mode (1 bit), indexed color mode (4 or 8 bit), RGB mode (24 bit) and RGBA mode (32
bit). This format also preserves the transparency of the image.
To save a PNG file, use the [File> Save As] command, and select PNG from the format
list. After validation, PhotoFiltre displays a window with additional recording options.

PNG format save properties

• The option [Interlaced]
This option allows you to activate or not interlacing mode. Interlacing generates an
image that is displayed as it is downloaded to a browser.
• The [Filtering] option
The purpose of filtering is to prepare the image for optimal compression. In some cases,
the image may suffer a slight loss.
No
The data is not changed and the image does not suffer any loss. This filtering is
recommended if you do not know which one to choose.
Difference
This filtering, called "horizontal differential", encodes the difference between the value of
a pixel and the corresponding value of the previous pixel on the same line.
High
This filtering, called "vertical differential", codes the difference between the value of a
pixel and the corresponding value of the previous pixel on the same column (just above).

Average
This filtering calculates the arithmetic mean of the two previous filterings (previous pixel
on the same line and pixel just above).
Paeth
Paeth filtering based on the three neighboring pixels (left, above, above left). This
technique was introduced by Alan W. Paeth.
Automatic
For each line to be processed, the best filtering is calculated among the above filterings.
When saving, PhotoFiltre uses the color mode and transparency of the current
image.

JPEG format
The Joint Photographic Experts Group (JPEG) is essentially used to record photographs
and snapshots. It compresses the image by eliminating data that may not be perceived
by the human eye. Compression is based on Huffman coding. The JPEG format uses a
24-bit RGB color mode or an 8-bit grayscale mode. It does not preserve transparency.
To save a file in JPEG format, use the [File> Save As] command, and select JPEG in the
format list. After validation, PhotoFiltre displays a window with additional recording

options.

JPEG format recording properties
• The [Compression] setting
Choose a compression ratio between 10 and 100. A low compression ratio, gives a
lower image quality and a smaller file size, while a high compression ratio, gives a better
image quality, but a file larger size.
Even with a maximum rate of 100, there are still losses compared to the original
image.
• The [Format] option
Standard
This format is compatible with most web browsers.
Progressive
The progressive format makes it possible to create an image which is displayed as it is
downloaded to a browser
• The [Grayscale] option
This option allows you to save the JPEG format in gray scale (256 colors, 8 bits).
• The option [Keep Exif information]
Some images from digital cameras contain EXIF or IPTC type metadata. If this option is
checked, the metadata, contained in the original file, will be kept during the recording.
This option is visible only if the original file contains metadata.
To get an estimate of compression size and quality, you can use the [Preview]
button.
• Default metadata
If the source image is a new JPEG image (new image or non-JPEG format), PhotoFiltre
will add its own EXIF metadata.

PhotoFiltre EXIF metadata properties
If your image contains EXIF metadata, the dimensions and resolution are
automatically updated when you save.

The GIF format
Graphics Interchange Format (GIF) is a commonly used file format on the Web. It uses
LZW type compression which reduces the size of the files. This format supports only 8bit indexed color mode, but preserves transparency.
To save an image in GIF, use the [File> Save As] command, and select GIF from the list
of formats. After validation, PhotoFiltre displays a window with additional recording
options.

GIF Registration Properties
• The option [Interlaced]
This option allows you to activate or not interlacing mode. Interlacing generates an
image that is displayed as it is downloaded to a browser.
• The [Optimized Palette] option
After reducing the number of colors, PhotoFiltre tries to optimize the palette by
rearranging colors and eliminating duplicates.
If the image contains more than 256 colors, PhotoFiltre reduces the number of
colors by using a diffusion algorithm. In any case, PhotoFiltre preserves
transparency.

The BMP format
BMP ( Bitmap Microsoft Windows / OS 2 ) format is used to exchange files between
applications and operating systems. BMP is a format supported by most drawing and
image editing applications. The image is saved without compression and can generate a

large file. This format supports monochrome mode (1 bit), indexed color mode (4 or 8
bit), RGB mode (24 bit) and RGBA mode (32 bit), but it does not preserve the
transparency of the image.
To save an image as a BMP, use the [File> Save As] command, and select BMP from
the format list.
When saving, PhotoFiltre uses the color mode of the current image.

The TIFF format
Tagged-Image File Format (TIFF) is used to exchange files between applications and
operating systems. TIFF is a format supported by most drawing and image editing
applications. This format supports monochrome mode (1 bit), indexed color mode (4 or 8
bit), RGB mode (24 bit) and RGBA mode (32 bit) but it does not preserve the
transparency of the image.
To save a TIFF image, use the [File> Save As] command, and then select TIFF from the
format list.

TIFF format recording properties (24-bit image, JPEG compression)

TIFF recording properties (LZW compression)
• The [Compression] option
If the option is unchecked, no compression will be applied when saving the image file. If
the option is checked, the drop-down list offers the following three compression groups:
1. RLE and CCITT FAX 4 : These types of compression are available for monochrome
(1bit) images.
2. LZW : This type of compression is available for indexed (4 and 8 bit) color mode
images and (32 bit) RGBA mode images.
3. LZW and JPEG : These types of compression are available for RGB (24-bit) color
mode images.

When saving, PhotoFiltre uses the color mode of the current image.

The Targa Format
Originally, the TGA ( Targa ) format was designed for systems equipped with the
Truevision video card. It supports indexed color mode (8-bit), RGB mode (24-bit) and
RGBA mode (32-bit), but it does not preserve the transparency of the image.
To save an image in Targa, use the [File> Save As] command, then select Targa from
the list of formats.

Targa Format Recording Properties
• The [Compression] option
This option enables or disables RLE compression. In most cases, compression
generates a smaller file.
When saving, PhotoFiltre uses the color mode of the current image.

The RLE format
This format is actually a Bitmap format using RLE type compression. In PhotoFiltre , this
format supports only 8-bit mode in 256 indexed colors and does not preserve
transparency.
To save an image in LAN, use the [File> Save As] command, and select RLE in the
format list.
If the image contains more than 256 colors, PhotoFiltre reduces the number of
colors by using a diffusion algorithm.

The PFI format
The PhotoFiltre Image (PFI) format is the default (native) format for PhotoFiltre . It
preserves the information contained in the layers as well as the transparency of the
image. The image can generate a large file because the layers are saved separately.
To save an image in PFI, use the [File> Save As] command, and then select PhotoFiltre
in the format list.

PFI recording properties
• The [Compression] option
This option enables or disables LZ77 lossless compression. In most cases, compression
generates a smaller file.

Use this format until you have finished editing or creating your image.
The PFI format saves a merged preview of the image to be compatible with
other applications.

Summary table
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Print an image

use
The purpose of the print module is to print an image by specifying parameters that can
change the size, resolution, and position of the image.
To launch the print module, you can:
- use the menu [File> Print]
- press the [Ctrl + P] keys
- click on the icon
in the toolbar

Print module properties
By default, PhotoFiltre prints all visible layers in the image. To print a particular layer,
select it as the only layer visible in the layer bar before you start the print module.
When printing, PhotoFiltre applies the following rules:
1. All visible layers are merged.
2. If the image contains transparent areas, they are replaced with white.

Visualization of the image
The image is represented as a miniature in a white background frame. The thumbnail is
a reflection of the size and position of the image that will be printed. The frame is
presented in portrait or landscape mode depending on the dimensions of the image. The
dimensions and resolution of the image are shown below the frame.

The [Configure] button
This button invokes the Windows Print Setup dialog box. Start by selecting a printer from
the list at the top of the dialog box. Then select a paper size and orientation, and then
click [OK]. When returning from the printer configuration, the module takes the initial

parameters.

Print options
• The [Center on Page] option
This option is simply to center the image in the page to be printed. This box is implicitly
checked when the module is called.
• The option [Use the whole page]
The image will be printed on the whole page taking into account the physical margins of
the printer (refer to the manufacturer's instruction manual). The proportions of the image
are preserved. This operation updates the image size, relative resolution, and size of the
thumbnail.
• [Actual size] option
The image will be printed at its actual size. The actual size is the one indicated in the
[Image Properties] dialog box. If the image size exceeds the physical margins of the
printer, PhotoFiltre displays an error message. This operation updates the image size,
relative resolution, and size of the thumbnail.
• The scale
The scale is the zoom factor that will be used when printing. For example, 300% means
that the image will be magnified 3 times when it is printed. Magnification is related to the
resolution of the printer because it determines the size of the points. For simplicity, we
can say that the scale corresponds to the ratio between the dimensions of the image in
pixels and the number of printable points. This option is available only if the [Use All
Page] and [Actual Size] checkboxes are unchecked. The relative resolution is the one
that will be applied to the print. The scroll bar allows you to change the percentage and
relative resolution of the image to print. The progress step of the bar is 10. This
operation updates the image size, the relative resolution, and the size of the thumbnail.
By default, PhotoFiltre applies the following rules when launching the print module:
1. The orientation of the paper is a function of the physical dimensions of the image. If
the image is wider than it is tall, the orientation will be in landscape mode.
2. PhotoFiltre adjusts the print size so that it occupies 80% of the page with a maximum
scale of 500% (magnification by a factor of 5). Above, the print quality may be of poor
quality.
• The group [Image size]
This group of information indicates the size of the image on the paper (print size). The
cm or inch unit depends on the setting in the [Preferences> Defaults] dialog box. It is
accessible only if the [Use All Page] and [Actual Size] boxes are unchecked. You can
change the width or height, but the proportions are retained. Pressing the [OK] or [Enter]
key controls the consistency of the entered data and updates the scale, relative
resolution, and size of the thumbnail.
Calculation rules:
- Size in cm = Size in pixels / Relative resolution x 2.54
- Size in pixels = Size in cm / 2.54 x Relative resolution

- Relative Resolution = Size in pixels / Size in cm x 2.54
The relative resolution also depends on the resolution of the printer.
Some printers can work on board lost (without margins). See the
manufacturer's instruction manual or their help file.
• The group [Position]
This group of information indicates the position of the image on the page. The cm or inch
unit depends on the setting in the [Preferences> Defaults] dialog box. It is accessible
only if the [Center on Page] and [Use All Page] checkboxes are unchecked. Using the
[Left] and [Top] settings, you can position your image on the page where you choose.
Pressing the [OK] or [Enter] key controls the consistency of the entered data and
updates the scale, relative resolution, and size of the thumbnail.
• [Print Outline Only] option
This option prints a blank box on the page. This frame is used to control the size of the
image and its positioning on the page without having to print the complete image.
If you use this setting, make a note of the changes you made because the
module disappears when you print.
Use this setting with the [Use All Page] option to determine the size of your
printer's physical margins.
• [Print cut lines] option
This option makes it possible to print two markers in the four corners of the photo to
facilitate its cutting.
• The [Copies] setting
This parameter indicates the number of pages to edit.

The image explorer

use
The purpose of the Image Explorer is to display, in thumbnail form, the images in a
folder. It allows you to quickly search for image files on your computer. It is possible to
explore any folder or one of the predefined folders (Selections, Patterns, Masks).
PhotoFiltre processes images differently depending on the type of folder being explored.
To display the image browser, you can:
- use the menu [Tools> Image Explorer]
- press the [Ctrl + E] keys
- click on the icon
in the toolbar
The Image Explorer window always appears at the bottom of the PhotoFiltre work area.
It is possible to display thumbnails on one or more lines.

Exploring the pattern folder with a two-line display.
To hide the image explorer, you can:
- use the menu [Tools> Image Explorer]
- press the [Ctrl + E] keys
- click on the icon
in the toolbar
Press the [F5] key to display the Image Explorer and to automatically start
scanning the last processed folder.

Description of the buttons

1. Explore / A folder
By clicking this button, PhotoFiltre opens the Windows Folder Search dialog box. Select
a folder and confirm to explore the contents of this folder.

2. Explore / The current image folder
By clicking this button, PhotoFiltre explores the folder of the current image. This button is
only accessible if there is an open image in the PhotoFiltre workspace and this image is
from a file. If there are several open images in the workspace, the folder of the active
image is explored.
3. Explore / The opening file
By clicking this button, PhotoFiltre explores the opening folder. This folder is set on the
[Folders] page of the [Preferences] command.
4. Explore / The registration dossier
By clicking this button, PhotoFiltre explores the recording folder. This folder is set on the
[Folders] page of the [Preferences] command.
5. Explore / The selections folder
By clicking this button, PhotoFiltre will explore the selections folder. This folder
corresponds to the [Selections] folder in the PhotoFiltre folder. If this folder does not
exist, the button is not accessible.
By holding down the [Ctrl] key while clicking, PhotoFiltre displays the Windows
dialog box for selecting a subfolder to explore.
6. Explore / The folder of masks
By clicking on this button, PhotoFiltre explores the folder of the masks used by the
PhotoMasque module. This folder corresponds to the [Masks] folder in the PhotoFiltre
folder. If this folder does not exist, the button is not accessible.
By holding down the [Ctrl] key while clicking, PhotoFiltre displays the Windows
dialog box for selecting a subfolder to explore.
7. Explore / The reasons file
By clicking this button, PhotoFiltre explores the folder of patterns used by fill functions
and some drawing tools. This folder corresponds to the [Patterns] folder in the
PhotoFiltre folder. If this folder does not exist, the button is not accessible.
By holding down the [Ctrl] key while clicking, PhotoFiltre displays the Windows
dialog box for selecting a subfolder to explore.
8. Context menu
By clicking this button, PhotoFiltre displays the context menu of the image browser. It is
also possible to display this context menu by right-clicking in the thumbnail display area.

The context menu
The context menu is made up of groups of menus and has several commands and
setting options.

• The [Explorer] menu
In this menu, we find the different actions associated with buttons 1 to 7.
Here are the correspondences:
- A folder = Button 1
- The current image folder = Button 2
- The opening file = Button 3
- The registration dossier = Button 4
- The selections folder = Button 5
- The mask folder = Button 6
- The reasons folder = Button 7
- The textures folder (no button match)
• The [Image] menu
This menu is only accessible if a thumbnail holds the focus. The actions are performed
on the image file corresponding to the selected thumbnail.
Here are the actions offered by PhotoFiltre :
- Rename the image
- Move an image to
- Copy an image to
- Delete the image
See the Picture Manager chapter for more details on these actions.
• The [Action] menu
This menu is only accessible if a thumbnail holds the focus. The actions offered by
PhotoFiltre depend on the type of folder being explored.
Here is the list of actions that can be performed:
Any type of file
The [Open as new image] command opens the image corresponding to the selected
thumbnail.
The [Open as layer] command creates a layer corresponding to the selected thumbnail.
This command is accessible only if there is an open image in the PhotoFiltre workspace
and this image is in 16 million color mode (RGB only).
The [Open with associated program] command invokes the program associated with the
image file type corresponding to the selected thumbnail. The association is set at the
Windows level.
The selections file
The [Load this shape] command loads the corresponding shape to the selected
thumbnail, activates the selection tool, and displays the selection. This command is
accessible only if there is an open image in the PhotoFiltre workspace.

The folder of the masks
The [Start PhotoMask with this mask] command invokes the PhotoMask module and
loads the mask corresponding to the selected thumbnail. This command is only
accessible if there is an open image in the PhotoFiltre workspace and this image is in 16
million color mode (RGB or RVBA).
The reasons file
The [Use as Pattern] command initializes the internal PhotoFiltre pattern with the image
corresponding to the selected thumbnail. The pattern is used by fill functions and some
drawing tools. This command is only accessible if there is an open image in the
PhotoFiltre workspace and this image is in 16 million color mode (RGB or RVBA).
The textures folder
The [Use as Texture] command calls the Texture module and loads the texture
corresponding to the selected thumbnail. This command is only accessible if there is an
open image in the PhotoFiltre workspace and this image is in 16 million color mode
(RGB or RVBA).
• The [Refresh] command
This command is used to restart the explorer on the folder being processed to refresh
the thumbnails.
• The [Automatic] command
This command is used to automatically display in the explorer the thumbnails of the
folder of the image that is opened. The subfolders are however not explored (no
recursion)
• The [Image Property] command
This command is accessible only if a thumbnail holds the focus. It displays an
information box on the image file corresponding to the selected thumbnail.
The items displayed are as follows:
- File name
- File location folder
- Dimensions in pixels
- Size in bytes, kilobytes or megabytes
- Date and time of modification
- Number of images present in the explorer
If the image contains EXIF, IPTC or Comment data, these are displayed in the
corresponding tabs.
• The option [Sort]
If this option is checked, PhotoFiltre sorts the thumbnails in ascending order of image file
names. Otherwise, the thumbnails are displayed according to the order in which files are
stored on your computer's disk.

• The option [Include subfolders]
If this command is checked, PhotoFiltre takes into account the images stored in the
subfolders of the folder being processed.
Be careful, you can have multiple images with the same name. Use the [Image
Property] command to differentiate them.
• The [Custom Filter] command
This command displays a dialog box that allows you to set the file formats to display in
the Image Explorer.
Sample filter to display only BMP and JPG image files:
* .jpg; *. jpeg; *. bmp
The custom filter is initialized blank when PhotoFiltre starts , which matches all
images recognized by PhotoFiltre .
• The [Show multi-line thumbnails] command
If this command is checked, it displays the thumbnails on several lines. Otherwise, they
are displayed on one line. The appearance of the explorer is changed in real time.
• The [Empty Thumbnail List] command
This command is accessible only if there are one or more thumbnails to display. It allows
you to erase all thumbnails from the explorer to free up memory space.
The thumbnail list is always reset when PhotoFiltre starts .

Work with the Image Explorer
When you have chosen a folder to explore, the thumbnails begin to appear from left to
right in the Image Explorer display area. During the exploration, a counter, located in the
status bar, indicates the number of images taken into account. The Image Explorer can
store up to 1000 thumbnails.

E xample of exploration on a line.
If the image files contain metadata, PhotoFiltre displays symbols at the top left of the
thumbnail to indicate the type of metadata. The symbol indicates that the image file
contains EXIF metadata. The symbol indicates that the image file contains IPTC
metadata. The symbol indicates that the image file contains a comment.
While browsing the folder, you can continue working with PhotoFiltre , but some

operations are slower.
It is possible to stop the treatment at any time by using the [Esc] key.

The default action
The default action, which can be accessed by double-clicking a thumbnail or pressing
the [Enter] key when a thumbnail holds the focus, depends on the explored folder and
the contents of the PhotoFiltre workspace.
• Exploring an image folder
PhotoFiltre opens the corresponding image for the selected thumbnail.
• Exploration of the selections file
Without an image in the workspace, PhotoFiltre opens the image corresponding to the
selected thumbnail.
If at least one image is open, PhotoFiltre loads the corresponding shape to the selected
thumbnail, activates the selection tool, and displays the selection.
• Exploring the folder of masks
Without an image in the workspace, or if the active open image is not in 16 million color
(RGB or RGBA) mode, PhotoFiltre opens the image corresponding to the selected
thumbnail.
Otherwise, PhotoFiltre calls the PhotoMask module and loads the mask corresponding
to the selected thumbnail.
• Exploring the reasons file
Without an image in the workspace, or if the active open image is not in 16 million color
(RGB or RGBA) mode, PhotoFiltre opens the image corresponding to the selected
thumbnail.
Otherwise, PhotoFiltre initializes the internal pattern with the corresponding image to the
selected thumbnail. The pattern is used by fill functions and some drawing tools.
• Exploring the texture file
Without an image in the workspace, or if the active open image is not in 16 million color
(RGB or RGBA) mode, PhotoFiltre opens the image corresponding to the selected
thumbnail. Otherwise, PhotoFiltre calls the Texture module and loads the texture
corresponding to the selected thumbnail.

Drag and drop
When dragging a thumbnail into the workspace (drag), the action taken by PhotoFiltre
when releasing the (drop) button depends on the folder being scanned and the position
of the mouse cursor.
• Exploring an image folder

Without an image in the workspace, or if the active open image is not in 16 million color
mode (RGB only), or if the mouse cursor is outside the active open image, PhotoFiltre
opens the corresponding image to the selected thumbnail.
If the mouse cursor is over the active open image, and this image is in 16 million color
(RGB only) mode, PhotoFiltre opens the corresponding image to the selected thumbnail
as a new layer.
• Exploration of the selections file
Without an image in the workspace, or if the mouse cursor is outside the active open
image, PhotoFiltre opens the corresponding image for the selected thumbnail.
If the mouse cursor is over the active open image, PhotoFiltre loads the corresponding
shape to the selected thumbnail, activates the selection tool, and displays the selection.
• Exploring the folder of masks
Without an image in the workspace, or if the active open image is not in 16 million color
(RGB or RGBA) mode, or if the mouse cursor is outside the active open image,
PhotoFiltre opens the corresponding image for the selected thumbnail.
If the mouse cursor is over the active open image, and this image is in 16 million color
(RGB or RGBA) mode, PhotoFiltre calls the PhotoMask module and loads the mask
corresponding to the selected thumbnail.
• Exploring the reasons file
Without an image in the workspace, or if the active open image is not in 16 million color
(RGB or RGBA) mode, or if the mouse cursor is outside the active open image,
PhotoFiltre opens the corresponding image for the selected thumbnail.
If the mouse cursor is over the active open image, and this image is in 16 million color
(RGB or RGBA) mode, PhotoFiltre initializes the internal pattern with the image
corresponding to the selected thumbnail. The pattern is used by fill functions and some
drawing tools.
• Exploring the texture file
Without an image in the workspace, or if the active open image is not in 16 million color
(RGB or RGBA) mode, or if the mouse cursor is outside the active open image,
PhotoFiltre opens the corresponding image for the selected thumbnail. If the mouse
cursor is over the active open image, and this image is in 16 million color (RGB or
RGBA) mode, PhotoFiltre calls the Texture module and loads the texture corresponding
to the selected thumbnail.

The PhotoMasque module

Presentation
PhotoMask allows you to perform advanced outline and transparency effects on your
images using predefined masks. It also offers the ability to create custom masks.
To launch the PhotoMask module, you can:
- use the menu [Filter> PhotoMask]
- click on the icon
in the toolbar

Properties of the PhotoMasque module
Masks are grayscale images. White is the transparency color, and gray levels are the
opacity. The darker the gray, the more opaque the color will be applied. PhotoMask
comes with several basic masks, try to get inspired to create your own masks.

Choice of the mask
This action is performed using the open button symbolized by a small folder. The most
popular formats are recognized (JPG, GIF, PNG, BMP, ...). After the selection of the
mask, a preview is proposed in the corresponding window. This one will be preserved for
the next uses of PhotoMasque .
It is preferable at this point to set the orientation of the mask according to the orientation
of the image using the rotation button below the preview. Thus, the deformations will be
less important and the result will be optimal.

On the left, the Airbrush mask. On the right, the
result on an image.

Settings and options
• The [Color] setting
This setting sets the application color for Color Only mode. Click the colored rectangle or
the arrow button to select the color.
• The [Opacity] setting
It allows you to change the opacity of the mask to achieve semi-transparency effects.
This setting is not available in [Transparency] mode.
• The mode of application
For the same mask, PhotoFiltre behaves differently depending on the selected mode.
[Color] mode
The mask uses the selected color and opacity.
[Grayscale] mode
The mask is used to create gray level effects (desaturation).
[Gaussian Blur] Mode
The mask is used to create Gaussian blur effects (high blur).
[Pattern] mode
The mask is used in combination with the pattern to fill the image (depending on the gray
levels of the mask). In this case, the pattern parameter is available.
[Transparency] mode
The mask is used to set the transparency of the current image or layer.
On a layer, this mode lets you edit the Alpha layer and create custom edge
effects.

On the left, a simple effect in color mode.

In the center, a combination of two masks in color mode.
On the right, a transparency effect.
• The [Blur] option
This option smooths the mask before it is applied.
• The [Duotone] option
This option cancels the gray levels. These are rounded to the nearest black or white
color. Gradient effects are removed.
• The option [Stretch mask]
By activating this option, the size of the mask is adjusted by deformation to that of the
image.
• [Repeat Mask] option
By enabling this option, the mask size is not changed. The mask is then used as a
pattern to cover the entire surface of the image.
• The [Fill pattern] parameter
It allows you to choose a pattern for filling (in combination with the mask).
This setting is available only for [Pattern] mode.

Recording the result
It is important to know that currently only GIF and PNG formats maintain transparency.
Be sure to choose these formats so you do not have any nasty surprises when using
your images for the Web. With the GIF format, the number of colors is reduced to 256
with a diffusion method.

Creating custom masks
Your masks must be in 256 color grayscale. It is best to use a format that supports
indexed color mode (GIF, PNG, BMP, TIFF) without loss of information to maintain the
original mask quality, especially if it contains gradients. However, the JPEG format can
be used with a compression ratio sufficient to limit the losses due to compression.
In [Color] mode, repeatedly apply the same mask with a different color (sky
blue, then white with the Watercolor mask for example).
The combination of several masks sometimes gives an interesting result. Try
the Dilution mask and then the Watercolor mask with a white color.

The Texture module

Presentation
The Texture module provides custom texture and relief effects. It offers a list of
predefined textures stored as a black and white mask.
To launch the Texture module, use the [Filter> Texture> Other] menu.

Texture module properties
Texture files are grayscale images. Medium gray is the neutral color, light gray is the
highlight, and dark gray is the recess. In this way, it is possible to simulate effects of
matter and relief. The Texture module comes with several basic textures, try to get
inspired to create your own textures.

Choice of texture
This action is performed using the open button symbolized by a small folder. The most
popular formats are recognized (JPG, GIF, PNG, BMP, ...). After selecting the texture, a
preview is proposed in the corresponding window. This one will be preserved for the next
uses of the Texture module.
At this point, you can change the orientation of the texture or apply a negative mode to
invert the reliefs. To do this, use the two buttons below the preview.

On the left, the texture mask. On the right, the result on an image.

Settings and options
• The [Opacity] setting
It allows you to change the opacity of the texture to reduce relief effects.
• The [Scale] parameter
This setting allows you to stretch or reduce the texture on the image. The relief effects
are thus wider or more tightened.
• The [Relief] parameter
This parameter is used to accentuate the relief effects.
Some textures simulate an effect of matter.

Creating custom textures
Your textures must be in 256 color grayscale. It is best to use a format that supports
indexed color mode (GIF, PNG, BMP, TIFF) without loss of information to maintain the
original texture quality, especially if it contains gradients. However, the JPEG format can
be used with a compression ratio sufficient to limit the losses due to compression.
Do not confuse "pattern" and "texture". A pattern makes it possible to fill an
area of the image, while a texture makes it possible to simulate relief effects.
You will find a large amount of textures on the web.

The PhotoPNG module

Presentation
The PhotoPNG module allows you to create overlay effects with color images. It offers
the possibility of creating sophisticated frames, copyrights, or simply decorative effects.
To launch the PhotoPNG module, use the [Filter> PhotoPNG] menu.

PhotoPNG Module Properties
The files in the PhotoPNG module are 32-bit PNG color images. This format allows it to
support Alpha layer transparency. The PhotoPNG module comes with several basic
images, try to get inspired to create your own images.

Choice of images
This action is performed using the open button symbolized by a small folder. After
selecting the PNG image, a preview is proposed in the corresponding window. This one
will be preserved for the next uses of the PhotoPNG module.
At this point, you can change the orientation of the PNG image. To do this, use the
button below the preview.

On the left, the PNG image to be embedded. On the right, the result after treatment.

Settings and options
• The [Mode] setting
This parameter allows you to choose how the PNG image will be applied to the media.
Three modes are available:
Framing mode
This mode automatically embeds the chosen PNG image on the entire surface of the
media.
Pattern mode
The PNG image is used as a pattern to fill the entire surface of the media.
Position mode
This mode allows you to choose where the PNG image will be embedded on the media.
• The [Opacity] setting
This setting allows you to change the opacity of the PNG image to reduce overlay
effects.
• The [Scale] parameter
This setting allows you to stretch or shrink the PNG image to be embedded. It is only
available with [Position] mode.
• The [Position] parameter
This parameter is used to define one of the nine locations where the PNG image will be
embedded. It is only available with [Position] mode.

Creating custom images
The images must be in color with an Alpha layer. You must save them in 32-bit PNG
format (RGBBA mode).
You will find a large amount of PNG clipart images on the web.

The Vector Trace Module

Presentation
A vector path is a sequence of points that determines an outline.
The different possibilities of the vector line of PhotoFiltre are:
- drawing a line between the created point and the previous point
- the plot can be closed or not
- the lines can be curved thanks to the use of Bézier curves
(described in 1962 by the French engineer Pierre Bézier)
- points can be moved
- the contour can be saved for future use
- the lines of the layout can be changed into a selection or a filled form or not
To create a vector path, you must:
- create a new image or open an existing image (or work on a layer)
- use the menu [Tools> Vector Path> New] to create a new path
- use the [Tools> Vector Path> Convert Selection] menu to create a path from a vector
selection
- use the menu [Tools> Vector Path> Open] to access an existing path or click on the
button
in the toolbar
When we are in the vector path, we no longer have access to other PhotoFiltre
commands. To completely return to PhotoFiltre, close the vector path.
The vector line is kept on the same image or on an image of the same size. In
this case, the [Tools> Vector Path> Reset] menu replaces the [Tools> Vector Path>
New] menu.
As soon as you start the vector path, you can create your first point at the desired point
and so on for the following points.

Vector line example

Description of the context menu
You have access, by a right click in the image, to a contextual menu.
The features of the vector plot can only be managed by the context menu. Depending on
the different steps of drawing the vector line, some functions of the context menu may be
inaccessible (grayed out).
• Lexicon
Point or node
Location that determines the beginning or end of a line in the path
Checkpoint or handle
Point that allows to form a Bézier curve
Guideline
Line joining a node to a control point

Properties of the context menu
1. Actions on the points of the vector line
Function [Add]
It allows to add a new point by clicking at the desired place. Automatically, a straight line
is drawn with the last point created. You can also add a point on a line by clicking on it or
nearby (maximum 7 pixels). A new point can only be created at a certain distance from
the previous one (at least 12 pixels).
[Delete] function
It allows you to delete a point by clicking on it. A line is redrawn between the previous
and the next point.
[Edit] function
It allows you to change the location of a point, keeping the left click pressed on it and
moving the cursor. If [Bézier Mode] is checked, you can bend the lines on either side of
the point by manipulating the control points.
[Reset] function
It makes it possible to cancel the curvature of the lines on each side of a point. By
clicking on it, the curves become simple straight lines. This function is active if the
[Bezier Mode] function is checked.

Function [Move all points]
It moves the whole plot, keeping the left click pressed and moving the cursor over the
image.
2. Special controls to edit the vector line
Option [Close the loop]
By unchecking this option, the last point created and the starting point are not linked.
Adding a point is done behind the last point created.
By checking this option, the loop is closed by a straight line drawn between the last
created point and the starting point. The addition of a point is done by deleting this line
and redrawing from this new point two new lines, one to the last point created and
another to the starting point.
Option [Bezier Mode]
This option allows you to curve lines using the [Edit] or [Smooth all points] functions.
A double-click on a point allows to switch between curved lines and straight
lines .
Option [Symmetrical Control Points]
By checking this option, the two control points that manage the calculation of the
amplitude of the curves act simultaneously on the two lines.
By unchecking this option, each control point becomes independent and each line can
be bent separately. This option is active if the [Bezier Mode] option is checked.
Option [Tracking Grid]
It allows to display a grid in order to position the points of the plot more easily. Be
careful, the grid must be set before using the [Vector Path] function.
See the Customize PhotoFiltre chapter for a detailed description of the options on the
[Tool Palette and Grid] page.
Option [Magnetism of the grid]
By checking this option, the points created or moved are always positioned in the upper
and left corner of the grid cell where the cursor is located.
3. Treatments on all points
Function [Reset all points]
By executing this function, the curved lines of the plot are straightened. This function is
active if the [Bezier Mode] function is checked.
[Smooth all points] function

By executing this function, PhotoFiltre calculates the default amplitude of the curves for
each line of the plot. This function is active if the [Bezier Mode] function is checked.
Transformation functions
By clicking the [Transformation] menu, we have access to the following transformation
functions:
- Vertical symmetry
- Horizontal symmetry
- 90 ° rotation
- Rotation 90 ° counterclockwise
- Rotation 180 °
- Parameterized transformation
See Layer Transformations for a detailed description of these options.
4. Transformation of the vector line for use in PhotoFiltre
[Contour and fill] function
This function displays the [Contour and Fill] setting window for drawing an outline or
filling the inside of it.
See Working with Selections for a detailed description of the Contour and Fill feature.
[Transform into selection] function
When executing this function, the outline of the trace is transformed into a vector
selection (black dotted line) if the [Bézier Mode] option is unchecked or when selecting
the Magic Wand (green dotted) selection if the [Bezier Mode] option is checked.
By executing this function, we exit from the [Vector Path] function and find all the
features of PhotoFiltre .
5. Vector file management
Function [New]
This function allows PhotoFiltre to initialize a new vector path.
Function [Open]
By executing this function, a previously saved track is loaded into a file. PhotoFiltre
displays the dialog box. It is positioned by default in the [Paths] folder and displays PFV
format files. Click on the desired vector plot (use preview) and confirm to close the dialog
and load the plot.
[Save] function
This function proposes to save a plot for future use. PhotoFiltre displays the dialog box.
It is positioned by default in the [Paths] folder. Type a new file name and validate.
Vector plots are saved in PFV ( PhotoFiltre Vectorial ) format .

6. Closure of the vector line
Function [Close]
By executing this function, we leave the [Vector Path] function. Passing through this
function is required to access all the features of PhotoFiltre again .
If there were any changes to the vector path between its opening and closing,
and to avoid losing all the work done, a confirmation request for the registration of
the path is requested when the [Vector Path] function is closed. ].
Pressing the [Esc] key exits the [Vector Path] function at any time. A
confirmation request may be requested to save the path.

use
• Creating points
[Add] function checked
Option [Close loop] unchecked
(see the thumbnail opposite)
The points 1 , 2 , 3 , 4 and 5 are
successively created one behind the other
by a mouse click. A minimum distance of
12 pixels from the previous one is required
for the point to appear.
Option [Close Loop] checked
(see the thumbnail opposite)
By checking this option, a straight line will
be drawn between points 1 and 5 .
• Deleting a point
[Delete] function checked
(see the thumbnail opposite)
Make a mouse click on point 3 that you
want to delete.
Point 3 will be cut by the click of the
mouse.

obtained result
(see the thumbnail opposite)

Point 3 is gone. The line is redrawn
between points 2 and 4 .

• Inserting a point
[Add] function checked
(see the thumbnail opposite)
Position the cursor at the desired location
on the line and click the mouse. The
maximum distance is 7 pixels between the
cursor and the line for insertion. Otherwise,
the point will be created after point 5 .

obtained result
(see the thumbnail opposite)
Point 3a is created. This is not the last
point for the route. If we wanted to add a
new point to more than 7 pixels of a line, it
would be created behind point 5 .

• Moving a point
[Edit] function checked
(see the thumbnail opposite)
By holding down the click on point 3a and
moving the cursor, the point is positioned in
a new place (here down, following the
direction of the blue arrow).

obtained result
(see the thumbnail opposite)

Releasing the mouse click positions point
3a at the desired new location.

• Creating a Bézier curve at a point

Option [Bezier Mode] checked
[Edit] function checked
Option [Symmetrical control points] checked
(see the thumbnails above)
Choose with a mouse click the point 3a to curve the lines (3a, 2) and (3a, 4) .
If the lines (3a, 2) and (3a, 4) are straight, the control points A and B are displayed on
the lines. The guidelines (3a, A) and (3a, B) are about one-third the length of the straight
lines.
If the lines (3a, 2) and (3a, 4) are curved, the guidelines (3a, A) and (3a, B) are tangents
to the curves.
The amplitude of the curvature is function:
- the displacement of control points A or B
- the stretching of the guidelines (3a, A) or (3a, B)

- the position of point 3a with respect to points 2 and 4 .
The curvature of the lines (3a, 2) and (3a, 4) is performed together and symmetrically by
keeping the click on the control point A or B and moving the cursor.
Option [symmetrical control points] unchecked
(see the thumbnails above)
By unchecking this option, the curvature will be dissociated on each line by moving its
own control point.
Control point A and the guideline (3a, A) will distort the line (3a, 2) .
Control point B and the guideline (3a, B) will deform the line (3a, 4) .
[Reset] function checked
(see the thumbnails above)
By activating this function, a mouse click on point 3a will straighten the lines (3a, 2) and
(3a, 4) .
• Curve all the points of the vector line
Option [Bezier Mode] checked
[Smooth all points] function
(see the thumbnail opposite)
By executing this function, a curve is
created on the entire vector line. This curve
is calculated automatically by PhotoFiltre .
Function [Reset all points]
(see the thumbnail opposite)
By executing this function, the entire
generated curve will be redrawn in straight
lines.

• Moving the whole vector line
[Move all points] function checked
(see the thumbnail opposite)
By holding the click on the image and
moving the cursor, you position the vector
line in a new location.

See Keyboard Shortcuts for a detailed description of the shortcut keys used for [Vector
Path].

Automate treatments

use
The purpose of the automation module is to perform a series of operations automatically to a
batch or to a selection of image files. It has eight tabs. Each tab manages a type of operation
to perform. Some are optional. When the module is launched, the options are loaded with the
data saved in the PhotoFiltre initialization file.
To launch the automation module, you can:
- use the menu [Tools> Automation]
- click on the icon
in the toolbar

The [File] tab
This tab allows you to choose the location of source files and the storage of export files with
change of format and file name.

Properties of the [File] tab
• The [Source Folder] setting
This parameter is used to search the folder of the images to be processed. Pressing the
button on the right opens the Windows Folder Search dialog box.
• The [Source Format] setting
This parameter allows you to choose an image format (or a particular format). To choose a
format, you must use the drop-down list. It is possible to combine different image formats. To

do this, you must create a personal filter by pressing the button to the right of the drop-down
list. Only enter image formats present in the drop-down list, otherwise they will not be
processed. After using a personal filter, to return to the list of formats, press the icon on the
right, then delete all formats entered and confirm with [Ok].
Syntax example: *, jpg; *. Bmp; *. Gif
Images in PFI format will merge all visible layers before processing.
Transparency is disabled when opening the image
• The [Custom Selection] option
This option allows you to manually choose the images to be processed. If the box is checked,
we have access to the list of images on the left. You must choose at least one file. The
selection is made according to the standard Windows method. When you switch tabs,
PhotoFiltre can return an error if there is no file selected. We stay in the [File] tab. If the box
is unchecked, all files in the source folder will be selected.
• The [Export Folder] setting
This parameter allows you to choose the export folder where you will store the modified
images. Pressing the button on the right opens the Windows Folder Search dialog box. When
you switch tabs, PhotoFiltre can return:
1. An error, if the file is not filled. We stay in the File tab.
2. A warning, if the folder is identical to the source folder. We go to the requested tab. If you
skip it, there is a risk of overwriting an existing file.
• The [Export Format] setting
This parameter allows you to choose a format to apply to your export images. To choose a
format, you must use the drop-down list. Depending on the requested format, two different
parameters can be displayed under the drop-down list.
1. With the JPEG format: a slider is used to give a compression ratio to the image. Attention,
with this format there is degradation of the images after each compression.
2. With Bitmap, GIF, Targa, PNG, and TIFF formats: A [Number of Colors] setting allows you
to choose a maximum number of colors when saving the image.

Export options
Summary table of the default settings used during registration
Export format

Default settings

PNG

Filtering: None

JPEG

Standard format
Retention of EXIF / IPTC data (*)

GIF

Optimized palette

TIFF

RLE compression for monochrome images (1 bit)
LZE compression for other images

Targa

Compression (RLE)

(*) Linked to registration preferences
It is possible to customize some settings, such as retaining the original date of the
file and EXIF data, via the [Tools> Preferences> Registration] command.
See also Customizing PhotoFiltre .
• The [Sequence] option
This option allows you to rename the export files. The name consists of a single prefix and an
incremented suffix with a step of one (the suffix starts at 001). If the box is checked, you have
access to the editable area below and you can indicate the prefix in the input box. Below,
there is an example displayed in real time. We can leave the input area blank, in which case
we will only have the suffix as file name. If the box is unchecked, the exported files will have
the name of the source files.
In both cases, you must pay attention to the possibility of overwriting a file with the
same name and format in the export folder, even if it is different from the source
folder. Indeed, they will be crushed without warning.

The [Image] tab
This tab allows you to assign physical parameters to the exported image. All options are
optional. To apply an option, check the box of the one you want to use.

Properties of the [Image] tab
• [Image Size] option
This option allows you to change the size of the export image. If the box is checked, the
parameters and options below are accessible. Otherwise, we keep the sizes of the source
image.
[Width] and [Height ] settings
They indicate the maximum size in pixels of the export image. The data entered are not exact
values, but they represent limits.
The [Unit] parameter
If the unit is in pixels, the size of the export image is resized with the maximum values
entered in the Width and Height editable areas. If, however, the unit is in%, a percentage is
applied to the size of the source image. This percentage corresponds to an enlargement
coefficient.
Percentage beaches:
1. 10 to 99%, the export image will be reduced
2. 100%, the export image will be identical
3. 101 to 500%, the export image will be enlarged
[Keep proportions] option
If this option is enabled, the proportions will be retained and the export images will be smaller
than or equal to the [Width] and [Height] settings. In the other case, the export images will
have the sizes indicated in the [Width] and [Height] parameters and there will be a distortion
of the image.
The [Optimize] option
If this option is activated, the smoothing mode enables bilinear interpolation during the
transformation. Thus, the result is of a better visual quality.
• The option [Framing]
This option creates a uniform frame for the export image. If the box is checked, the
parameters and options below are accessible.
The [Color] parameter
This parameter indicates the fill color of the frame.
The [Width] parameter
This parameter is used to define the width in pixels of the frame.
The [Outside] setting
If this setting is enabled, the frame is created outside the image. In the other case, the frame
is created inside the image, but the outline of the image is lost on the width of the frame.

• The [Size of the work area] option
This option makes it possible to modify the size of the working area of the image (support),
either by enlarging it (adding a background) or by reducing it (cropping). If the box is
checked, the parameters and options below are accessible. The data is relative to the
dimensions of the export image after resizing and framing.
[Width] and [Height ] settings
They indicate the size (in pixels) of the work area. PhotoFiltre handles different possibilities
on sizes:
1. If the width or height of the work area is larger than that of the source image, the source
image is positioned according to the [Position] setting.
2. If the width or height of the work area is smaller than that of the source image, the image is
truncated to the width or height. The part to be retained is defined according to the [Position]
(cropping) parameter.
3. If the width is zero, the width of the export image is applied to the work area (no change).
Similarly, if the height is zero, the height of the export image is applied to the work area (no
editing).
The [Background] setting
It allows you to apply a color to the work area. This parameter is ignored in the case of a
crop.
The option [Background]
It allows you to choose a pattern to apply to the background. The pattern has priority on the
bottom. In the case of a transparent pattern, it will reveal the background color at the
transparent areas. This option is ignored in the case of a crop. The red cross on the right
makes it possible to erase the motive present in the box.
The [Position] parameter
It allows you to position the source image on the work area in nine different places. Three
cases can occur:
1. The dimensions of the work area are larger than those of the source image, the parameter
indicates where the image will be positioned (adds a background).
2. The dimensions of the work area are smaller than those of the source image, the
parameter indicates the part of the image that will be retained (cropping).
3. In other cases, there will be a combination of the first two.
The option [Drop shadow]
It allows, if the box is checked, to create a shadow on the right and the bottom of the image
of export. The thickness in pixels is to be entered in the editable area below the checkbox. If
there is no change in the work area, you can set a background to color the white part of the
drop shadow.
• The option [Force DPI]
This option allows you to force the dpi (dot per inch) on the export image. If the box is
checked, the editable area on the right is accessible to indicate the new value of the dpi.

• Note
The size of the export image, takes into account twice the width of the outer frame and the
thickness of the drop shadow. This must be taken into account when determining the size of
the work area. The image is truncated if it is larger than the work area.

The [Setting] tab
This tab allows you to apply specific values to the brightness, contrast, saturation and
gamma correction on the export image. All settings are optional. To make a setting optional,
set the brightness, contrast, or saturation to 0%. For gamma correction, set to 1.00.

Properties of the [Setup] tab
Move the slider on the slider to change the value in each option. Each option can be applied
to a particular color layer (red, green, blue, cyan magenta and yellow). Choose the color in
the Layer parameter window of the processed option.
To convert a series of images to grayscale, adjust the saturation to a minimum, that
is, to -100%.

The [Filter] tab
This tab allows you to apply a series of predefined filters to the export image. Filters are all
optional.

Properties of the [Filter] tab
To apply a filter, check the box of the one you want to use. All filters are cumulative. The
[Colored Filter] option is used to define the color of the filter to be applied. The option
[Opacity] defines the translucency coefficient of the filter. You can enable the [Invert] option
to simulate a color subtraction effect.

The [Transformation] tab
This tab allows you to apply rotation and symmetry effects to the export image. All options
are optional.

Properties of the [Transformation] tab
To apply a transformation, check the box of the one you want to use. Rotations and
symmetries are cumulative.
• The [Rotation] option
The [Rotate 90 ° clock] setting
It rotates a quarter of a turn in the clockwise direction, the export image.
The [Rotate 90 ° counterclockwise] parameter
It rotates the export image by a quarter of a turn in the opposite direction of clockwise.
The [Rotate 180 °] parameter
It rotates the export image by half a turn.
• The [Symmetry] option
The parameter [Vertical symmetry] (or horizontal axis symmetry)
It makes it possible to vertically switch the export image. This gives a reflection effect in the
water.
The parameter [Horizontal symmetry] (or vertical axis symmetry)
It allows you to flip the export image horizontally. This gives a mirror effect.

The [PhotoPNG] tab

This tab allows you to apply overlay effects with color images. The use of this module is
optional.

[PhotoPNG] tab properties
To use this module, you must check the [PhotoPNG] option. The choice of the image to insert
is made using the opening button symbolized by a small folder. After selecting the PNG
image, a preview is proposed in the corresponding window. At this point, you can change the
orientation of the PNG image. To do this, use the button below the preview.
• The [Mode] setting
This parameter allows you to choose how the PNG image will be applied to the media.
Three modes are available:
Framing mode
This mode automatically embeds the chosen PNG image on the entire surface of the media.
Pattern mode
The PNG image is used as a pattern to fill the entire surface of the media.
Position mode
This mode allows you to choose where the PNG image will be embedded on the media.
• The [Opacity] setting
This setting allows you to change the opacity of the PNG image to reduce overlay effects.

• The [Scale] parameter
This setting allows you to stretch or shrink the PNG image to be embedded. It is only
available with [Position] mode.
• The [Position] parameter
This parameter is used to define one of the nine locations where the PNG image will be
embedded. It is only available with [Position] mode.
Use the [Filter> PhotoPNG] menu to pre-test a single image.

The [Copyright] tab
This tab is intended to insert a copyright to the export image. This option is optional.

Properties of the [Copyright] tab
To insert the copyright into the export image, you must check the [Copyright] option.
• The option [Copyright]
[Size], [Color] and [Font] settings
They allow to choose the size, the color and the font to apply to the copyright text.
[Bold], [Italic] and [Underline] options
They allow, if the boxes are checked, to apply a style to the text of the copyright. They are
cumulative.
The [Alignment] parameter

It allows to indicate the place where will be positioned the text (left, middle, right) of the
copyright.
The [Background] setting
It allows, if the box is checked, to choose a background to the text of the copyright. The color
strip is applied across the entire width of the image. The height of the banner depends on the
height of the text.
The preview area provides, in real time, an overview of the eight parameters above.
[Top], [Center] and [Bottom] options
They allow you to position the copyright text at the top, center, or bottom of the export image.

The option [Outside ]
It allows, if the box is checked, to position the copyright outside the image. If the box is
unchecked, the text is positioned inside the image. This parameter is not available if the
[Center] option has been chosen.
The parameter [Opacity]
It allows to apply a translucency effect to the copyright. It applies to both the content and the
text.
This setting is available only if the [Outside] option is not enabled.
The input area
It allows you to enter your text for the copyright. The drop-down menu (available by pressing
the button to the left of the input box) allows you to choose from six predefined options.
Copyright
File name

Displays the text "Copyright ©"
<#N>

Displays the name of the file without extension

File name + Extension <# Do>

Displays the file name with its extension

Dated

<#D>

Displays the modification date of the export file

Width x Height

<#w> x <#h> Displays the width and height in pixels of the image

Width

<#W>

Displays the width in pixels of the image

Height

<#H>

Displays the height in pixels of the image

The <value> syntax is shorthand text that appears in the input box. PhotoFiltre will interpret
the shortcut to indicate the correct value when processing the function. In addition to these
six options, you can enter personal text. You can mix personal text and predefined shortcuts.
The copyright has only one line. If the entered text is larger than the width of the image, the
line will be truncated according to the alignment type definition. If there is no text in the input
box, the copyright will not be created.
Use the [Image> Copyright] menu to pre-test an image.

The [Action] tab
This tab is used to trigger the processing of the operations defined in the different tabs and to
save the options and parameters in the configuration file. It also displays, in the form of a
report, the operations to be performed and the list of images processed or in error (at the end
of processing).

Properties of the [Action] tab
• The display window
In this window are listed, in the form of a report, all the operations to be performed and the
list of images processed or in error at the end of processing.
• The [Save Settings] button
It allows to save, in the initialization file of PhotoFiltre , the various options and parameters
which will be taken again at the next launching of the module.
• The [Ok] button
It triggers the modification operations. The module window is erased. Each processed image
is displayed in the PhotoFiltre work area and is replaced by the next one. Only the last
remains visible. At the end of processing, the module window is visible again and the [Ok]
button is grayed out.
In the display window, a list of processed files is inserted after the operations. A list of error
files is also displayed in case of processing problems on the images. If there are more than
ten errors, during image processing, PhotoFiltre stops the editing procedure.
To stop processing, press the [Esc] key. PhotoFiltre then displays a dialog box
asking you to confirm that you stop processing or resume processing.

The order of treatments
It is important to know the order of the processes because, if it is not appropriate, it is
advisable to launch the automation module several times using a lossless intermediate
export format (for example BMP).
1. Opening the image
2. Size of the image
3. Settings
4. Filters
5. PhotoPNG
6. Framing
7. Size of the work area and shading
8. Transformations
9. Force DPI
10. Copyright
11. Color reduction
12. Saving the image

Create animated images

use
The animated Gif module allows you to create animations of the animated Gif type, using
the internal layer management of PhotoFiltre .

Animated Gif Module Properties

Principle of the animated Gif
The animated GIF consists of images placed one behind the other and which give an
animation effect thanks to the retinal persistence. The image of the frame name is also
called. Each image is displayed for a specific period of time called duration.
In PhotoFiltre , the different images composing the animation are the layers.

Constitution of the animated Gif
The preparatory work is essential, because you have to organize the layers according to
the type of animation you want. For example, to get a transparent animated GIF, you
must first set the transparency of each layer.
To begin, you must open an image (composed of one or more layers) or create a new
document as a background. The background will determine the size of the animated Gif.
Then, to simulate the animation, you have to create as many layers as you need, starting
from the bottom and stacking them. The stacking order will determine the order of the
images to be animated. You must know that the background will not form a GIF frame,
but will only serve as a support. Depending on the options selected, PhotoFiltre may
need to merge a layer with the background or the one below it to compose the
animation.
For this type of work, you can refer to the different chapters related to layers.
The number of images is unlimited, but it depends on your operating system and the
available memory on your computer.
During the creation of the animated GIF, it is advisable to save the work in PFI
format for easier editing later.

You can open an existing animated Gif in PhotoFiltre . The file is open in layer
mode. Each layer corresponds to an image of the animated Gif.

Generation of the animated Gif
To generate the animated Gif, you must use the [Tools> Animated Gif] menu. This
command remains grayed out if there is no image present on the workspace. You need
at least two layers (a background layer and another layer), otherwise PhotoFiltre returns
an error.
When generating an animated GIF, all layers are taken into account by the module, even
those that are hidden.
• The [Duration] option
This option consists of two integral parameters. It allows to assign to images a display
delay in hundredths of a second. This duration indicates that the image will be visible
during the mentioned time before moving on to the next one. By default, the values are
100 / 100th of a second (equivalent to one second).
The durations are preserved throughout the PhotoFiltre session as long as the number
of layers composing the GIF does not change too much.
In the drop-down list on the right, you will find a hierarchy corresponding to that of the
layer bar. The list is determined as follows:
1. All images
2. Name of the first layer
3. Name of the next layer and the same until the end
To set a uniform duration for all images, select [All Images] in the list. To set a duration
for a specific image, select the name of the corresponding layer from the list.
We can set a duration of zero to ignore the image concerned.
If you need to change the duration on a few layers and give all others a uniform
duration, first apply the uniform duration to all the images and then modify the
particular layers.
• The option [Close]
This option allows you to continually repeat the animated GIF. By default, the box is
checked.
• The [Broadcast] option
This option allows to apply an algorithm improving the visual quality of the image when
reducing the number of colors. By default, this box is checked.
• [Restore background] option
This option automatically inserts the background layer between each image. We can
thus simulate a constant background in the animation.

• [Crop Transparent Edges] option
This option allows you to trim transparent edges on layers that are smaller than the
bottom.
• The option [Web 216 colors]
This option allows you to use an improved 216 color palette for the Web. In this case,
PhotoFiltre creates a constant palette for each of the images composing the animation.
The result is of lower quality, but it offers greater compatibility with other applications. By
default, this option is selected.
• The [Optimized Palette] option
This option allows you to calculate optimized palettes of 256 colors. In this case,
PhotoFiltre uses different colors for each of the images composing the animation. The
result is better, but not compatible with some applications.
• The option [Transparency]
This option allows you to create fully transparent animated GIFs. In this case, each layer
corresponds to an image composing the animation. Transparency is taken from the
layer, but the opacity of the layer is ignored. You must understand that this option only
affects the generated GIF, but does not affect the transparency of the layers.
• The [Preview] button
PhotoFiltre opens a window of your Internet browser to preview the animated Gif. In
case of transparent Gif, a bottom checkerboard is visible to better visualize
transparency.
• The [Export] button
It launches the standard Windows dialog box for saving with GIF as the unique file type.

Creating a slideshow
This type of animated Gif is the easiest to do because it consists of a series of images of
the same size. Here, the preparatory phase is important because you have to prepare a
series of images of the same size in width and height. In our example, we will use the
three images below.

1. Open the first image in PhotoFiltre
2. Insert a new blank background to prevent the first frame from being ignored in the
animation. Use the [Layer> Insert New Background> Blank] command.
3. Open the other images as a layer. Repeat as many times as there are images to

insert. Use the [Layer> New> Open As Layer] command.
4. You can now generate the animated GIF using the following options:
- Duration of 100/100 for all the images
- Buckle
- Optimized palette (this option is recommended despite compatibility issues)
- Diffusion

Parade of men (with an opaque and constant background)
We need the following two pictures. Note that the layer is opaque while the guy is in
transparent mode.

The image on the left serves as a background, the image of
right is used to build the layers.
1. Start by opening in PhotoFiltre , the background image.
2. Open the image of the man as a layer. Use the [Layer> New> Open As Layer]
command.
3. Duplicate the human layer twice with the [Layer> Duplicate] command
4. Move the layers to have one in the center, one on the left and one on the right.
After these operations, you must obtain a layered image, similar to the screenshot
below.

5. Generate the animated GIF using the following options:
- Duration of 40/100 for all images
- Buckle

- Restore the bottom
- Web 216 colors

Creating a counter (in transparent mode)
1. Launch PhotoFiltre and create a new image of 150x150 pixels. You can leave the
white background because it will be ignored in the animation.
2. Insert a new text with the number "3" (Impact font, size 100, Black color, Smoothed).
Leave the new layer in the center of the image.
3. Select the layer at the top of the stack and hide it. Insert new text with the number "2"
using the same font settings as before. Leave the new layer in the center of the image.
4. Select the layer at the top of the stack and hide it. Insert new text with the number "1"
using the same font settings as before. Leave the new layer in the center of the image.
5. Select the layer at the top of the stack and hide it. Insert a new text with the number
"0" using the same font settings as before. Leave the new layer in the center of the
image.
6. Select the layer at the top of the stack and hide it. Insert a new text with the number
"Go" using the same font settings as before. Leave the new layer in the center of the
image.
After these operations, you must obtain the layers below.

7. Generate the animated Gif with the following options:
- Duration of 50/100 for all the images, then 100/100 for the last one
- Buckle
- Transparency
- Web 216 colors
- Diffusion

Image fade
To make a fade, we need two images of the same width and height. In our example, we
will use the two images below.

1. Open the first image in PhotoFiltre
2. Insert a new blank background to prevent the first frame from being ignored in the
animation. Use the [Layer> Insert New Background> Blank] command.
3. Open the second image as a layer. Use the [Layer> New> Open As Layer] command.
4. Duplicate the layer of the second image twice with the [Layer> Duplicate] command.
You must obtain three occurrences of the second image.
5. Apply a 30% opacity to layer number 2 (the first occurrence of the second image)
6. Apply 50% opacity to layer number 3 (the second occurrence of the second frame).
After these operations, you must obtain the following layered image:
Blank background
Layer 1 = Image 1, opacity 100%
Layer 2 = Image 2, Opacity 30%
Layer 3 = Image 2, Opacity 50%
Layer 4 = Image 2, opacity 100%
7. Generate the animated GIF using the following options:
- Duration of 30/100 for all the images
- Buckle
- Optimized palette (this option is recommended despite compatibility issues)
- Diffusion

Image rising

To achieve this effect we need a single image. We will also use the layer merge
principle.

1. Open the image above in PhotoFiltre . It will serve as support (bottom)
2. Try to play back the next layered image. The layers are described from the bottom up.

Background = image above
Layer 1 = Color Layer, White, 100% (1)
Layer 2 = Color Layer, White, 75%
Layer 3 = Color Layer, White, 50%
Layer 4 = Color Layer, White, 25%
Layer 5 = Blank, completely transparent layer (2)
Layer 6 = Color Layer, White, 25%
Layer 7 = Color Layer, White, 50%
Layer 8 = Color Layer, White, 75%
(1) To create a new color layer, use the [Layer> New> Color] menu. Select the white
color and change the opacity.
(2) To generate a completely transparent layer, use the [Layer> New> Blank] menu. In
the New setting window, select the Automatic transparency check box.
3. Generate the animated Gif with the following options:
- Duration of 20/100 for all the images, 100/100 for the layer 1 and the layer 5
- Buckle
- Restore the bottom
- Optimized palette (this option is recommended despite compatibility issues)
- Diffusion

External modules

Defining PhotoFiltre plugins
External plug-ins are programs, in the form of libraries, that enrich the functionality of
PhotoFiltre . External plug- ins are also called plug-ins or plug-ins . In Quebec, we also
use the word graft .
PhotoFiltre plug-ins are not compatible with other applications. With the exception of 8BF
filters, plug-ins developed for other applications are not supported by PhotoFiltre .
PhotoFiltre manages several types of plug-ins. Each type is placed in a dedicated menu.

The different types of plugins
• Filter modules
They are available in 16 million colors, and apply to the selection of the current image.
They are placed in the [Filter> Plugin] menu.
• Image modules
They are available, regardless of the number of colors, and apply to the entire image in
progress. They are placed in the [Image> Plugin] menu.
• Import type modules
They are intended for import functions and are always available (with or without image).
They are placed in the [File> Import] menu.
• Export- type modules
They are intended for the export functions of the current image.
They are placed in the [File> Export] menu.
• Tool- type modules
They are intended for functions that can not be classified in the above types.
They are placed in the [Tools> Plugin] menu.

Add plugins to PhotoFiltre
• Search modules
External modules can be downloaded from www.photofiltre.com in the Plugins section.
External modules are usually in compressed ZIP format.
Each ZIP file consists of two files:
- a PFL file ( PhotoFiltre Library , module program file).
- a TXT file (text file giving technical information: author, module name, version and

details of the modus operandi).
• Installing the plugins
The ZIP file is uncompressed in the [Plugins] folder of PhotoFiltre . The default folder is:
[C: \ Program Files \ PhotoFiltre Studio X \ Plugins]
The installation of a file with the PFL extension is required. You can also install the text
file that will allow you, if necessary, to find the operating mode of the module. A restart of
PhotoFiltre is necessary for the recognition of newly installed modules.
Too many plugins can slow down PhotoFiltre startup.

Using the plugins
• Verification of the presence of the modules
For this check, click on the [?] Menu. If the [About the module] command is missing,
check the following 2 points:
1. Check if the box, [Load modules at startup], is checked in the boot preferences.
2. Check if the plugins have been installed in the [Plugins] folder of PhotoFiltre . There
must be at least one valid PFL file in the folder.
• Launching the plugins
To know the type to which a module belongs, launch the command [? > About the
module]. Choose the one you want to use. PhotoFiltre then displays the properties
window for the plug-in.

Properties of an external plugin
Here is the detailed description of the module properties window:
- Name of the external module followed by its version number
- Date of commissioning
- Name of the author of the plugin
- Menu: indicates the path to find the plugin in PhotoFiltre
- File name: indicates the name of the PFL file of the plug-in

- The description of the plugin
The menu corresponding to the execution of the module may, in some cases,
be grayed out. Check the module documentation for its execution conditions.

The module bar
To make it easier to launch plug-ins, PhotoFiltre can create a module bar. To make it
visible, you must check the [View> Module Bar] menu. If the menu is grayed out, it
means that there is no module in the [Plugins] folder (or that the modules present are not
valid).
You can customize the plug-in bar with the [Tools> Preferences] command by selecting
your favorite modules (up to 20). If no module is selected, PhotoFiltre automatically
takes the first 20 in the list.
See the Customize PhotoFiltre chapter for more information on the module bar.
The module bar is always positioned opposite the tool palette.

Development of external modules
Plugins can be written by any developer with knowledge in any of the following
languages: Delphi, Visual C ++, C ++ Builder, Standard C, and ASM.
To make the plug-ins, programmers must load a development kit from
www.photofiltre.com in the Plugins section. This kit contains the development interfaces,
the documentation of the functions as well as some examples.

8BF filters
• Definition
8BF filters are also plug-ins, but unlike PhotoFiltre plug-ins they are compatible with
many applications. In general, 8BF filters can apply effects to images.
• Search for 8BF filters
There are thousands of 8BF filters on the web. It's up to you to find the ones that suit you
best. The installation file must contain at least one file with the extension 8BF.
• Installing 8BF filters
Copy the 8BF file, and all necessary files for its operation, to the folder defined by the
[8BF Filters Folder] setting in the 8BF preferences. A PhotoFiltre restart is needed to
recognize newly installed filters.
See the Customize PhotoFiltre chapter for more information on setting up 8BF filters.
Too many 8BF filters can slow the start of PhotoFiltre .

Create icons

use
The icon export module allows you to create Windows icons from any image.

Export module properties in icon

Definition
In computer language, an icon is a small image representing an application, a file, a
document or a folder, in a graphical operating system such as Windows , Linux or
Macintosh .
On Windows , an icon is saved as an image file with the ICO extension. There are
different icon sizes, but the most common ones are 16x16, 32x32 and 48x48.
Windows XP and later support 32-bit icons in true color mode (TrueColor) with 24 bits
allocated for color and 8 bits for Alpha. This format allows the system to display icons
with smooth outlines and semi-transparency effects. Previous versions of Windows (95,
98, ME, NT, and 2000) only support 1-bit transparency masks. On these operating
systems, the icons are displayed with sharp contours (without smoothing).

Generation of the icon
To generate an icon, you must use the [Tools> Export icon] menu. This command
remains grayed out if there is no image present on the workspace.
PhotoFiltre enforces the following rules:
1. No distortion of the image (conservation of proportions).
2. If the image is composed of multiple layers, all visible layers are merged.
3. If the image is transparent, PhotoFiltre preserves transparency.
4. If the image is in indexed color mode, PhotoFiltre provides the most appropriate

export format.
• The dimensions
PhotoFiltre offers seven predefined sizes:
- 16x16: compatible with all versions of Windows
- 32x32: compatible with all versions of Windows
- 48x48: compatible with Windows XP and higher
- 64x64: compatible with Windows XP and higher
- 96x96: compatible with Windows XP and higher
- 128x128: compatible with Windows XP and higher
- 256x256: compatible with Windows XP and higher
• The export format
PhotoFiltre uses the format of the current image as the export format of the icon. For
example, if the current image is in 256 colors, PhotoFiltre offers an 8-bit default export
format.
The RGB Color option allows you to force the 24-bit mode and ignore the
current image format (only for indexed mode images)
If the current image contains Alpha transparency (RGBA), the icon will be
exported in 32 bits
All icons in 256x256 are exported in 32 bits for Windows compatibility
• The [Export] button
This button launches the standard Windows dialog box allowing recording with ICO as a
single file type.

The image manager

use
The purpose of the Image Manager is to manipulate image files to rename, move, copy
or delete them. To start one of these four commands, use the [Tools> Image Manager]
menu.
The Image Manager is accessible only if there is an open image in the PhotoFiltre
workspace and this image is from a file.

Rename an image
The [Rename Image] command changes the name of the open image. It is accessible
via the menu [Tools> Image Manager> Rename Image]. After displaying the setting
window, enter the new name in the input box and confirm. You do not have to enter the
file extension because PhotoFiltre does not allow this change and the original extension
is always preserved. The new name is automatically updated in the title bar of the image.

Properties of the Rename Image command.
If the image has been modified, PhotoFiltre proposes to save the image before executing
the command.
This command can also be activated by pressing the [F2] key.

Move an image
The [Move Image To] command moves the open image to another folder. It can be
accessed via the [Tools> Image Manager> Move Image To] menu. After displaying the
setting window, click the button to the right of the folder name. PhotoFiltre displays the
Windows dialog box that lets you choose the destination folder. Select the destination
folder and confirm.

Properties of the Move Image To command.
If the image is already present in the destination folder, a warning window prevents the
move. The open image is assigned to the new folder and is deleted in the original folder.
If the image has been modified, PhotoFiltre proposes to save the image before executing
the command.

This command can also be activated by pressing the [Shift + M] keys .

Copy an image
The [Copy to Image] command copies an open image to another folder. It can be
accessed from the [Tools> Image Manager> Copy Image To] menu. After displaying the
setting window, click the button to the right of the folder name. PhotoFiltre displays the
Windows dialog box that lets you choose the destination folder. Select the destination
folder and confirm.

Properties of the command Copy image to.
If the image is already present in the destination folder, a warning window prevents
copying. If the image has been modified, PhotoFiltre proposes to save the image before
executing the command.
This command can also be activated by pressing the [Shift + C] keys.

Delete an image
The [Delete Image] command sends an open image to the Windows Recycle Bin. It can
be accessed via the [Tools> Image Manager> Delete Image] menu. After confirming the
deletion, the next image (in the deleted image folder) is opened in the workspace instead
of the deleted image.

Confirmation of the deletion.
This command can also be activated by pressing the [Shift + Delete] keys.

Customize PhotoFiltre

use
The purpose of the [Preferences] command is to customize and make PhotoFiltre easier
to manage. It has twelve pages that allow you to determine parameters that will be used
by other commands (default values, definition of folder locations, ...).
To start the command, you can:
- use the menu [Tools> Preferences]
in the toolbar
- click on the icon
To display the different pages, you can:
- use the drop-down menu
- use the arrows on the left and right of the drop-down menu. The left arrow goes back in
the list, the right advances in the list.

The [Folders] page
This page is used to determine the opening folder and the folder for saving images.
These choices are applied when opening and saving an image and by some commands.

Properties of the Folders page
• The [Opening File] option
This option allows you to search the default folder for the images to be processed.
Pressing the icon on the right opens the Windows Folder Search dialog. If the [Lock
Folders] option is not checked, the folder will be replaced by the folder of the next open
image.
• The [Registration Folder] option
This option searches for the default save folder for processed images. Pressing the icon

on the right opens the Windows Folder Search dialog. If the [Lock Folders] option is not
checked, the folder will be replaced by the folder of the next saved image.
When opening and saving an image, these folders will be offered first. At this
point, the user, of course, always has the possibility to choose different folders.
To edit the recording folder, when saving an image, use the [File> Save As]
command.
• [Lock Folders] option
If this box is checked, the opening and saving folders are not changed after opening or
saving an image.
• The option [Single folder for opening and recording]
If this box is checked, the record folder is the same as the opening folder. In this case,
the [Registration Folder] option is grayed out.

The [Opening] page
This page makes it possible to determine particular treatments to be performed when
opening the image file.

Properties of the Opening page
• [Rotation based on EXIF orientation] option
This option allows you to apply automatic rotation when opening the image according to
the orientation stored in the EXIF metadata. This rotation will not be taken into account
when saving the image in JPEG with preservation of the EXIF metadata.
• [Open images in 16 million colors] option
If this option is checked, an indexed color image (1 to 8 bits) will be automatically
opened in 16 million colors (RGB for images without transparency and RARBA for
images with simple or complex transparency). This automatically activates the RGB
color mode features (filters, drawing tools, collage, text, etc.).

• [Auto White Balance for RAW Images]
If this option is checked, PhotoFiltre performs an automatic white balance when opening
RAW images to correct exposure and colors. If this option is not checked, no correction
is made (raw data recovery).
See also chapter Open an image .

The [Registration] page
This page is used to determine a default format and some properties to keep when
saving the file.

Properties of the Registration page
• [Use a default format] option
This option determines the default record format type. If this box is unchecked, the dropdown list is grayed out (not available). When saving the image, the type of format
proposed is that of the opening image. If this box is checked, select a file format from the
drop-down list. This type of format will be proposed when saving the image.
• [Keep file date] option
If the box is unchecked, the date and time of the image change are those determined by
the system at the time of registration. If the box is checked, the date and time of the
image modification are not changed (unless the image has never been saved before).
• The option [Keep Exif information]
Some images from digital cameras contain EXIF or IPTC type metadata. If the box is
checked, these metadata will be kept (if possible) during the recording.
See also chapter Saving an image .

The page [History]
This page is used to determine the maximum number of changes (Histories) that will be

saved in memory by PhotoFiltre for the same image. If the number of logs arrives at the
one specified on the page, and there is a new change, PhotoFiltre removes the oldest
history to save the new one. This parameter is linked to the [Edit> Undo] (or Ctrl + Z),
[Edit> Redo] (or Ctrl + Y) and [Edit> History] (or Shift + Z) commands.

Properties of the History page
• The [History by Image] parameter
To determine the number of histories for an image, move the slider on the slider from left
to right (value between 2 and 48). The position of the cursor gives, in the frame below,
the amount of memory required for comfortable use.
Observe the warning in red, to take into account the modifications.

The [Tool Palette and Grid] page
This page allows you to position the tool palette in different places on the PhotoFiltre
workspace and to determine the settings for the marker grid.

Tool Palette and Grid Page Properties
• The [Alignment of the Tool Palette] option

You can position the tool palette in different places in the workspace.
PhotoFiltre offers three alignment options.
floating
In this mode, you can position the Tool Palette anywhere on your desktop. This one will
always be visible, because it stays above the other windows of the application. To move
it, position the mouse cursor in the title bar named "Tools" and, while holding down the
left button, move the cursor to the desired location. Its position will be kept the next time
PhotoFiltre is opened.
The red cross on the right side of the title bar hides the tool palette. To reactivate it,
check the [View> Toolbar] (or CTRL + L) command.
Left
The tool palette is docked to the left of the workspace. It takes the form of a toolbar and
it can not be moved.
Right
The tool palette is docked to the right of the workspace. It takes the form of a toolbar and
it can not be moved.
• The group [Grid]
The following settings will be used by the [View> Location Grid] command.
The [Unit] parameter
This parameter specifies the type of unit (pixels, cm, or inches) to use to generate the
square-shaped cells in the grid.
The [Color] parameter
This parameter indicates the color of the net that defines the outline of the cells.
The [Cell size] parameter
This parameter indicates, for the unit in pixels, the size of the cells with a maximum size
of 300 pixels. For units in cm and inches, this setting is inactive because the size is
forced to 1 cm or 1 inch. The spacing of the cells is then related to the resolution of the
image.

The [Defaults] page
This page allows you to define values that will be used by some commands when
starting PhotoFiltre .

Page Properties Defaults
• The group [Units]
Picture Setting
The three choices are pixels, cm and inches. They are found in the Image Size, New,
and Work Area Size commands.
Parameter Print
The two possible choices are cm and inches. They are found in the print module.
• The group [Dialog Boxes]
[Remember settings] option
If this option is enabled, PhotoFiltre saves to a file the location and settings entered in
the dialog windows. If this option is disabled, no items will be saved (for the next
PhotoFiltre launch).
The [Reset] button
Pressing this button displays a request for [Confirmation]. If the answer is [Yes], the
settings backup file will be deleted. A PhotoFiltre restart is required to clear the
remaining settings stored in the software memory.
[Automatic] option
If this option is enabled, PhotoFiltre automatically resets the defaults when you open the
dialog box for some setting filters. If this option is disabled, the last values used in these
filters are retained.
This option has an impact on the following tuning filters:
- Custom
- Brightness
- Contrast
- Hue / Saturation

- Color balance
- Gamma correction
- Levels

The [Plug-in Bar] page
This page allows you to choose from 1 to 20 external modules that will be displayed as a
button in the plug-in bar. These modules are specific to PhotoFiltre .
Observe the warning in red, to take into account the modifications.

Properties of the External Plugins Bar page
The list that is generated corresponds to a list of PFL (PhotoFiltre Library) files contained
in the PhotoFiltre Plugins folder. To select the plug-ins, just check the list (up to 20) of
the modules you want to appear. In general, select the ones you use most often. If no
module is selected in the list, PhotoFiltre will take the first 20.
Refer to the chapter Plugins for more information on the module bar.

The page [8BF]
This page is used to determine the call mode and storage folder for 8BF filters. In this
folder, you can use subfolders to prioritize modules.

8BF Page Properties
For the options to be active, the 8bf.pfl file must be present in the PhotoFiltre Plugins
folder. These options are related to the [Filter> 8BF Filter] command.
Refer to the chapter Plugins for more information about 8BF filters.
• [8BF Filters Folder ] option
In this option, pressing the icon on the right opens the Windows Folder Search dialog
box. It is advisable to share this folder with other applications.
Observe the warning in red, to take into account the modifications.
• The [Mode] option
This parameter is used to define the call mode of the 8BF filters. In RGB Color mode,
PhotoFiltre does not allow 8BF filters to change the Alpha layer. On the other hand, the
modification of the Alpha layer is possible in RGBA mode, if the filter manages this
possibility.

The [JPEG Compression] page
This page is used to set the recording of images in JPEG format.

JPEG Compression Page Properties
• The option [Ask the user]
With this option, the user chooses the compression ratio. At the request of saving the
image, and just after the Windows Registration dialog box, a window appears asking for
the compression rate to apply.
• [Force a default compression] option
When this option is enabled, you have access to the slider underneath which allows you
to choose the compression ratio. By default, it is 90%. At the request of saving the file,
and just after the Windows Registration dialog box, the image is saved directly with the
chosen rate.

The [Start] page
This page allows you to customize PhotoFiltre and apply some properties that are taken
into account at startup.

Startup Page Properties
• The option [Allow Multiple Instances]

If the box is unchecked, only one instance of PhotoFiltre can be launched in the system.
If the box is checked, we can launch several PhotoFiltre instances in the system. This
option is important when you associate file formats with PhotoFiltre .
• [Disable advanced display] option
In advanced view, PhotoFiltre improves the display of buttons on the toolbar, toolbox,
and module bar by adding shadows and gradients. It also improves the ergonomics of
the drop-down and contextual menus by drawing an icon corresponding to the menu
function. This mode can cause compatibility problems on some systems or slow down
the display. PhotoFiltre offers the possibility to disable this mode by checking the box.
• [Disable background texture] option
The color of the PhotoFiltre work area is determined by the Windows display settings. If
the box is unchecked, the work area looks like a fabric frame. If the box is checked, the
work area is solid (standard)
• [Disable XP Menus]
PhotoFiltre improves the display of menus by adding a color gradient and displaying, in
red, the keyboard shortcuts. This mode is available only on Windows XP . To use the
standard menu display, check this box.
• [Load plugins at startup] option
If the box is unchecked, access to the PhotoFiltre plug-ins and 8BF modules is denied. If
the box is checked, access to PhotoFiltre plug-ins and 8BF modules is allowed.
• [Clear recent open files history] option
The [File> Recent Files] command displays the latest open files. The number of visible
files is 12 at most. If the box is unchecked, the file list remains visible each time
PhotoFiltre is started. If the box is checked, the file list will be deleted each time
PhotoFiltre is started.
• [Disable Start Screen] option
If the checkbox is unchecked, PhotoFiltre does not display at startup the splashscreen
that lists various components used (plug-ins, 8BF filters, preferences).
• The option [Translucent dialogs]
If the box is unchecked, the dialogs are opaque. If the box is checked, the dialog boxes
are translucent. This mode is available only on Windows XP and the higher versions.
Observe the warning in red, to take into account the modifications.

The [Miscellaneous] page
This page also allows you to customize PhotoFiltre and to apply some properties to it
that are taken into account as soon as the validation.

Properties of the Miscellaneous page
• [Show Active Layer Limits]
This option allows you to view the outline of the active layer. If this box is checked, the
active layer will be delimited by a dotted line. If this box is unchecked, no outline will be
displayed.
• The option [Cursors actual size for drawing]
This option allows you to have more precise cursors when using drawing tools. If this
box is checked, the drawing tools will have sliders of particular size and shape. The
shape depends on the type of tool selected. The size depends on the dimensions of the
tool and the display zoom. If this box is unchecked, the cursor will be represented by a
cross or an icon symbolizing the selected tool.
• [Draw on Alpha Transparency] option
If this option is enabled, PhotoFiltre changes the alpha transparency of the layer when
drawing tools are used. In this case, the opacity of the layer is modified according to the
opacity of the drawing and the transparent areas are replaced by more or less opaque
areas at the level of the plot. If this option is disabled, the Alpha transparency is not
impacted by the drawing tools.
• [Disable zoom with mouse wheel]
The zoom allows a reduction or enlargement of the display of the image. Plus, you
enlarge an image, plus the pixels are magnified. In this case, they can be modified more
easily. The zoom values range from 10% to 1600%. If the box is unchecked, the mouse
wheel can be used to modify the zoom (forward, down, up, zoom out). If the box is
checked, the mouse wheel has no effect on the zoom. In this case, use the zoom in the
toolbar.
• The [Automatic Layer Selection] option
If this option is enabled, PhotoFiltre automatically turns on the layer corresponding to the
region of the clicked image. If this option is disabled, you must select a thumbnail in the
layer bar to activate the desired layer.

• The option [Numbering of layers]
If this option is enabled, PhotoFiltre displays increasing numbering on behalf of each
layer. This numbering starts from the bottom of the stack of layers upwards. If this option
is disabled, no numbering is displayed.
• [Extend layer for drawing] option
If this option is enabled, PhotoFiltre automatically extends the layer to the background
size when you start drawing. For this option to be active, [Draw on Alpha Transparency]
must be checked.

The page [Vista & Windows 7]
This page allows you to customize the PhotoFiltre interface by applying personal colors
to certain elements. It is available only on systems with Windows Vista and Windows 7
versions.

Properties of the Vista and Windows 7 page
• The [Background] setting
This setting is used to set the color of the PhotoFiltre workspace.
• The [Color 1] setting
This setting is used to set the color of the PhotoFiltre toolbar.
• The [Color 2] setting
This setting is used to set the color of the PhotoFiltre toolbox and plug-in bar.
• The [Reset] button
This button forces the predefined colors (charcoal gray, sky blue and gray blue).
• The [System] button

This button is used to recover the default colors of the Windows operating system.
(In general, these are metallic gray dominants used for 3D effects)
• The option [Use XP dialogs]
This option makes it possible to force the XP style dialogs, to preview (thumbnail and
Exif information), during a request to open a file.
• [Use XP Display Style] option
This option displays the PhotoFiltre interface in the XP style.
Observe the warning in red, to take the changes into account!

Keyboard shortcuts

Various
CTRL + B

Contour and filling

CTRL + C

Copy to the clipboard

SHIFT + CTRL + C

Copy with merge to the clipboard

CTRL + E

Displays / Hides the Image Explorer

CTRL + H

Image size

SHIFT + H

Size of the work area

SHIFT + CTRL + H

Crop image (if selected)

CTRL + J

Display the properties of the image

CTRL + K

Repeat the last action (Edit menu)

CTRL + L

Show / Hide the Tool Palette

CTRL + N

New image

CTRL + O

Open an image

CTRL + P

Prints the current image

CTRL + Q

Quit PhotoFiltre

CTRL + R

Restores the image with the latest version saved

CTRL + S

Saves the current image

SHIFT + CTRL + S

Save the image under a new name

CTRL + T

Adds a new text layer

CTRL + U

Duplicate the current image

CTRL + V

Paste the contents of the clipboard

SHIFT + CTRL + V

Paste the contents of the clipboard as a picture

CTRL + W

Closes the current image

CTRL + X

Cut to the clipboard

CTRL + Y

Restore the last action

CTRL + Z

Cancel the last action

SHIFT + Z

Displays the history list

SHIFT + CTRL + Z

Attenuates the last action

Direction keys (*)

Scroll image if it is larger than the display area (**)

(*) Arrows UP, DOWN, LEFT, RIGHT
(**) If the Selection tool or the Move tool is active in the Tool Palette

Activation of tools (in the tool palette)

K

Pipette Tool

The

Magic wand tool

M

Line Tool

NOT

Fill Tool (Bucket)

O

Airbrush Tool (Spray) (*) (**)

P

Brush Tool

Q

Advanced Brush Tool (*) (**)

R

Blur Tool

(*)

S

Finger tool

(*)

T

Cloning Buffer Tool

(*)

U

Scrolling tool

V

Rubber

W

Layer Manager

X

Retouching Tool

(*)

Y

Deformation tool

(*)

Z

Artistic Brush Tool

(*)

0 (zero) Nozzle tool

(**)
(*) (**)

(*) (**)

(*) (**)

(*)

(*) Continuous pressing the SPACE key toggles the current tool in [Move] mode.
Stopping the pressing the SPACE key allows the return to the selected tool.
(**) Pressing the CTRL key continuously switches the current tool in the [Pipette] mode.
When the CTRL key is pressed, it returns to the selected tool.

Selection tool
CTRL + A

Select the whole picture

SHIFT + CTRL + A

Selects all the layer

CTRL + D

Show / hide the selection

CTRL + G

Parameterized selection (manual adjustments)

CTRL + I

Inverts the selection

Delete

Clears the selection with the background color

Esc (Esc)

Hides the selection

AT

Rectangle Selection

B

Ellipse selection

VS

Rounded Corners Selection

D

Losange Selection

E

Triangle selection base down

F

Left Triangle selection

BOY WUT

Triangle selection base up

H

Right base triangle selection

I

Lasso selection (freehand)

J

Polygon selection (multilines)

Direction keys (*)

Move the selection of a pixel

SHIFT + Direction Keys (*) Move the selection of 8 pixels
Double click

Show / hide the markers of the selection

(*) Arrows UP, DOWN, LEFT, RIGHT
The ALT key can be used in combination with the arrow keys to change the size of the
current selection.
Using the SHIFT key, with the arrow keys, can be repetitive, pressing and releasing the
Caps Lock key (Caps Lock Caps Lock English) force the capital mode permanently.
Pressing the Caps Lock key again deletes this operation.

Viewing
CTRL + F Full screen mode / Slideshow
+

Zoom in (*)

-

Zoom out (*)

*

Automatic zoom (*)

=

Full size (*)

F1

Displays help

(*) The CTRL key combined with one of the zoom functions reposition the image at the
top left of the PhotoFiltre workspace.

Full screen mode / Slideshow
Origin (Home)

First image

Page Prec (PgUp) Previous image
Next Page (PgDn) Next image
End

Last picture

Space or Entrance Enable or disable the slide show
Esc (Esc)

Back to the workspace

Navigation keys
(in the current image folder of the workspace)
Origin (Home)

First image

Page Prec (PgUp) Previous image
Next Page (PgDn) Next image
End

Last picture

Image Manager
SHIFT + C

Copy the image to another folder

SHIFT + M

Move the image to another folder

F2

Renames the file name of the image

SHIFT + DEL Deletes the image (sends to the trash)

Layer management
F6

Next layer

F7

Previous layer

SHIFT + CTRL + G

Manual setting

CTRL + ENTER

Merge with the lower layer

SHIFT + ENTER

Merge all visible layers

Ctrl + Del

Deletes the current layer

Layer Manager Tool
Direction keys (*)

Move the layer one pixel

SHIFT + Direction Keys (*) Move the layer 8 pixels
Double click

Displays the properties of the layer

(*) Arrows UP, DOWN, LEFT, RIGHT
Using the SHIFT key, with the arrow keys, can be repetitive, pressing and releasing the
Caps Lock key (Caps Lock Caps Lock English) force the capital mode permanently.
Pressing the Caps Lock key again deletes this operation.

Vector path
SHIFT

While pressing the key
- the [Delete] function is enabled in all modes

CTRL

While pressing the key
- the [Add] function is activated in edit mode
- the [Edit] function is activated in the other modes

Direction keys (*)
SHIFT + Direction Keys (*)

In the [Move all points] function
- they offset the path of a pixel
- they offset the 8 pixel plot

Double click

In the [Edit] function and with the [Bezier Mode] checked
- it smooths a point on the track, a new Double-Click
resets the point

Esc (Esc)

Exit the [Vector Path] function at any time

(*) Arrows UP, DOWN, LEFT, RIGHT

Install PhotoFiltre

Introduction
PhotoFiltre is compatible with the following versions of Windows :
- Windows 95
- Windows 98
- Windows Millennium
- Windows NT
- Windows 2000
- Windows XP
- Windows Vista
- Windows 7
PhotoFiltre is only available for download. To obtain it, you must log on to
www.photofiltre.com . On this page, there are two types of software downloads available.

• Version with installer
This version is for users who want to install PhotoFiltre automatically. In addition to the
software, it contains the following basic elements: selections, brushes, masks, patterns,
textures, PhotoPNGs, nozzles and vector paths. The installation file supports the
installation of files and folders.
• Version in zip format
This version is intended for users with knowledge in handling Windows Explorer and a
ZIP file decompression program. It contains the same elements as the version with
installer. All folders and files in the archive must be copied respecting the tree structure.

Download description
The following description is made with Windows XP SP2 . Depending on the type of OS,
it may differ in the graphics of windows, but not in the sequence of operations to be
performed.
After choosing the version to download, click on the corresponding line - in our example,
it is PhotoFiltre Studio (full version with installer) - and follow the progress of the
operations.
• File download

Properties of the Windows download window.
The [Execute] button
Avoid using this button. After the download, Windows automatically launches the
software installation, and it does not keep any trace of the downloaded file.
The [Save] button
Preferably use this button to move to the next window.
The [Cancel] button
This button stops the download.
• Save as

Properties of the Windows window Save As.
The [Save in] setting
In the drop-down list, choose the folder where the file will be stored.
The [File name] setting

By default, the name is the one indicated in the [File Download] window. But it is
possible to modify it, for example to add the version number. This does not overwrite the
old version of the software. Be careful, do not touch the .exe extension.
The [Save] button
This button starts the download. If a file of the same name is already present, a dialog
box asks to confirm the overwriting of this file to start the recording.
The [Cancel] button
This button stops the download.
• download progress

Properties of the Windows window for download progress.
The download time and the transfer rate depend on your type of Internet connection
(here, the transfer is done with a 512k ADSL line).
The [Cancel] button
This button interrupts the download during progress. Be careful, the downloaded file is
partially stored on your hard drive. It is prudent to delete it.
• Download complete

Properties of the Windows window Download completed.
The [Execute] button
Avoid using this button. To install software, it is recommended to close all applications.
At this point, the user is still connected to the Internet , so it is better to leave the Web.
The [Open Folder] button
This button opens the folder where the file was stored. You can check if it has been
loaded completely by checking for example the size.
The [Close] button
This button closes the window.

Installing PhotoFiltre
To begin the installation, it is necessary, with the explorer of Windows , to be positioned
in the file where the downloaded file was stored. You must then double-click on this file
and follow the progress of the operations.
• Open file
This Windows window is displayed, only, if you have Windows XP SP2 .

Properties of the Windows Open File window.
The [Execute] button
Use this button to continue the treatment.
The [Cancel] button
This button interrupts the execution of the installation file.
• Welcome to the installation program

Properties of the welcome window.
The software version is indicated in the title bar of the window. Please follow the
instructions for closing all other applications.
The [Next>] button
This button is used to move to the next window.
The [Cancel] button
This button interrupts the installation. A dialog box asks to confirm your choice.
• User license

Properties of the User License window.
This window indicates the terms of the PhotoFiltre license that you must follow .
The [<Previous] button
This button returns to the previous window.

The [I accept] button
This button is used to move to the next window.
The [Cancel] button
This button interrupts the installation. A dialog box asks to confirm your choice.
• Choice of the installation folder

Properties of the Select Installation Folder window.
By default, the proposed folder is [C: \ Program Files \ PhotoFiltre Studio X] for the
Studio version and [C: \ Program Files \ PhotoFiltre 7] for version 7 . Advanced users
can edit this folder using the [Browse] button.
The [<Previous] button
This button returns to the previous window.
The [Next>] button
This button is used to move to the next window.
The [Cancel] button
This button interrupts the installation. A dialog box asks to confirm your choice.
Please note the name of the installation folder as it will be used to load masks,
patterns, plugins and selections.
• Choosing the folder in the Start menu

Properties of the Select Folder window in the Start menu.
By default, the proposed folder is PhotoFiltre Studio X or PhotoFiltre 7 depending on the
installed version. Advanced users can change the name of this folder directly in the line.
The [<Previous] button
This button returns to the previous window.
The [Install] button
This button starts the installation of PhotoFiltre .
The [Cancel] button
This button interrupts the installation. A dialog box asks to confirm your choice.
• Loading installation

Properties of the Installation window in progress.
The progress bar shows the progress of the PhotoFiltre installation. At the end of the

installation, go directly to the next window.
• End of installation

Properties of the End of Installation window.
If you leave the check box [Launch PhotoFilter ...], the software will be launched
automatically by clicking the [Close] button.
The [Close] button
This button completes the installation.
The [Cancel] button
This button interrupts the installation. A dialog box asks to confirm your choice. It is not
very useful at this level.

This icon is created on the Windows desktop and allows you to quickly launch
PhotoFiltre .

Uninstall PhotoFiltre

Introduction
The uninstallation is to remove PhotoFiltre from your computer. The procedure will
delete the installation folder with the subfolders, the folder in the Start menu, the
Windows desktop icon and the registration key.
It is advisable to make a backup of the different items you have created (and
want to keep) before uninstalling. You will be able to reinstall them later.

Uninstalling PhotoFiltre
From the Windows taskbar, the uninstallation of the software can be done in two
different ways:
- Click [Start> All Programs> PhotoFilter> Uninstall PhotoFiltre]. You must adapt this
command according to the folder you selected during the installation.
- Click [Start> Control Panel], and then click [Add / Remove Programs]. Find PhotoFiltre
in the list of programs and click the [Change / Remove] button.
Whichever way you use, the uninstallation sequence is the same.

Properties of the uninstall window.
The [Uninstall] button
This button confirms the uninstall request.
The [Cancel] button
This button cancels the uninstall.
After you click the [Uninstall] button, the program starts deleting the files and folders.

Properties of the uninstallation window
The [Close] button
This button completes the uninstallation.
If you install PhotoFiltre again, you will need to re-enter your registration key.

Enter your key in PhotoFiltre

Introduction
PhotoFiltre Studio X is a shareware with a 30-day evaluation period. After the trial
period, you must acquire the software to obtain a license from the author. To do this, log
on to www.photofiltre-studio.com and go to the [License] section. Here you will find all
the information you need to acquire the license and the unlock key.
During the evaluation period, a warning window may appear when you start PhotoFiltre
Studio X to indicate the number of days remaining.
At the end of the evaluation period, and if you have not registered PhotoFiltre Studio X ,
the warning window below is displayed when PhotoFiltre Studio X starts. The toolbar, the
filter bar, and the tool palette are disabled.

Window for expiry of the evaluation period.
Clicking the [Ok] button directly displays the input window.

The input window
To display the input window, click on the [? > Registration]. If you did not get your unlock
key, you can click the [Cancel] button to return to the interface and exit the program.

Properties of the input window.
1. Enter your username in capital letters and lowercase letters. The entry must not
contain any spaces before and after the name. If these constraints are not respected, the
key will not be valid.
2. Enter the key in groups of five characters (disregard the "-" character indicated on
your license)

3. If the entry is correct, click the [OK] button that has become accessible. This action
unlocks PhotoFiltre Studio X.

Window recording the key with input error.
If the [Ok] button is not accessible, check that you have respected the
uppercase and lowercase entry at the user name.
The validity of the key is verified in the window [? > About PhotoFiltre ...].

Launching PhotoFiltre

Introduction
When installing PhotoFiltre , a shortcut is created on the Windows desktop. This allows
the standard launch of PhotoFiltre . It is possible to customize the launch using
parameters associated with the program. These settings can also be used on the MS
DOS command line.
The [-noplugins] parameter
This setting speeds up the opening of PhotoFiltre , ignoring the loading of plug-ins and
8BF filters.
The [-ini: full name of the ini file]
By default, PhotoFiltre uses the [PhotoFiltre.ini] and [PhotoFiltreDialogs.ini] files to hold
information that will be included in subsequent executions. This parameter is used to
customize these initialization files. When you first launch PhotoFiltre , the first INI file will
be created with the full name (path and file name) specified in the parameter. The
second INI file will be created automatically with the path of the first INI file and its name
(without the extension) followed by Dialogs.ini . These files will be taken again for the
following executions. This allows, for example, multiple users to each have their own
working environment or multiple [Automation] command launches with different
processing, and so on.
The [-localini] parameter
This setting is primarily for Network PhotoFiltre installations. Very often, installation
folders are protected and users can not change their working environment. By adding
this parameter, PhotoFiltre places the initialization file in the Windows folder associated
with the user.
For networked installations, it is recommended to use the [-localini] parameter
instead of the [-ini: full name of the ini file].

Creating a custom shortcut
You can insert the settings described above into the shortcut created when installing
PhotoFiltre , but it is recommended that you create a new shortcut.
Creating a shortcut from the Windows desktop
Start by right-clicking on the Windows desktop and in the pop-up menu that appears
choose [New> Shortcut].

Shortcut Creation Properties
In the input box:
1. Enter the location of the program using the [Browse] button. In case of standard
installation of PhotoFiltre , we obtain the following path:
["C: \ Program Files \ PhotoFiltre Studio X \ pfstudiox.exe"]
Note the presence of quotation marks around the path, which are required when paths
and file names contain spaces.
2. At the end of the program location, you must manually add the parameters you want
to use. Each will be separated by a space. We must obtain an order of this type:
["C: \ Program Files \ PhotoFiltre Studio X \ pfstudiox.exe" -noplugins "-ini: C: \ Program
Files \ PhotoFiltre Studio X \ JCB.ini"].
Here you also have to enclose the [-ini:] parameter in quotation marks, because the path
has spaces. In this example, PhotoFiltre will be opened with custom boot files, without
the plug-ins and without the 8BF filters. Automatically, the second INI file created will be
named C: \ Program Files \ PhotoFiltre Studio X \ JCBDialogs.ini
Missing syntax (missing quotes, missing space between parameters, error in
parameter names or paths, etc.) can cause error messages when PhotoFiltre is
started and settings may be ignored .
3. Click the [Next] button and give your shortcut a name.

Title Selection Properties for the Program

