Chinese/Japanese text issue

Bug, suggestion, ça se passe par ici !
Ne concerne que ce qui touche au logiciel en lui même.

Modérateur : Modérateurs

Règles du forum
:idea: Forum d'aide au fonctionnement de PhotoFiltre et de PhotoFiltre Studio.
:idea: Merci de consulter la documentation de PF Studio, et de lire cette information, pour vous orienter.
Si vous êtes débutant, voir Comment me lancer. Votre question a peut-être déjà sa réponse.
livio.franze
Nouveau(elle)|Nouveau|Nouvelle
Nouveau(elle)|Nouveau|Nouvelle
Messages : 2
Inscription : 12 janv. 2023 17:37
Version de PhotoFiltre : 11.4.1
Système d'exploitation : Windows 11
Processeur : i7-10510U
Mémoire RAM : 16 GB

Chinese/Japanese text issue

Message par livio.franze »

Hi, i have a problem with Chinese/Japanese text. When I enter text using Chinese or Japanese characters, everything looks normal, but if i save the project to a file (using the *.pfi extension), close and reopen it from the file, Chinese or Japanese characters are lost (they are replaced by question marks)

Is it a bug? Is there a workaround?

Using PhotoFiltre 11.4.1

Thank you
Antonio
Administrateur(trice)|Administrateur|Administratrice
Administrateur(trice)|Administrateur|Administratrice
Messages : 12681
Inscription : 28 oct. 2003 22:49
Contact :

Re: Chinese/Japanese text issue

Message par Antonio »

PF11 is unicode but for the moment pfi format is not unicode and text is converted to ansi to be compatible with the studio X version.

Before saving, convert the text layer to bitmap layer (menu layer). But the size is bigger and the text will be static (not a good solution but only this methode works)
livio.franze
Nouveau(elle)|Nouveau|Nouvelle
Nouveau(elle)|Nouveau|Nouvelle
Messages : 2
Inscription : 12 janv. 2023 17:37
Version de PhotoFiltre : 11.4.1
Système d'exploitation : Windows 11
Processeur : i7-10510U
Mémoire RAM : 16 GB

Re: Chinese/Japanese text issue

Message par livio.franze »

thanks, hope it will be fixed in the future
Répondre